aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
commit29747f458a1eb2ce23b4594b09d0256dd62760b8 (patch)
tree1b71ba5d9ffdd308b6c18130f7c116f5bab5dc12 /math
parent7aad84f808b93baa6a7077ce0b47573b9c4c79a0 (diff)
downloadports-29747f458a1eb2ce23b4594b09d0256dd62760b8.tar.gz
ports-29747f458a1eb2ce23b4594b09d0256dd62760b8.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/gdcalc/Makefile6
-rw-r--r--math/gdcalc/pkg-plist3
-rw-r--r--math/geg/Makefile4
-rw-r--r--math/guppi/Makefile6
-rw-r--r--math/guppi/pkg-plist14
5 files changed, 22 insertions, 11 deletions
diff --git a/math/gdcalc/Makefile b/math/gdcalc/Makefile
index 09c74143c228..d254234727c7 100644
--- a/math/gdcalc/Makefile
+++ b/math/gdcalc/Makefile
@@ -3,11 +3,11 @@
# Whom: Jan Srocker <Jan.Stocker@t-online.de>
#
# $FreeBSD$
-#
+# $MCom: ports/math/gdcalc/Makefile,v 1.1 2006/10/04 15:51:37 ahze Exp $
PORTNAME= gdcalc
PORTVERSION= 2.13
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= http://bhepple.freeshell.org/dcalc/unix/
@@ -16,7 +16,7 @@ COMMENT= Gnome-based scientific calculator
RUN_DEPENDS= ${LOCALBASE}/bin/gunits:${PORTSDIR}/math/units
-USE_GNOME= gnomelibs
+USE_GNOME= gnomelibs gnomehier
GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/math/gdcalc/pkg-plist b/math/gdcalc/pkg-plist
index 55382829322e..adb73b1fd539 100644
--- a/math/gdcalc/pkg-plist
+++ b/math/gdcalc/pkg-plist
@@ -7,8 +7,5 @@ share/pixmaps/HP-16C-48.xpm
share/pixmaps/mini-HP-16C-48.xpm
@dirrmtry share/pixmaps
@dirrmtry share/icons
-@dirrmtry share/gnome/apps/Utilities
-@dirrmtry share/gnome/apps
-@dirrmtry share/gnome/
@dirrmtry share/applnk/Applications
@dirrmtry share/applnk
diff --git a/math/geg/Makefile b/math/geg/Makefile
index 9661cc5e03c4..43b85248505a 100644
--- a/math/geg/Makefile
+++ b/math/geg/Makefile
@@ -18,7 +18,7 @@ COMMENT= Visualise multiple 2D-functions of one variable
USE_X_PREFIX= yes
USE_GNOME= gtk12
-USE_AUTOTOOLS= automake:14 autoconf:213
+USE_AUTOTOOLS= automake:15 autoconf:253
AUTOMAKE_ARGS= -a -i
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
@@ -27,6 +27,6 @@ MAN1= geg.1
PLIST_FILES= bin/geg
pre-configure:
- @cd ${WRKSRC}; ${ACLOCAL} -I ${X11BASE}/share/aclocal
+ @cd ${WRKSRC}; ${ACLOCAL} -I ${LOCALBASE}/share/aclocal -I ${X11BASE}/share/aclocal
.include <bsd.port.mk>
diff --git a/math/guppi/Makefile b/math/guppi/Makefile
index 473550df3365..9c6a59c39562 100644
--- a/math/guppi/Makefile
+++ b/math/guppi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= guppi
PORTVERSION= 0.40.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/Guppi/0.40
@@ -20,14 +20,14 @@ LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
USE_GETTEXT= yes
USE_BZIP2= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs bonobo libglade gal gnometarget
USE_PYTHON= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gnumeric --enable-explicit-python-linking
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include/libglade-1.0" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/libglade-1.0" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
GNUMERIC_IDLDIR="${WRKDIR}/gnumeric"
PLIST_SUB= VERSION="${PORTVERSION}"
diff --git a/math/guppi/pkg-plist b/math/guppi/pkg-plist
index a69ce37d6014..266ca186aa74 100644
--- a/math/guppi/pkg-plist
+++ b/math/guppi/pkg-plist
@@ -309,3 +309,17 @@ share/locale/zh_CN/LC_MESSAGES/Guppi.mo
@dirrm lib/guppi
@dirrm include/gnome-1.0/libguppitank
@dirrm include/gnome-1.0/libguppi
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/no/LC_MESSAGES
+@dirrmtry share/locale/no
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el