aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>1998-05-07 06:08:25 +0000
committerMatthew Hunt <mph@FreeBSD.org>1998-05-07 06:08:25 +0000
commit36e4ff9e75efc95becabcb02d5936639da324eb1 (patch)
treeb9742e8ee5e1e757bbfe4c3f71b167700b5fb3a2 /math
parent671e0c516e42f1f6a87952d2b4a21a666d7babdd (diff)
downloadports-36e4ff9e75efc95becabcb02d5936639da324eb1.tar.gz
ports-36e4ff9e75efc95becabcb02d5936639da324eb1.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/R-letter/Makefile6
-rw-r--r--math/R-letter/files/R2
-rw-r--r--math/R-project/Makefile6
-rw-r--r--math/R-project/files/R2
-rw-r--r--math/R/Makefile6
-rw-r--r--math/R/files/R2
6 files changed, 12 insertions, 12 deletions
diff --git a/math/R-letter/Makefile b/math/R-letter/Makefile
index ac1cd756e4ed..186721deb622 100644
--- a/math/R-letter/Makefile
+++ b/math/R-letter/Makefile
@@ -3,11 +3,11 @@
# Date created: Mon May 4 10:03:02 EST 1998
# Whom: Maurice Castro <maurice@serc.rmit.edu.au>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/05/04 17:53:34 mph Exp $
#
DISTNAME= R-0.61.2
-PKGNAME= r-${PAPERSIZE:S/A4/a4/:S/LETTER/letter/:S/Letter/letter/}-0.61.2
+PKGNAME= R-${PAPERSIZE:S/A4/a4/:S/LETTER/letter/:S/Letter/letter/}-0.61.2
CATEGORIES= math
MASTER_SITES= http://lib.stat.cmu.edu/R/CRAN/src/base/ \
ftp://ftp.stat.math.ethz.ch/R/ \
@@ -43,7 +43,7 @@ post-configure:
cd ${WRKSRC}/etc; && ${PREFIX}/bin/perl -pi -e "s#/usr/bin/perl#${PREFIX}/bin/perl#" `grep -l /usr/bin/perl *`
do-install:
- ${SED} 's:PREFIX:${PREFIX}:' ${FILESDIR}/R > ${PREFIX}/bin/R
+ ${SED} 's:PREFIX:${PREFIX}:;s:DEFAULTPAPER:${PAPERSIZE}:' ${FILESDIR}/R > ${PREFIX}/bin/R
(cd ${WRKSRC}; find . -type d -exec chmod a+rx \{\} \; )
(cd ${WRKSRC}; find . -type f -exec chmod a+r \{\} \; )
chmod a+x ${PREFIX}/bin/R
diff --git a/math/R-letter/files/R b/math/R-letter/files/R
index 493f41b35183..fdb58232ac6a 100644
--- a/math/R-letter/files/R
+++ b/math/R-letter/files/R
@@ -51,7 +51,7 @@ fi
# R_PAPERSIZE="a4"
# R_PAPERSIZE="letter"
# R_PAPERSIZE="none"
-R_PAPERSIZE=a4
+R_PAPERSIZE=DEFAULTPAPER
export R_PAPERSIZE
# Default Print Command
diff --git a/math/R-project/Makefile b/math/R-project/Makefile
index ac1cd756e4ed..186721deb622 100644
--- a/math/R-project/Makefile
+++ b/math/R-project/Makefile
@@ -3,11 +3,11 @@
# Date created: Mon May 4 10:03:02 EST 1998
# Whom: Maurice Castro <maurice@serc.rmit.edu.au>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/05/04 17:53:34 mph Exp $
#
DISTNAME= R-0.61.2
-PKGNAME= r-${PAPERSIZE:S/A4/a4/:S/LETTER/letter/:S/Letter/letter/}-0.61.2
+PKGNAME= R-${PAPERSIZE:S/A4/a4/:S/LETTER/letter/:S/Letter/letter/}-0.61.2
CATEGORIES= math
MASTER_SITES= http://lib.stat.cmu.edu/R/CRAN/src/base/ \
ftp://ftp.stat.math.ethz.ch/R/ \
@@ -43,7 +43,7 @@ post-configure:
cd ${WRKSRC}/etc; && ${PREFIX}/bin/perl -pi -e "s#/usr/bin/perl#${PREFIX}/bin/perl#" `grep -l /usr/bin/perl *`
do-install:
- ${SED} 's:PREFIX:${PREFIX}:' ${FILESDIR}/R > ${PREFIX}/bin/R
+ ${SED} 's:PREFIX:${PREFIX}:;s:DEFAULTPAPER:${PAPERSIZE}:' ${FILESDIR}/R > ${PREFIX}/bin/R
(cd ${WRKSRC}; find . -type d -exec chmod a+rx \{\} \; )
(cd ${WRKSRC}; find . -type f -exec chmod a+r \{\} \; )
chmod a+x ${PREFIX}/bin/R
diff --git a/math/R-project/files/R b/math/R-project/files/R
index 493f41b35183..fdb58232ac6a 100644
--- a/math/R-project/files/R
+++ b/math/R-project/files/R
@@ -51,7 +51,7 @@ fi
# R_PAPERSIZE="a4"
# R_PAPERSIZE="letter"
# R_PAPERSIZE="none"
-R_PAPERSIZE=a4
+R_PAPERSIZE=DEFAULTPAPER
export R_PAPERSIZE
# Default Print Command
diff --git a/math/R/Makefile b/math/R/Makefile
index ac1cd756e4ed..186721deb622 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -3,11 +3,11 @@
# Date created: Mon May 4 10:03:02 EST 1998
# Whom: Maurice Castro <maurice@serc.rmit.edu.au>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/05/04 17:53:34 mph Exp $
#
DISTNAME= R-0.61.2
-PKGNAME= r-${PAPERSIZE:S/A4/a4/:S/LETTER/letter/:S/Letter/letter/}-0.61.2
+PKGNAME= R-${PAPERSIZE:S/A4/a4/:S/LETTER/letter/:S/Letter/letter/}-0.61.2
CATEGORIES= math
MASTER_SITES= http://lib.stat.cmu.edu/R/CRAN/src/base/ \
ftp://ftp.stat.math.ethz.ch/R/ \
@@ -43,7 +43,7 @@ post-configure:
cd ${WRKSRC}/etc; && ${PREFIX}/bin/perl -pi -e "s#/usr/bin/perl#${PREFIX}/bin/perl#" `grep -l /usr/bin/perl *`
do-install:
- ${SED} 's:PREFIX:${PREFIX}:' ${FILESDIR}/R > ${PREFIX}/bin/R
+ ${SED} 's:PREFIX:${PREFIX}:;s:DEFAULTPAPER:${PAPERSIZE}:' ${FILESDIR}/R > ${PREFIX}/bin/R
(cd ${WRKSRC}; find . -type d -exec chmod a+rx \{\} \; )
(cd ${WRKSRC}; find . -type f -exec chmod a+r \{\} \; )
chmod a+x ${PREFIX}/bin/R
diff --git a/math/R/files/R b/math/R/files/R
index 493f41b35183..fdb58232ac6a 100644
--- a/math/R/files/R
+++ b/math/R/files/R
@@ -51,7 +51,7 @@ fi
# R_PAPERSIZE="a4"
# R_PAPERSIZE="letter"
# R_PAPERSIZE="none"
-R_PAPERSIZE=a4
+R_PAPERSIZE=DEFAULTPAPER
export R_PAPERSIZE
# Default Print Command