aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-10-28 09:49:51 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-10-28 09:49:51 +0000
commit41e0ceb43c8ed56ceaa370c7a5ad102ae2dda8f7 (patch)
tree4ee511fd1cc04c17f805aea240df3c1835c1ec3e /math
parentd4d87f21368277439d519b13637dc668fc4054ff (diff)
downloadports-41e0ceb43c8ed56ceaa370c7a5ad102ae2dda8f7.tar.gz
ports-41e0ceb43c8ed56ceaa370c7a5ad102ae2dda8f7.zip
Unbreak on powerpc64.
PR: 231722 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=483254
Diffstat (limited to 'math')
-rw-r--r--math/gringo/Makefile4
-rw-r--r--math/gringo/files/patch-libgringo_src_term.cc10
2 files changed, 11 insertions, 3 deletions
diff --git a/math/gringo/Makefile b/math/gringo/Makefile
index d03384dd4a75..5600c69c3638 100644
--- a/math/gringo/Makefile
+++ b/math/gringo/Makefile
@@ -3,8 +3,8 @@
PORTNAME= gringo
DISTVERSION= 4.5.4
-PORTREVISION= 1
DISTVERSIONSUFFIX= -source
+PORTREVISION= 1
CATEGORIES= math devel
MASTER_SITES= SOURCEFORGE/potassco/${PORTNAME}/${PORTVERSION}
@@ -16,8 +16,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= re2c:devel/re2c
-BROKEN_powerpc64= fails to compile: term.cc: error: pow is not a member of std
-
USES= bison compiler:c++11-lib python:2.7 scons
MAKE_ARGS= ${MAKE_ENV}
CXXFLAGS+= -std=c++11
diff --git a/math/gringo/files/patch-libgringo_src_term.cc b/math/gringo/files/patch-libgringo_src_term.cc
new file mode 100644
index 000000000000..eb0e5fcaf30a
--- /dev/null
+++ b/math/gringo/files/patch-libgringo_src_term.cc
@@ -0,0 +1,10 @@
+--- libgringo/src/term.cc.orig 2018-09-25 16:02:56 UTC
++++ libgringo/src/term.cc
+@@ -21,6 +21,7 @@
+ #include "gringo/term.hh"
+ #include "gringo/logger.hh"
+ #include "gringo/graph.hh"
++#include <cmath>
+
+ namespace Gringo {
+