aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2018-10-30 01:20:14 +0000
committerWen Heping <wen@FreeBSD.org>2018-10-30 01:20:14 +0000
commit4c597b950173de34f5a0a5eb8b0fac1e848c3586 (patch)
tree8e78207b3d3ff23483e2e5b42252342d12f765ae /math
parentea89c48b992c0fe84dacb69c982874a53e0663da (diff)
downloadports-4c597b950173de34f5a0a5eb8b0fac1e848c3586.tar.gz
ports-4c597b950173de34f5a0a5eb8b0fac1e848c3586.zip
- Update to 2018.07.03
Notes
Notes: svn path=/head/; revision=483440
Diffstat (limited to 'math')
-rw-r--r--math/fxt/Makefile6
-rw-r--r--math/fxt/distinfo6
-rw-r--r--math/fxt/pkg-plist42
3 files changed, 36 insertions, 18 deletions
diff --git a/math/fxt/Makefile b/math/fxt/Makefile
index 31e2d0dedec5..b23903c1b618 100644
--- a/math/fxt/Makefile
+++ b/math/fxt/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= fxt
-DISTVERSION= 2017.07.25
+DISTVERSION= 2018.07.03
CATEGORIES= math
MASTER_SITES= http://www.jjj.de/fxt/
@@ -12,9 +12,11 @@ COMMENT= FFT code and related stuff
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING.txt
+BROKEN_FreeBSD_10= Fails to build
+
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= gmake tar:tgz
+USES= gmake compiler:c++11-lib
MAKE_ENV= FXT_INSTALL="${INSTALL_DATA}"
MAKEFILE= makefile
diff --git a/math/fxt/distinfo b/math/fxt/distinfo
index 1739a89b30a8..212e37bc5da7 100644
--- a/math/fxt/distinfo
+++ b/math/fxt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1501116181
-SHA256 (fxt-2017.07.25.tgz) = 15e83cf64efac36a4ddc1bcc3fe099b1b69f88f2b4d37234176eaa8b2d2cd090
-SIZE (fxt-2017.07.25.tgz) = 1837717
+TIMESTAMP = 1540860507
+SHA256 (fxt-2018.07.03.tar.gz) = 0ef8c49d30612388382f85a38b1e94e82eb7f8954b0f0dc0a3e2e8d8464aa6aa
+SIZE (fxt-2018.07.03.tar.gz) = 1851742
diff --git a/math/fxt/pkg-plist b/math/fxt/pkg-plist
index d37d39d24e8e..02207cd47c9c 100644
--- a/math/fxt/pkg-plist
+++ b/math/fxt/pkg-plist
@@ -3,7 +3,6 @@ include/fxt/aux0-all.h
include/fxt/aux0/binomial.h
include/fxt/aux0/cayley-dickson-mult.h
include/fxt/aux0/cmult.h
-include/fxt/aux0/constants.h
include/fxt/aux0/csincos.h
include/fxt/aux0/factorial.h
include/fxt/aux0/fibonacci.h
@@ -13,24 +12,18 @@ include/fxt/aux0/ldn2rc.h
include/fxt/aux0/print-fixed.h
include/fxt/aux0/rand-idx.h
include/fxt/aux0/randf.h
-include/fxt/aux0/range.h
-include/fxt/aux0/sign.h
include/fxt/aux0/sincos.h
include/fxt/aux0/sumdiff.h
include/fxt/aux0/swap.h
include/fxt/aux0/tex-line.h
-include/fxt/aux0/trigrec.h
include/fxt/aux0/version.h
include/fxt/aux1-all.h
include/fxt/aux1/arith1.h
include/fxt/aux1/bytescan.h
include/fxt/aux1/copy.h
-include/fxt/aux1/norm.h
include/fxt/aux1/num2str.h
-include/fxt/aux1/shift.h
include/fxt/aux1/wordgray.h
include/fxt/aux2-all.h
-include/fxt/aux2/copy2d.h
include/fxt/aux2/transpose.h
include/fxt/aux2/transpose2.h
include/fxt/bits-all.h
@@ -238,6 +231,7 @@ include/fxt/comb/composition-nz.h
include/fxt/comb/composition-rank.h
include/fxt/comb/composition-unimodal.h
include/fxt/comb/cyclic-perm.h
+include/fxt/comb/cyclic-words.h
include/fxt/comb/debruijn.h
include/fxt/comb/delta2gray.h
include/fxt/comb/descent-rgs.h
@@ -299,6 +293,9 @@ include/fxt/comb/ksubset-lex.h
include/fxt/comb/ksubset-rec.h
include/fxt/comb/ksubset-twoclose.h
include/fxt/comb/lex-compare.h
+include/fxt/comb/lindenmayer-system.h
+include/fxt/comb/lyndon-factorization.h
+include/fxt/comb/lyndon-words.h
include/fxt/comb/map23-rgs.h
include/fxt/comb/mixedradix-colex.h
include/fxt/comb/mixedradix-endo-gray.h
@@ -329,6 +326,7 @@ include/fxt/comb/motzkin-rgs-lex.h
include/fxt/comb/motzkin-step-rgs-lex.h
include/fxt/comb/mpartition.h
include/fxt/comb/mpartition2.h
+include/fxt/comb/mset-kperm-lex.h
include/fxt/comb/mset-perm-gray.h
include/fxt/comb/mset-perm-lex-rec.h
include/fxt/comb/mset-perm-lex.h
@@ -443,7 +441,7 @@ include/fxt/comb/setpart.h
include/fxt/comb/skew-binary.h
include/fxt/comb/sl-gray-compare.h
include/fxt/comb/smooth-rfact-rgs.h
-include/fxt/comb/stringsubst.h
+include/fxt/comb/string-subst.h
include/fxt/comb/subset-debruijn.h
include/fxt/comb/subset-deltalex.h
include/fxt/comb/subset-gray-delta.h
@@ -479,14 +477,23 @@ include/fxt/dctdst-all.h
include/fxt/dctdst/dctdst.h
include/fxt/ds-all.h
include/fxt/ds/array2d.h
+include/fxt/ds/array3d.h
include/fxt/ds/bitarray.h
+include/fxt/ds/bitarray2d.h
+include/fxt/ds/bounding-box.h
+include/fxt/ds/centered-array2d.h
+include/fxt/ds/centered-array3d.h
include/fxt/ds/deque.h
include/fxt/ds/heap.h
include/fxt/ds/left-right-array.h
+include/fxt/ds/point2d.h
+include/fxt/ds/point3d.h
include/fxt/ds/priorityqueue.h
include/fxt/ds/queue.h
include/fxt/ds/ringbuffer.h
include/fxt/ds/stack.h
+include/fxt/ds/vector2d.h
+include/fxt/ds/vector3d.h
include/fxt/fft-all.h
include/fxt/fft/fft-default.h
include/fxt/fft/fft.h
@@ -523,7 +530,6 @@ include/fxt/haar/transposedhaarrevnn.h
include/fxt/jjassert.h
include/fxt/matrix-all.h
include/fxt/matrix/matrix.h
-include/fxt/matrix/mmult.h
include/fxt/matrix/vector.h
include/fxt/mod-all.h
include/fxt/mod/chebyshev.h
@@ -1075,6 +1081,10 @@ lib/libfxt.a
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/ksubset-rec-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/ksubset-twoclose-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/ksubset-twoclose-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/lyndon-factorization-demo.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/lyndon-factorization-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/lyndon-words-demo.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/lyndon-words-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/map23-rgs-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/map23-rgs-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/maxrep-gray-demo.cc
@@ -1137,6 +1147,8 @@ lib/libfxt.a
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/mpartition-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/mpartition2-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/mpartition2-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/mset-kperm-lex-demo.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/mset-kperm-lex-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/mset-ksubset-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/mset-ksubset-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/mset-perm-gray-demo.cc
@@ -1403,14 +1415,14 @@ lib/libfxt.a
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/skew-binary-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/smooth-rfact-rgs-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/smooth-rfact-rgs-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/string-subst-demo.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/string-subst-hilbert3d-demo.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/string-subst-hilbert3d-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/string-subst-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/stirling1-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/stirling1-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/stirling2-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/stirling2-out.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/stringsubst-demo.cc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/stringsubst-hilbert3d-demo.cc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/stringsubst-hilbert3d-out.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/stringsubst-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/subset-debruijn-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/subset-debruijn-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/subset-deltalex-demo.cc
@@ -1435,6 +1447,8 @@ lib/libfxt.a
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comb/young-tab-rgs-subset-lex-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ds/bitarray-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ds/bitarray-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ds/bitarray2d-demo.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ds/bitarray2d-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ds/deque-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ds/deque-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ds/left-right-array-demo.cc
@@ -1669,6 +1683,8 @@ lib/libfxt.a
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/seq/A186053-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/seq/A187081-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/seq/A187081-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/seq/A191755-demo.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/seq/A191755-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/seq/A206464-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/seq/A206464-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/seq/A206702-demo.cc