aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-01-02 16:49:24 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-01-02 16:49:24 +0000
commit51d04637cb2aa7e77e78d6b7de91125251405083 (patch)
treefefd75a0b797bfd5f2fbecc832b9a94f740ee983 /math
parenta3cc859109302e74945b2f3684edfd3e5c434fdc (diff)
Notes
Diffstat (limited to 'math')
-rw-r--r--math/ceres-solver/Makefile3
-rw-r--r--math/cgal/Makefile5
-rw-r--r--math/libmesh/Makefile3
3 files changed, 4 insertions, 7 deletions
diff --git a/math/ceres-solver/Makefile b/math/ceres-solver/Makefile
index 9c8909e64d17..69197b21c7e1 100644
--- a/math/ceres-solver/Makefile
+++ b/math/ceres-solver/Makefile
@@ -14,11 +14,10 @@ COMMENT= Nonlinear least squares minimizer
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= eigen>=3.2.2:math/eigen3
LIB_DEPENDS= libglog.so:devel/glog
RUN_DEPENDS:= ${BUILD_DEPENDS:Meigen*}
-USES= cmake:outsource compiler:${OPENMP}c++11-lib localbase shebangfix
+USES= cmake:outsource compiler:${OPENMP}c++11-lib eigen:3 localbase shebangfix
USE_GITHUB= yes
USE_LDCONFIG= yes
SHEBANG_FILES= examples/slam/pose_graph_*/plot_results.py \
diff --git a/math/cgal/Makefile b/math/cgal/Makefile
index b81bd341b65c..a5f7b56e1d71 100644
--- a/math/cgal/Makefile
+++ b/math/cgal/Makefile
@@ -16,8 +16,7 @@ LICENSE_COMB= multi
BROKEN_sparc64= does not build: fails to compile all_files.cpp
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen3.pc:math/eigen3 \
- ${LOCALBASE}/lib/libntl.a:math/ntl
+BUILD_DEPENDS= ${LOCALBASE}/lib/libntl.a:math/ntl
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libmpfr.so:math/mpfr \
libgmp.so:math/gmp
@@ -25,7 +24,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
#TODO math/mpfi, math/rs, graphics/qglviewer
#Not yet in ports
-USES= cmake shebangfix tar:xz
+USES= cmake eigen:3 shebangfix tar:xz
USE_LDCONFIG= yes
SHEBANG_FILES= scripts/cgal_create_CMakeLists \
scripts/cgal_create_cmake_script
diff --git a/math/libmesh/Makefile b/math/libmesh/Makefile
index 5ccc8aad4759..a022063d65a6 100644
--- a/math/libmesh/Makefile
+++ b/math/libmesh/Makefile
@@ -12,10 +12,9 @@ COMMENT= Numerical simulation of partial differential equations
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= eigen>0:math/eigen3
LIB_DEPENDS= libboost_system.so:devel/boost-libs
-USES= autoreconf gmake libtool
+USES= autoreconf eigen:3 gmake libtool
GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= libMesh