aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-20 18:36:24 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-20 18:36:24 +0000
commit727a9693d42943be20371f133d0e377fa9ddb8d3 (patch)
tree36a173650ebabc8f72926ad4c538dc5409d11f45 /math
parentd761cbf4d5df3936fe49bda41f2d0afce425452f (diff)
downloadports-727a9693d42943be20371f133d0e377fa9ddb8d3.tar.gz
ports-727a9693d42943be20371f133d0e377fa9ddb8d3.zip
New port: math/gau2grid: Fast computation of a gaussian and its derivative on a grid
Notes
Notes: svn path=/head/; revision=482614
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/gau2grid/Makefile24
-rw-r--r--math/gau2grid/distinfo3
-rw-r--r--math/gau2grid/pkg-descr7
-rw-r--r--math/gau2grid/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index bbe06bbfd024..6faa991d3c48 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -216,6 +216,7 @@
SUBDIR += galculator
SUBDIR += gambit
SUBDIR += gap
+ SUBDIR += gau2grid
SUBDIR += gdcalc
SUBDIR += geg
SUBDIR += geogebra
diff --git a/math/gau2grid/Makefile b/math/gau2grid/Makefile
new file mode 100644
index 000000000000..68cf5e052918
--- /dev/null
+++ b/math/gau2grid/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= gau2grid
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2.0
+CATEGORIES= math python
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Fast computation of a gaussian and its derivative on a grid
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON= BUG: ValueError: descr is not a valid dtype descriptor: '<f16' (see https://github.com/dgasmith/gau2grid/issues/25)
+
+BUILD_DEPENDS= ${PYNUMPY}
+
+USES= cmake:outsource python:build # C code build depends on python to generate some headers
+USE_GITHUB= yes
+GH_ACCOUNT= dgasmith
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/math/gau2grid/distinfo b/math/gau2grid/distinfo
new file mode 100644
index 000000000000..189a7918ed6e
--- /dev/null
+++ b/math/gau2grid/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1538885352
+SHA256 (dgasmith-gau2grid-v1.2.0_GH0.tar.gz) = 5c0312256c794d17c806bafa4a755489d21d3985e44a4429e865b51e67666b9c
+SIZE (dgasmith-gau2grid-v1.2.0_GH0.tar.gz) = 124928
diff --git a/math/gau2grid/pkg-descr b/math/gau2grid/pkg-descr
new file mode 100644
index 000000000000..2a8fcb58b544
--- /dev/null
+++ b/math/gau2grid/pkg-descr
@@ -0,0 +1,7 @@
+gau2grid is a python-generated C library for vectorized computation of grid to
+gaussian collocation matrices
+
+The core of gau2grid is generating the collocation matrices between a real space
+grid and a gaussian basis set expanded to a given angular momenta.
+
+WWW: https://github.com/dgasmith/gau2grid
diff --git a/math/gau2grid/pkg-plist b/math/gau2grid/pkg-plist
new file mode 100644
index 000000000000..09eb11dd4f0a
--- /dev/null
+++ b/math/gau2grid/pkg-plist
@@ -0,0 +1,7 @@
+include/gau2grid/gau2grid.h
+include/gau2grid/gau2grid_pragma.h
+lib/libgg.so
+share/cmake/gau2grid/gau2gridConfig.cmake
+share/cmake/gau2grid/gau2gridConfigVersion.cmake
+share/cmake/gau2grid/gau2gridTargets-%%CMAKE_BUILD_TYPE%%.cmake
+share/cmake/gau2grid/gau2gridTargets.cmake