aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2012-02-04 14:37:52 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2012-02-04 14:37:52 +0000
commit85803ea146d051ccfb19bae5a199c43afe6fcbda (patch)
treeef0a7ad7305e124e4c573c515181c699ed450526 /math
parent65a4e2ef3cb2773a4dd234a2bc66d544f26cbbd2 (diff)
downloadports-85803ea146d051ccfb19bae5a199c43afe6fcbda.tar.gz
ports-85803ea146d051ccfb19bae5a199c43afe6fcbda.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/cvc3/Makefile18
-rw-r--r--math/cvc3/distinfo4
-rw-r--r--math/cvc3/pkg-plist6
3 files changed, 21 insertions, 7 deletions
diff --git a/math/cvc3/Makefile b/math/cvc3/Makefile
index 8176ab5eac3b..5983d9972d4f 100644
--- a/math/cvc3/Makefile
+++ b/math/cvc3/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= cvc3
-PORTVERSION= 1.2.1
-PORTREVISION= 3
+PORTVERSION= 2.4.1
CATEGORIES= math
-MASTER_SITES= http://www.cs.nyu.edu/acsys/cvc3/download/${PORTVERSION}/ \
- http://www.cs.nctu.edu.tw/~lwhsu/ports/distfiles/
+MASTER_SITES= http://www.cs.nyu.edu/acsys/cvc3/download/${PORTVERSION}/
MAINTAINER= lwhsu@FreeBSD.org
COMMENT= An automatic theorem prover for the SMT problem
@@ -29,4 +27,14 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
USE_PERL5= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,/bin/bash,/bin/sh,' ${WRKSRC}/Makefile.std
+ ${REINPLACE_CMD} -e 's,.*$$(LDCONFIG).*,,' ${WRKSRC}/src/Makefile
+ ${REINPLACE_CMD} -e 's,$$(libdir)/pkgconfig,${PREFIX}/libdata/pkgconfig,' ${WRKSRC}/src/Makefile
+
+post-install:
+ ${INSTALL_PROGRAM} `readlink ${WRKSRC}/bin/cvc3` ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/math/cvc3/distinfo b/math/cvc3/distinfo
index 15179ba0c438..a28de6748653 100644
--- a/math/cvc3/distinfo
+++ b/math/cvc3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cvc3-1.2.1.tar.gz) = e2100454606c649a2de59dd9fe3300fe3a7ecc4ac03c1d304c8f797aaed34bd9
-SIZE (cvc3-1.2.1.tar.gz) = 827577
+SHA256 (cvc3-2.4.1.tar.gz) = d55b1d6006cfbac3f6d4c086964558902c3ed0efa66ac499cfb2193f3ee4acf7
+SIZE (cvc3-2.4.1.tar.gz) = 1196616
diff --git a/math/cvc3/pkg-plist b/math/cvc3/pkg-plist
index 528151be4b7a..eaa858dba45c 100644
--- a/math/cvc3/pkg-plist
+++ b/math/cvc3/pkg-plist
@@ -33,6 +33,7 @@ include/cvc3/expr_stream.h
include/cvc3/expr_transform.h
include/cvc3/expr_value.h
include/cvc3/fdstream.h
+include/cvc3/formula_value.h
include/cvc3/hash_fun.h
include/cvc3/hash_map.h
include/cvc3/hash_set.h
@@ -66,6 +67,7 @@ include/cvc3/theorem_manager.h
include/cvc3/theorem_producer.h
include/cvc3/theory.h
include/cvc3/theory_arith.h
+include/cvc3/theory_arith3.h
include/cvc3/theory_arith_new.h
include/cvc3/theory_arith_old.h
include/cvc3/theory_array.h
@@ -85,4 +87,8 @@ include/cvc3/vc.h
include/cvc3/vc_cmd.h
include/cvc3/vcl.h
lib/libcvc3.so
+lib/libcvc3.so.5
+lib/libcvc3.so.5.0
+lib/libcvc3.so.5.0.0
+libdata/pkgconfig/cvc3.pc
@dirrm include/cvc3