aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2007-06-29 05:46:43 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2007-06-29 05:46:43 +0000
commitb9ba1ad61ec8ac4f754fdbd3e762691564d11838 (patch)
treee643e74666458bfc6f67e70b390fbf4594583163 /math
parent59d5387029bc0989baa5684776c438795412513b (diff)
downloadports-b9ba1ad61ec8ac4f754fdbd3e762691564d11838.tar.gz
ports-b9ba1ad61ec8ac4f754fdbd3e762691564d11838.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/PDL/Makefile4
-rw-r--r--math/asymptote/Makefile4
-rw-r--r--math/freefem++/Makefile3
-rw-r--r--math/labplot/Makefile4
-rw-r--r--math/msieve/Makefile3
-rw-r--r--math/orpie/Makefile4
-rw-r--r--math/p5-Math-GSL/Makefile4
-rw-r--r--math/py-gsl/Makefile4
-rw-r--r--math/qtiplot/Makefile3
-rw-r--r--math/ruby-gsl/Makefile3
-rw-r--r--math/yacas/Makefile3
11 files changed, 22 insertions, 17 deletions
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
index eedcf7b5bc0c..f555d742edaa 100644
--- a/math/PDL/Makefile
+++ b/math/PDL/Makefile
@@ -8,7 +8,7 @@
PORTNAME= PDL
PORTVERSION= 2.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:S/$/:cpan/} \
${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
@@ -28,7 +28,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl \
${SITE_PERL}/Term/ReadLine/readline.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
LIB_DEPENDS= plplotd.11:${PORTSDIR}/math/plplot \
fftw.2:${PORTSDIR}/math/fftw \
- gsl.9:${PORTSDIR}/math/gsl
+ gsl.10:${PORTSDIR}/math/gsl
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GL= yes
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index c24db903b104..47308d04a6a5 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asymptote
PORTVERSION= 1.25
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -46,7 +46,7 @@ ALL_TARGET= asy
INSTALL_TARGET= install-asy
.if defined(WITH_GSL)
-LIB_DEPENDS+= gsl.9:${PORTSDIR}/math/gsl
+LIB_DEPENDS+= gsl.10:${PORTSDIR}/math/gsl
.endif
# Documentation
diff --git a/math/freefem++/Makefile b/math/freefem++/Makefile
index 3e8082c6ef2f..17c24d281108 100644
--- a/math/freefem++/Makefile
+++ b/math/freefem++/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freefem++
DISTVERSION= 2.17-1
+PORTREVISION= 1
CATEGORIES= math science
MASTER_SITES= http://www.freefem.org/ff++/ftp/
@@ -17,7 +18,7 @@ LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk-threads \
fftw3.4:${PORTSDIR}/math/fftw3 \
umfpack.1:${PORTSDIR}/math/suitesparse \
arpack.1:${PORTSDIR}/math/arpack \
- gsl.9:${PORTSDIR}/math/gsl
+ gsl.10:${PORTSDIR}/math/gsl
BUILD_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
dvips:${PORTSDIR}/print/dvipsk-tetex \
pdflatex:${PORTSDIR}/print/teTeX-base \
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index e7c483565847..d1cf4151f12a 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= LabPlot
PORTVERSION= 1.5.1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=labplot
@@ -18,7 +18,7 @@ COMMENT= LabPlot : Data analysis and visualisation
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
Magick.10:${PORTSDIR}/graphics/ImageMagick \
audiofile.0:${PORTSDIR}/audio/libaudiofile \
- gsl.9:${PORTSDIR}/math/gsl \
+ gsl.10:${PORTSDIR}/math/gsl \
jasper.4:${PORTSDIR}/graphics/jasper \
fftw3.4:${PORTSDIR}/math/fftw3 \
netcdf:${PORTSDIR}/science/netcdf \
diff --git a/math/msieve/Makefile b/math/msieve/Makefile
index f28291f69ba9..20e216a6212e 100644
--- a/math/msieve/Makefile
+++ b/math/msieve/Makefile
@@ -7,6 +7,7 @@
PORTNAME= msieve
PORTVERSION= 1.23
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://www.boo.net/~jasonp/ \
http://mirror.roe.ch/dist/msieve/
@@ -41,7 +42,7 @@ CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
.if !defined(WITHOUT_GNFS)
-LIB_DEPENDS+= gsl.9:${PORTSDIR}/math/gsl
+LIB_DEPENDS+= gsl.10:${PORTSDIR}/math/gsl
ALLTGT_SUFX= _nfs
.endif
diff --git a/math/orpie/Makefile b/math/orpie/Makefile
index 1c510c186b9a..d0e22ec78f1e 100644
--- a/math/orpie/Makefile
+++ b/math/orpie/Makefile
@@ -7,7 +7,7 @@
PORTNAME= orpie
PORTVERSION= 1.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES+= math
MASTER_SITES= http://www.eecs.umich.edu/~pelzlpj/orpie/
@@ -15,7 +15,7 @@ MAINTAINER= dylan@dylex.net
COMMENT= A fullscreen RPN calculator for the console
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
-LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/math/p5-Math-GSL/Makefile b/math/p5-Math-GSL/Makefile
index 51d6f45dc535..9402a5c93144 100644
--- a/math/p5-Math-GSL/Makefile
+++ b/math/p5-Math-GSL/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Math-GSL
PORTVERSION= 0.01
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Math
@@ -16,7 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A perl interface to GNU Scientific Library
-LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl
PERL_CONFIGURE= yes
MAKE_ENV= INC="-I${LOCALBASE}/include"
diff --git a/math/py-gsl/Makefile b/math/py-gsl/Makefile
index d5252672651e..7ba44612f8bb 100644
--- a/math/py-gsl/Makefile
+++ b/math/py-gsl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gsl
PORTVERSION= 0.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pygsl
@@ -20,7 +20,7 @@ COMMENT= Python interface to GNU Scientific Library
BUILD_DEPENDS= ${PYNUMERIC}
RUN_DEPENDS= ${PYNUMERIC}
-LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g}
USE_PYTHON= yes
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 36524b09dc67..adb69ed9f751 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -7,13 +7,14 @@
PORTNAME= qtiplot
DISTVERSION= 0.9rc2
+PORTREVISION= 1
CATEGORIES= math science
MASTER_SITES= http://soft.proindependent.com/src/
MAINTAINER= makc@issp.ac.ru
COMMENT= An Origin clone for data analysis and scientific plotting
-LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl \
+LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl \
muparser.0:${PORTSDIR}/math/muparser \
origin.0:${PORTSDIR}/math/liborigin \
qwtplot3d-qt4:${PORTSDIR}/math/qwtplot3d-qt4 \
diff --git a/math/ruby-gsl/Makefile b/math/ruby-gsl/Makefile
index d626342b1688..d6d4bf1666f8 100644
--- a/math/ruby-gsl/Makefile
+++ b/math/ruby-gsl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gsl
PORTVERSION= 1.9.0
+PORTREVISION= 1
CATEGORIES= math ruby
MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
MASTER_SITE_SUBDIR= rb-${PORTNAME}
@@ -17,7 +18,7 @@ DIST_SUBDIR= ruby
MAINTAINER= clsung@FreeBSD.org
COMMENT= A Ruby extension library for GSL (GNU Scientific Library)
-LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl
USE_RUBY= yes
USE_RUBY_SETUP= yes
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 089c17979f32..25a474240e24 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -8,13 +8,14 @@
PORTNAME= yacas
PORTVERSION= 1.0.61
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://yacas.sourceforge.net/backups/
MAINTAINER= shaun@FreeBSD.org
COMMENT= Yet Another Computer Algebra System
-LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl
USE_AUTOTOOLS= libtool:15
USE_PERL5_BUILD= yes