aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-12-24 22:10:16 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-12-24 22:10:16 +0000
commitc61709aca4a0c1e46d756f658f8619f8ce80821f (patch)
tree4e0767fa8382922ec12dd2f5a876fc25db4cb843 /math
parentf6c6ba5218a02ac91087ecd4d3aa982c84b790e9 (diff)
downloadports-c61709aca4a0c1e46d756f658f8619f8ce80821f.tar.gz
ports-c61709aca4a0c1e46d756f658f8619f8ce80821f.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/libqalculate/Makefile9
-rw-r--r--math/libqalculate/distinfo5
-rw-r--r--math/libqalculate/files/patch-libqalculate-Number.cc29
3 files changed, 6 insertions, 37 deletions
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index da143ba45955..27d3d8ff5e5e 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libqalculate
-PORTVERSION= 0.8.2
-PORTREVISION= 1
+PORTVERSION= 0.9.0
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= qalculate
@@ -17,17 +16,15 @@ COMMENT= Very powerful GUI calculator for GNOME (backend library)
LIB_DEPENDS= cln.4:${PORTSDIR}/math/cln
-USE_X_PREFIX= yes
-USE_GCC= 3.4+
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-USE_GNOME= intlhack lthack pkgconfig gnomehack glib20 libxml2
+USE_GNOME= intlhack gnomehack glib20 libxml2
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= "does not build even with USE_GCC"
+IGNORE= does not build on FreeBSD 4.x
.endif
.include <bsd.port.post.mk>
diff --git a/math/libqalculate/distinfo b/math/libqalculate/distinfo
index fa2f320df998..54d8466619f9 100644
--- a/math/libqalculate/distinfo
+++ b/math/libqalculate/distinfo
@@ -1,2 +1,3 @@
-MD5 (libqalculate-0.8.2.tar.gz) = 69824de52bea915f5cc00ed6e3b905c9
-SIZE (libqalculate-0.8.2.tar.gz) = 683579
+MD5 (libqalculate-0.9.0.tar.gz) = 1c730ef9865fc5ef850ae7c7dbe4eb93
+SHA256 (libqalculate-0.9.0.tar.gz) = 5cad6916d9fb38fab662ef812bff55d79653d144e734ab4c66cd1424ef556449
+SIZE (libqalculate-0.9.0.tar.gz) = 693984
diff --git a/math/libqalculate/files/patch-libqalculate-Number.cc b/math/libqalculate/files/patch-libqalculate-Number.cc
deleted file mode 100644
index c179a9ee8938..000000000000
--- a/math/libqalculate/files/patch-libqalculate-Number.cc
+++ /dev/null
@@ -1,29 +0,0 @@
---- libqalculate/Number.cc.orig Thu Nov 3 18:27:14 2005
-+++ libqalculate/Number.cc Thu Nov 3 18:28:15 2005
-@@ -2389,7 +2389,7 @@
- if(po.indicate_infinite_series && !infinite_series) {
- remainders.push_back(remainder);
- }
-- remainder *= base;
-+ remainder = remainder * base;
- div = cln::truncate2(remainder, d);
- remainder2 = div.remainder;
- remainder = div.quotient;
-@@ -2398,7 +2398,7 @@
- started = !cln::zerop(remainder);
- }
- if(started) {
-- num *= base;
-+ num = num * base;
- num += remainder;
- }
- l10++;
-@@ -2417,7 +2417,7 @@
- }
- remainders.clear();
- if(!exact && !infinite_series) {
-- remainder *= base;
-+ remainder = remainder * base;
- div = cln::truncate2(remainder, d);
- remainder2 = div.remainder;
- remainder = div.quotient;