aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-29 12:42:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-29 12:42:04 +0000
commit222461c302e52a3848555e999ecc7a10f98b278e (patch)
tree4fad0f8d9c328a570a49371daf5f0078d7075272 /math
parentb6155c63444b79580e9bd13727472581d1ed66f1 (diff)
downloadports-222461c302e52a3848555e999ecc7a10f98b278e.tar.gz
ports-222461c302e52a3848555e999ecc7a10f98b278e.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/calctool/Makefile18
-rw-r--r--math/pgcalc/Makefile9
-rw-r--r--math/yacas/Makefile14
3 files changed, 23 insertions, 18 deletions
diff --git a/math/calctool/Makefile b/math/calctool/Makefile
index 1d55cd7654ea..fd9ba5b187a8 100644
--- a/math/calctool/Makefile
+++ b/math/calctool/Makefile
@@ -18,15 +18,17 @@ COMMENT= A multi-GUI (terminal, X, XView) calculator program
USE_LDCONFIG= yes
-OPTIONS= X11 "Build X11 version of calctool" on \
- TTY "Build tty version of calctool" on \
- XVIEW "Build tty version of calctool" off
+OPTIONS_DEFINE= X11 TTY XVIEW
+OPTIONS_DEFAULT= X11 TTY
+X11_DESC= Build X11 version of calctool
+TTY_DESC= Build tty version of calctool
+XVIEW_DESC= Build tty version of calctool
MAN1= calctool.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
USE_XORG= x11
BINARIES+= xcalctool
PLIST_SUB+= X11=""
@@ -34,14 +36,14 @@ PLIST_SUB+= X11=""
PLIST_SUB+= X11="@comment "
.endif
-.if !defined(WITHOUT_TTY)
+.if ${PORT_OPTIONS:MTTY}
BINARIES+= tty_calctool
PLIST_SUB+= TTY=""
.else
PLIST_SUB+= TTY="@comment "
.endif
-.if defined(WITH_XVIEW)
+.if ${PORT_OPTIONS:MXVIEW}
BINARIES+= xv_calctool
LIB_DEPENDS+= xview.3:${PORTSDIR}/x11-toolkits/xview
PLIST_SUB+= XVIEW=""
@@ -72,4 +74,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/calctool.1 ${PREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/calctool.help ${DATADIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/pgcalc/Makefile b/math/pgcalc/Makefile
index 232eb595af60..e6b3a0ad8efd 100644
--- a/math/pgcalc/Makefile
+++ b/math/pgcalc/Makefile
@@ -22,11 +22,12 @@ INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= ARTS "Build with aRts support" on
+OPTIONS_DEFINE= ARTS
+OPTIONS_DEFAULT= ARTS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITH_ARTS)
+.if ${PORT_OPTIONS:MARTS}
CONFIGURE_ARGS+= --without-arts
.endif
@@ -43,4 +44,4 @@ post-extract:
@${REINPLACE_CMD} -e 's,SkinPath =,& QString("${PREFIX}/share/apps/${PORTNAME}/skins/"); //,' \
${WRKSRC}/src/pgcalc.cpp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 8e03a5181c49..902e6ecb2978 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -17,26 +17,28 @@ COMMENT= Yet Another Computer Algebra System
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS= TESTS "Run bundled self-tests after build" on
+OPTIONS_DEFINE= TESTS DOCS
+OPTIONS_DEFAULT= TESTS
+TESTS_DESC= Run bundled self-tests after build
USE_PERL5_BUILD=yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
MAKE_JOBS_SAFE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "sparc64"
BROKEN= Does not compile with GCC 4.2
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+= --enable-html-doc --with-html-dir=${DOCSDIR}
.else
CONFIGURE_ARGS+= --disable-html-doc
.endif
-.if !defined(WITHOUT_TESTS)
+.if ${PORT_OPTIONS:MTESTS}
BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash
.endif
@@ -45,9 +47,9 @@ post-patch:
's| /bin/bash| ${LOCALBASE}/bin/bash|' ${WRKSRC}/tests/test-yacas
post-build:
-.if !defined(WITHOUT_TESTS)
+.if ${PORT_OPTIONS:MTESTS}
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
${MAKEFILE} check ${MAKE_ARGS})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>