aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-04-23 13:25:16 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-04-23 13:25:16 +0000
commitaad09bc5e23eb75a7a865a8b0002fbc6e13d4659 (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /math
parent5c818b158c5b9479669f8322b4da8c48f5c30ef9 (diff)
Notes
Diffstat (limited to 'math')
-rw-r--r--math/fftw/Makefile4
-rw-r--r--math/fityk/Makefile4
-rw-r--r--math/giacxcas/Makefile12
-rw-r--r--math/gmp/Makefile4
-rw-r--r--math/matio/Makefile3
-rw-r--r--math/mpfr/Makefile5
6 files changed, 17 insertions, 15 deletions
diff --git a/math/fftw/Makefile b/math/fftw/Makefile
index 2a2170d611c2..c637089ddb9e 100644
--- a/math/fftw/Makefile
+++ b/math/fftw/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fftw
PORTVERSION= 2.1.5
-PORTREVISION?= 9
+PORTREVISION?= 10
CATEGORIES= math
MASTER_SITES= ftp://ftp.fftw.org/pub/fftw/ \
ftp://ftp.fftw.org/pub/fftw/old/ \
@@ -22,7 +22,7 @@ FFTW_FLAVOR?= default
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
-USES= fortran gmake libtool
+USES= fortran gmake libtool:keepla
USE_LDCONFIG= yes
BROKEN_sparc64= does not build
diff --git a/math/fityk/Makefile b/math/fityk/Makefile
index 3ab693381139..07092454effb 100644
--- a/math/fityk/Makefile
+++ b/math/fityk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fityk
PORTVERSION= 0.9.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= SF/xylib:xylib
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:DEFAULT \
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/spirit/include/classic_core.hpp:${PORT
gnuplot:${PORTSDIR}/math/gnuplot
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
-USES= gmake libtool tar:bzip2 desktop-file-utils shared-mime-info
+USES= desktop-file-utils gmake libtool:keepla shared-mime-info tar:bzip2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
LDFLAGS+= -lbz2 -lz
USE_GITHUB= yes
diff --git a/math/giacxcas/Makefile b/math/giacxcas/Makefile
index cd2858fee8e3..8b7663f152f3 100644
--- a/math/giacxcas/Makefile
+++ b/math/giacxcas/Makefile
@@ -3,7 +3,7 @@
PORTNAME= giacxcas
PORTVERSION= 1.1.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= http://www-fourier.ujf-grenoble.fr/~parisse/giac/freebsd/ \
http://www.math.jussieu.fr/~han/xcas/sources/
@@ -28,11 +28,11 @@ LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
NO_CDROM= French documentation is for non-commercial use only
GNU_CONFIGURE= yes
+USES= desktop-file-utils gettext gmake libtool:keepla shebangfix
USE_GL= gl
-USE_XORG= xcursor xft xi
+USE_XORG= x11 xcursor xft xi
USE_TEX= latex:build dvipsk:build
USE_LDCONFIG= yes
-USES= gettext gmake shebangfix desktop-file-utils
USE_GCC= yes
DOCSDIR= ${PREFIX}/share/doc/giac
PORTDOCS= *
@@ -40,6 +40,7 @@ DATADIR= ${PREFIX}/share/giac
PORTDATA= *
SHEBANG_FILES= src/pgiac
+CONFIGURE_ENV= X_LIBS=-lX11
CPPFLAGS+= -I${FLTKDEV-GIAC} -I${COCOALIB-GIAC}/include -I${LOCALBASE}/include
LDFLAGS+= -L${FLTKDEV-GIAC}/lib -L${COCOALIB-GIAC}/lib -L${LOCALBASE}/lib
CXXFLAGS+= -I${LOCALBASE}/include
@@ -50,7 +51,8 @@ COCOALIB-GIAC= ${WRKDIR}/CoCoALib-0.9950
INFO= giac_es giac_us
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
.if ${OSVERSION} >= 1000000
CONFIGURE_ARGS+= --disable-ntl
.endif
@@ -73,4 +75,4 @@ pre-configure:
./configure --prefix=${FLTKDEV-GIAC} \
&& ${MAKE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/gmp/Makefile b/math/gmp/Makefile
index 945a84047ebb..88f398521d09 100644
--- a/math/gmp/Makefile
+++ b/math/gmp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gmp
PORTVERSION= 5.1.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gmp
@@ -16,8 +16,8 @@ LICENSE= LGPL3
OPTIONS_DEFINE= CPU_OPTS
CPU_OPTS_DESC= Enable assembly optimizations for your CPU
+USES= libtool:keepla
USE_XZ= yes
-USES= libtool
GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --prefix=${PREFIX} \
diff --git a/math/matio/Makefile b/math/matio/Makefile
index 0f101cced1b6..a84a543d9c74 100644
--- a/math/matio/Makefile
+++ b/math/matio/Makefile
@@ -3,6 +3,7 @@
PORTNAME= matio
PORTVERSION= 1.5.2
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= SF
@@ -12,7 +13,7 @@ COMMENT= Library for reading and writing Matlab MAT files
LICENSE= BSD2CLAUSE
GNU_CONFIGURE= yes
-USES= libtool pathfix
+USES= libtool:keepla pathfix
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/math/mpfr/Makefile b/math/mpfr/Makefile
index 9461b0a4773c..bec1561bbf38 100644
--- a/math/mpfr/Makefile
+++ b/math/mpfr/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mpfr
PORTVERSION= 3.1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math devel
MASTER_SITES= http://www.mpfr.org/mpfr-current/
DIST_SUBDIR= ${DISTNAME}
@@ -23,8 +23,7 @@ LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
#PATCHFILES!= /usr/bin/jot -s " " -w patch%02d ${PATCHLEVEL} 1 ${PATCHLEVEL}
#PATCH= ${LOCALBASE}/bin/gpatch
-USES= libtool
-
+USES= libtool:keepla
USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gmp=${LOCALBASE}