aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-07-16 08:26:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-07-16 08:26:25 +0000
commitd22728a7e856c5c9ae691125736d656a2c1163ad (patch)
tree631e17a2b7895241106d33db493284675e581402 /math
parentf329319eb51eb2930a53eb96f5f2932c737a71b8 (diff)
downloadports-d22728a7e856c5c9ae691125736d656a2c1163ad.tar.gz
ports-d22728a7e856c5c9ae691125736d656a2c1163ad.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/atlas/Makefile2
-rw-r--r--math/calctool/Makefile2
-rw-r--r--math/petsc/Makefile8
-rw-r--r--math/xspread/Makefile2
4 files changed, 7 insertions, 7 deletions
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index f60b501d8590..7d9a019b42f3 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -55,7 +55,7 @@ POINTER?= 32
.endif
.if defined(MAINTAINER_MODE)
-LIB_DEPENDS+= blas:${PORTSDIR}/math/blas
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
.endif
.for i in DATA DOCS
diff --git a/math/calctool/Makefile b/math/calctool/Makefile
index 9a32f3b05380..9d03ff6b66cb 100644
--- a/math/calctool/Makefile
+++ b/math/calctool/Makefile
@@ -38,7 +38,7 @@ PLIST_SUB+= TTY="@comment "
.if ${PORT_OPTIONS:MXVIEW}
BINARIES+= xv_calctool
-LIB_DEPENDS+= xview.3:${PORTSDIR}/x11-toolkits/xview
+LIB_DEPENDS+= libxview.so:${PORTSDIR}/x11-toolkits/xview
PLIST_SUB+= XVIEW=""
.else
PLIST_SUB+= XVIEW="@comment "
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index bdabfe20dc68..ebb3d0d0f598 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -123,11 +123,11 @@ PLIST_SUB+= MPIUNI=""
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
LIBBLASLAPACK= -L${LOCALBASE}/lib -lalapack -lcblas -lf77blas
CONFIGURE_ARGS+= --with-blas-lapack-lib="${LIBBLASLAPACK}"
.else
-LIB_DEPENDS+= lapack:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
LIBBLASLAPACK= -L${LOCALBASE}/lib -llapack -lblas
CONFIGURE_ARGS+= --with-blas-lapack-lib="${LIBBLASLAPACK}"
.endif
@@ -161,7 +161,7 @@ CONFLICTS+= metis-4*
WITH_BLACS= yes
.endif
.if defined(WITH_BLACS) && defined(WITH_MPI)
-LIB_DEPENDS+= blacs:${PORTSDIR}/math/blacs
+LIB_DEPENDS+= libblacs.so:${PORTSDIR}/math/blacs
CONFIGURE_ARGS+= --with_blacs=1 \
--with-blacs-include=${LOCALBASE}/include \
--with-blacs-lib=[${LOCALBASE}/lib/libblacsc.a,${LOCALBASE}/lib/libblacsf77.a,${LOCALBASE}/lib/libblacs.a]
@@ -169,7 +169,7 @@ CONFIGURE_ARGS+= --with_blacs=1 \
WITH_SCALAPACK= yes
. endif
. if defined(WITH_SCALAPACK)
-LIB_DEPENDS+= scalapack:${PORTSDIR}/math/scalapack
+LIB_DEPENDS+= libscalapack.so:${PORTSDIR}/math/scalapack
CONFIGURE_ARGS+= --with-scalapack=1 \
--with-scalapack-dir=${LOCALBASE}
. endif
diff --git a/math/xspread/Makefile b/math/xspread/Makefile
index 6ee80103ef2e..6d7997500c95 100644
--- a/math/xspread/Makefile
+++ b/math/xspread/Makefile
@@ -31,7 +31,7 @@ PLIST_FILES= bin/pxspread bin/xspread man/man1/pxspread.1.gz \
.if ${PORT_OPTIONS:MX11}
USE_XORG= x11 xau xcb xdmcp xt
-LIB_DEPENDS+= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs
+LIB_DEPENDS+= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.else