aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-16 03:00:46 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-16 03:00:46 +0000
commitfa4bf2ee1d039ae33718a8286802e7bf7ceb3387 (patch)
tree728a3619568ce38b9188fc0b8717a16a880d52d3 /math
parentb0dffdff28a18aa92669ae08593f8e26d4128641 (diff)
downloadports-fa4bf2ee1d039ae33718a8286802e7bf7ceb3387.tar.gz
ports-fa4bf2ee1d039ae33718a8286802e7bf7ceb3387.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/diehard/Makefile2
-rw-r--r--math/ocamlgsl/Makefile2
-rw-r--r--math/parmgridgen/Makefile2
-rw-r--r--math/pecl-big_int/Makefile2
-rw-r--r--math/pecl-big_int/pkg-plist12
-rw-r--r--math/py-nzmath/Makefile2
-rw-r--r--math/py-scientific/Makefile2
-rw-r--r--math/ruby-fftw3/Makefile2
-rw-r--r--math/ruby-gsl/Makefile2
-rw-r--r--math/ruby-narray/Makefile2
10 files changed, 24 insertions, 6 deletions
diff --git a/math/diehard/Makefile b/math/diehard/Makefile
index fe57dded58ec..3e05a6a6df40 100644
--- a/math/diehard/Makefile
+++ b/math/diehard/Makefile
@@ -17,6 +17,8 @@ PLIST_SUB= DOCSDIR="share/doc/${PORTNAME}" DATADIR="share/${PORTNAME}"
DOCSLIST= NOTES readme
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's|operm5\.cov|${DATADIR}/operm5.cov|g;' \
${WRKSRC}/cdoperm5.c
diff --git a/math/ocamlgsl/Makefile b/math/ocamlgsl/Makefile
index 2d85d0c4da79..60a9b0c919a0 100644
--- a/math/ocamlgsl/Makefile
+++ b/math/ocamlgsl/Makefile
@@ -25,6 +25,8 @@ HAS_CONFIGURE= YES
MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/gsl-ocaml-${PORTVERSION}
+OPTIONS_DEFINE= DOCS
+
post-configure:
@${ECHO_CMD} 'stagedir="${STAGEDIR}"' >> ${WRKSRC}/setup.data
@${ECHO_CMD} 'docdir="$$datarootdir/doc/ocaml/$$pkg_name"' >> ${WRKSRC}/setup.data
diff --git a/math/parmgridgen/Makefile b/math/parmgridgen/Makefile
index 713e3da3c769..3d98107e9c38 100644
--- a/math/parmgridgen/Makefile
+++ b/math/parmgridgen/Makefile
@@ -19,6 +19,8 @@ LIB_DEPENDS+= libmpi.so:${PORTSDIR}/net/openmpi
USES= gmake
MAKE_JOBS_UNSAFE= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} 's|make|$$(MAKE)|g' ${WRKSRC}/Makefile
#respect CFLAGS
diff --git a/math/pecl-big_int/Makefile b/math/pecl-big_int/Makefile
index 02ada663f217..253a40010cdc 100644
--- a/math/pecl-big_int/Makefile
+++ b/math/pecl-big_int/Makefile
@@ -21,6 +21,8 @@ EXAMPLES= bitset.php example.php rand.php RSA.php std_header.php
CONFIGURE_ARGS= --enable-big-int=shared
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
diff --git a/math/pecl-big_int/pkg-plist b/math/pecl-big_int/pkg-plist
index 982efe9af06e..5e11de094436 100644
--- a/math/pecl-big_int/pkg-plist
+++ b/math/pecl-big_int/pkg-plist
@@ -3,10 +3,10 @@
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/RSA.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/bitset.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/example.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/rand.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/std_header.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/RSA.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bitset.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rand.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/std_header.php
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
diff --git a/math/py-nzmath/Makefile b/math/py-nzmath/Makefile
index 64700bba4256..83eacb8b4938 100644
--- a/math/py-nzmath/Makefile
+++ b/math/py-nzmath/Makefile
@@ -15,6 +15,8 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= NZMATH
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/data/discriminant.csv ${STAGEDIR}${DATADIR}
diff --git a/math/py-scientific/Makefile b/math/py-scientific/Makefile
index d7796daf2550..b38633185a03 100644
--- a/math/py-scientific/Makefile
+++ b/math/py-scientific/Makefile
@@ -23,6 +23,8 @@ PYDISTUTILS_AUTOPLIST= yes
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/LICENSE ${STAGEDIR}${DOCSDIR}
diff --git a/math/ruby-fftw3/Makefile b/math/ruby-fftw3/Makefile
index c6fbb4ed2039..11d12052b96e 100644
--- a/math/ruby-fftw3/Makefile
+++ b/math/ruby-fftw3/Makefile
@@ -29,6 +29,8 @@ CONFIGURE_ARGS+= --with-narray-include=${LOCALBASE}/lib/ruby/gems/${RUBY_VER}/ge
DOCS= LICENSE.txt doc/*
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}
.for f in ${DOCS}
diff --git a/math/ruby-gsl/Makefile b/math/ruby-gsl/Makefile
index 61112cda00ac..cd06dece8004 100644
--- a/math/ruby-gsl/Makefile
+++ b/math/ruby-gsl/Makefile
@@ -24,6 +24,8 @@ CONFIGURE_ARGS= -- --with-opt-dir="${LOCALBASE}"
DOCS= AUTHORS ChangeLog THANKS rdoc
+OPTIONS_DEFINE= DOCS
+
post-extract:
${FIND} ${WRKSRC} '(' -name '.DS_Store' -o -name '*~' ')' -delete
diff --git a/math/ruby-narray/Makefile b/math/ruby-narray/Makefile
index fb71503ef000..dc923937debe 100644
--- a/math/ruby-narray/Makefile
+++ b/math/ruby-narray/Makefile
@@ -24,6 +24,8 @@ MAKE_ARGS= INSTALL_PROG="${INSTALL_PROGRAM}" \
DOC_EN= ChangeLog README.en SPEC.en
DOC_JA= README.ja SPEC.ja
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}/ja
.for f in ${DOC_EN}