aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2009-02-11 11:04:55 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2009-02-11 11:04:55 +0000
commit22b1896e39586c83bab46d50c9c303451f62a949 (patch)
tree02578c4bc6f2d6432b612d36f2434f6c087c3905 /math
parentdc0e0ced8d1eba2ed6a5b1ed5911824705a8e1ed (diff)
downloadports-22b1896e39586c83bab46d50c9c303451f62a949.tar.gz
ports-22b1896e39586c83bab46d50c9c303451f62a949.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/it++/Makefile23
-rw-r--r--math/it++/distinfo6
-rw-r--r--math/it++/files/patch-configure11
-rw-r--r--math/it++/files/patch-include_base_machdep.h22
-rw-r--r--math/it++/pkg-plist247
5 files changed, 148 insertions, 161 deletions
diff --git a/math/it++/Makefile b/math/it++/Makefile
index 20ee44c38857..f5f6eb8b69a9 100644
--- a/math/it++/Makefile
+++ b/math/it++/Makefile
@@ -7,12 +7,12 @@
#
PORTNAME= it++
-PORTVERSION= 3.8.1
+PORTVERSION= 4.0.6
PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= itpp
-DISTNAME= ${PORTNAME}${PORTVERSION}
+DISTNAME= itpp-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Mathematical, signal processing and communication library
@@ -27,23 +27,22 @@ LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
BLAS= -lf77blas -latlas
.else
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
-BLAS= -lblas
+BLAS= -lblas
.endif
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= opt
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-lapack --without-fft
+USE_LDCONFIG= yes
USE_GMAKE= yes
USE_FORTRAN= yes
+MAN1= itpp-config.1
post-patch:
- @${REINPLACE_CMD} -e "s|sparc|__sparc__|" \
- -e "s|alpha|__alpha__|" ${WRKSRC}/include/base/machdep.h
@${REINPLACE_CMD} -e "s|[$$]{it_dir}|${LOCALBASE}|g" ${WRKSRC}/configure
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/it-config ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/lib/libit++.a ${PREFIX}/lib
- ${CP} -R ${WRKSRC}/include ${PREFIX}/include/it++
- ${FIND} ${PREFIX}/include/it++ -name \*.orig -delete
+post-install:
+ @${RM} -f ${PREFIX}/lib/libitpp.la \
+ ${PREFIX}/lib/pkgconfig/itpp.pc
+ @-${RMDIR} ${PREFIX}/lib/pkgconfig
.include <bsd.port.post.mk>
diff --git a/math/it++/distinfo b/math/it++/distinfo
index 83a9b2a79ba1..01e1f8acb8ff 100644
--- a/math/it++/distinfo
+++ b/math/it++/distinfo
@@ -1,3 +1,3 @@
-MD5 (it++3.8.1.tar.gz) = 152939bfc438f70e8eb0a056f2743ad4
-SHA256 (it++3.8.1.tar.gz) = 376be56bf5bc8fdb003e95dd70caf788d25362616e62982ab5d9531451419d2d
-SIZE (it++3.8.1.tar.gz) = 503647
+MD5 (itpp-4.0.6.tar.gz) = f47da8c61de3dd042b94fc9b9adc345b
+SHA256 (itpp-4.0.6.tar.gz) = 36bf3a6851a9b813c3554935b91f3ba5f1f63f8beddbcf3404ae7f9efbe3c345
+SIZE (itpp-4.0.6.tar.gz) = 1245054
diff --git a/math/it++/files/patch-configure b/math/it++/files/patch-configure
deleted file mode 100644
index 4c3ae19fe376..000000000000
--- a/math/it++/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Sat Feb 19 17:35:18 2005
-+++ configure Sat Feb 19 17:35:04 2005
-@@ -328,7 +328,7 @@ HAVE_LAPACK = $lapack
- HAVE_FFTW = $fftw
- OS = $os
- IT_DIR = $it_dir
--CXX = $compiler
-+#CXX = $compiler
-
- PROF_FLAGS = -pg \$(OPTIMIZED_FLAGS)
- DEBUG_FLAGS = -g -DASSERT_LEVEL=2
diff --git a/math/it++/files/patch-include_base_machdep.h b/math/it++/files/patch-include_base_machdep.h
deleted file mode 100644
index d0c709113123..000000000000
--- a/math/it++/files/patch-include_base_machdep.h
+++ /dev/null
@@ -1,22 +0,0 @@
---- include/base/machdep.h.orig 2005-01-17 09:02:20.000000000 +0000
-+++ include/base/machdep.h 2008-04-30 11:49:04.000000000 +0000
-@@ -24,6 +24,7 @@
- #ifndef __machdep_h
- #define __machdep_h
-
-+#include <machine/endian.h>
- #include "itconfig.h"
-
- namespace itpp {
-@@ -71,9 +72,9 @@
- inline void little_endian(it_s8 x, it_s8 &y) { y = x; }
- inline void little_endian(it_u8 x, it_u8 &y) { y = x; }
-
--#if defined(sparc)
-+#if _BYTE_ORDER == _LITTLE_ENDIAN
- #define __LITTLE_ENDIAN__
--#elif defined(i386) || defined(_M_IX86) || defined(_x86_64) || defined(alpha) || defined(vms)
-+#elif _BYTE_ORDER == _BIG_ENDIAN
- #define __BIG_ENDIAN__
- #endif
-
diff --git a/math/it++/pkg-plist b/math/it++/pkg-plist
index a37234936c8a..4fffdaa77e51 100644
--- a/math/it++/pkg-plist
+++ b/math/it++/pkg-plist
@@ -1,115 +1,136 @@
-bin/it-config
-lib/libit++.a
+bin/itpp-config
+lib/libitpp.so
+lib/libitpp.so.6
-include/it++/base/array.h
-include/it++/base/bessel.h
-include/it++/base/binary.h
-include/it++/base/binfile.h
-include/it++/base/cblas.h
-include/it++/base/cholesky.h
-include/it++/base/circular_buffer.h
-include/it++/base/converters.h
-include/it++/base/det.h
-include/it++/base/eigen.h
-include/it++/base/elmatfunc.h
-include/it++/base/factory.h
-include/it++/base/fastica.h
-include/it++/base/fastmath.h
-include/it++/base/filter.h
-include/it++/base/help_functions.h
-include/it++/base/integration.h
-include/it++/base/inv.h
-include/it++/base/itassert.h
-include/it++/base/itfile.h
-include/it++/base/itpp_version.h
-include/it++/base/ls_solve.h
-include/it++/base/lu.h
-include/it++/base/machdep.h
-include/it++/base/machdep.h.bak
-include/it++/base/mat.h
-include/it++/base/matfunc.h
-include/it++/base/operators.h
-include/it++/base/parser.h
-include/it++/base/qr.h
-include/it++/base/random.h
-include/it++/base/scalfunc.h
-include/it++/base/sigfun.h
-include/it++/base/smat.h
-include/it++/base/sort.h
-include/it++/base/source.h
-include/it++/base/specmat.h
-include/it++/base/stack.h
-include/it++/base/stat.h
-include/it++/base/svd.h
-include/it++/base/svec.h
-include/it++/base/timing.h
-include/it++/base/transforms.h
-include/it++/base/vec.h
-include/it++/comm/bch.h
-include/it++/comm/channel.h
-include/it++/comm/commfunc.h
-include/it++/comm/convcode.h
-include/it++/comm/crc.h
-include/it++/comm/egolay.h
-include/it++/comm/error_counters.h
-include/it++/comm/galois.h
-include/it++/comm/hammcode.h
-include/it++/comm/interleave.h
-include/it++/comm/modulator.h
-include/it++/comm/ofdm.h
-include/it++/comm/pulse_shape.h
-include/it++/comm/punct_convcode.h
-include/it++/comm/rec_syst_conv_code.h
-include/it++/comm/reedsolomon.h
-include/it++/comm/sequence.h
-include/it++/comm/spread.h
-include/it++/comm/turbo.h
-include/it++/itbase.h
-include/it++/itcomm.h
-include/it++/itconfig.h
-include/it++/itmex.h
-include/it++/itsrccode.h
-include/it++/matlab/matlab_engine.h
-include/it++/srccode/audiofile.h
-include/it++/srccode/gmm.h
-include/it++/srccode/lpcfunc.h
-include/it++/srccode/pnm.h
-include/it++/srccode/vq.h
-include/it++/srccode/vqtrain.h
-include/it++/alpha_modules.h
-include/it++/base/copy_vector.h
-include/it++/base/fftw3.h
-include/it++/base/freq_filt.h
-include/it++/base/lapack.h
-include/it++/comm/channel_code.h
-include/it++/fixedpoint/cfix.h
-include/it++/fixedpoint/cfixed.h
-include/it++/fixedpoint/fix.h
-include/it++/fixedpoint/fix_base.h
-include/it++/fixedpoint/fix_factory.h
-include/it++/fixedpoint/fix_functions.h
-include/it++/fixedpoint/fix_operators.h
-include/it++/fixedpoint/fixed.h
-include/it++/graphics/libharu.h
-include/it++/graphics/plot_pdf.h
-include/it++/itfixedpoint.h
-include/it++/itgraphics.h
-include/it++/itprotocol.h
-include/it++/protocol/events.h
-include/it++/protocol/front_drop_queue.h
-include/it++/protocol/packet.h
-include/it++/protocol/packet_channel.h
-include/it++/protocol/packet_generator.h
-include/it++/protocol/selective_repeat.h
-include/it++/protocol/signals_slots.h
-include/it++/protocol/tcp.h
-include/it++/protocol/tcp_client_server.h
+include/itpp/base/algebra/cholesky.h
+include/itpp/base/algebra/det.h
+include/itpp/base/algebra/eigen.h
+include/itpp/base/algebra/inv.h
+include/itpp/base/algebra/ls_solve.h
+include/itpp/base/algebra/lu.h
+include/itpp/base/algebra/qr.h
+include/itpp/base/algebra/schur.h
+include/itpp/base/algebra/svd.h
+include/itpp/base/math/elem_math.h
+include/itpp/base/math/error.h
+include/itpp/base/math/integration.h
+include/itpp/base/math/log_exp.h
+include/itpp/base/math/min_max.h
+include/itpp/base/math/misc.h
+include/itpp/base/math/trig_hyp.h
+include/itpp/base/array.h
+include/itpp/base/bessel.h
+include/itpp/base/binary.h
+include/itpp/base/binfile.h
+include/itpp/base/blas.h
+include/itpp/base/circular_buffer.h
+include/itpp/base/converters.h
+include/itpp/base/copy_vector.h
+include/itpp/base/factory.h
+include/itpp/base/fastmath.h
+include/itpp/base/gf2mat.h
+include/itpp/base/help_functions.h
+include/itpp/base/itassert.h
+include/itpp/base/itfile.h
+include/itpp/base/ittypes.h
+include/itpp/base/mat.h
+include/itpp/base/matfunc.h
+include/itpp/base/operators.h
+include/itpp/base/parser.h
+include/itpp/base/random.h
+include/itpp/base/smat.h
+include/itpp/base/sort.h
+include/itpp/base/specmat.h
+include/itpp/base/stack.h
+include/itpp/base/svec.h
+include/itpp/base/timing.h
+include/itpp/base/vec.h
+include/itpp/comm/bch.h
+include/itpp/comm/channel.h
+include/itpp/comm/channel_code.h
+include/itpp/comm/commfunc.h
+include/itpp/comm/convcode.h
+include/itpp/comm/crc.h
+include/itpp/comm/egolay.h
+include/itpp/comm/error_counters.h
+include/itpp/comm/galois.h
+include/itpp/comm/hammcode.h
+include/itpp/comm/interleave.h
+include/itpp/comm/ldpc.h
+include/itpp/comm/llr.h
+include/itpp/comm/modulator.h
+include/itpp/comm/modulator_nd.h
+include/itpp/comm/ofdm.h
+include/itpp/comm/pulse_shape.h
+include/itpp/comm/punct_convcode.h
+include/itpp/comm/rec_syst_conv_code.h
+include/itpp/comm/reedsolomon.h
+include/itpp/comm/sequence.h
+include/itpp/comm/spread.h
+include/itpp/comm/turbo.h
+include/itpp/fixed/cfix.h
+include/itpp/fixed/cfixed.h
+include/itpp/fixed/fix.h
+include/itpp/fixed/fix_base.h
+include/itpp/fixed/fix_factory.h
+include/itpp/fixed/fix_functions.h
+include/itpp/fixed/fix_operators.h
+include/itpp/fixed/fixed.h
+include/itpp/optim/newton_search.h
+include/itpp/signal/fastica.h
+include/itpp/signal/filter.h
+include/itpp/signal/filter_design.h
+include/itpp/signal/freq_filt.h
+include/itpp/signal/poly.h
+include/itpp/signal/resampling.h
+include/itpp/signal/sigfun.h
+include/itpp/signal/source.h
+include/itpp/signal/transforms.h
+include/itpp/signal/window.h
+include/itpp/stat/histogram.h
+include/itpp/stat/misc_stat.h
+include/itpp/stat/mog_diag.h
+include/itpp/stat/mog_diag_em.h
+include/itpp/stat/mog_diag_kmeans.h
+include/itpp/stat/mog_generic.h
+include/itpp/srccode/audiofile.h
+include/itpp/srccode/gmm.h
+include/itpp/srccode/lpcfunc.h
+include/itpp/srccode/pnm.h
+include/itpp/srccode/vq.h
+include/itpp/srccode/vqtrain.h
+include/itpp/protocol/events.h
+include/itpp/protocol/front_drop_queue.h
+include/itpp/protocol/packet.h
+include/itpp/protocol/packet_channel.h
+include/itpp/protocol/packet_generator.h
+include/itpp/protocol/selective_repeat.h
+include/itpp/protocol/signals_slots.h
+include/itpp/protocol/tcp.h
+include/itpp/protocol/tcp_client_server.h
+include/itpp/config.h
+include/itpp/itbase.h
+include/itpp/itcomm.h
+include/itpp/itfixed.h
+include/itpp/itmex.h
+include/itpp/itoptim.h
+include/itpp/itprotocol.h
+include/itpp/itsignal.h
+include/itpp/itsrccode.h
+include/itpp/itstat.h
-@dirrm include/it++/fixedpoint
-@dirrm include/it++/graphics
-@dirrm include/it++/protocol
-@dirrm include/it++/srccode
-@dirrm include/it++/matlab
-@dirrm include/it++/comm
-@dirrm include/it++/base
-@dirrm include/it++
+share/itpp/itload.m
+share/itpp/itsave.m
+
+@dirrm share/itpp
+@dirrm include/itpp/protocol
+@dirrm include/itpp/stat
+@dirrm include/itpp/srccode
+@dirrm include/itpp/signal
+@dirrm include/itpp/optim
+@dirrm include/itpp/fixed
+@dirrm include/itpp/comm
+@dirrm include/itpp/base/math
+@dirrm include/itpp/base/algebra
+@dirrm include/itpp/base
+@dirrm include/itpp