aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-07-14 02:56:36 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-07-14 02:56:36 +0000
commit3034d94e677c00cc00546fe59b90130e23d419e7 (patch)
tree95c766cdd826712bc89c06e598577d27e09b5499 /math
parentbf8612ab0a529962905e293af7c211cb74cbb55b (diff)
Now we use USE_FORTRAN=yes to use FORTRAN compiler.
Notes
Notes: svn path=/head/; revision=195551
Diffstat (limited to 'math')
-rw-r--r--math/nsc2ke/Makefile5
-rw-r--r--math/superlu/Makefile5
-rw-r--r--math/superlu_mt/Makefile5
-rw-r--r--math/umfpack/Makefile6
4 files changed, 4 insertions, 17 deletions
diff --git a/math/nsc2ke/Makefile b/math/nsc2ke/Makefile
index 8f075fad161a..a21e1ca7f556 100644
--- a/math/nsc2ke/Makefile
+++ b/math/nsc2ke/Makefile
@@ -21,10 +21,7 @@ COMMENT= A Navier-Stokes solver
RESTRICTED= No resale, contact author for commercial usage
-WANT_FORTRAN=yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
FFLAGS+= -O2
NO_WRKSUBDIR= yes
diff --git a/math/superlu/Makefile b/math/superlu/Makefile
index 40400fdf6092..a379ced68742 100644
--- a/math/superlu/Makefile
+++ b/math/superlu/Makefile
@@ -35,10 +35,7 @@ BLAS= -lblas
LAPACK= -llapack
.endif
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
P_VERSION= 3.0
WRKSRC= ${WRKDIR}/SuperLU_${P_VERSION}
diff --git a/math/superlu_mt/Makefile b/math/superlu_mt/Makefile
index 6b22e4d5f423..4a78bd2b040a 100644
--- a/math/superlu_mt/Makefile
+++ b/math/superlu_mt/Makefile
@@ -21,10 +21,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Routines for performing multithreaded sparse factorization
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
diff --git a/math/umfpack/Makefile b/math/umfpack/Makefile
index 91e289a9ae57..29e0d3d1ba5d 100644
--- a/math/umfpack/Makefile
+++ b/math/umfpack/Makefile
@@ -15,11 +15,7 @@ DISTNAME= UMFPACKv${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Unsymmetric-pattern MultiFrontal Package
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-
-WANT_FORTRAN= yes #dummy but future use
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
FORTRANLIBS= -lgfortranbegin -lgfortran
GCCLIBDIR= -L`${CAT} ${WRKSRC}/LIBDIR` -L`${CAT} ${WRKSRC}/LIBDIR`/../../..