aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-05-14 13:56:24 +0000
committerWen Heping <wen@FreeBSD.org>2010-05-14 13:56:24 +0000
commit3afe5913a106874833bcfc7f87f6dcab56f2f25b (patch)
tree76edd64a0337683c93c54c468751cc0ae8f02911 /math
parent30383561822aaf802a5646883a12d0144fc16026 (diff)
downloadports-3afe5913a106874833bcfc7f87f6dcab56f2f25b.tar.gz
ports-3afe5913a106874833bcfc7f87f6dcab56f2f25b.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-GIS-Distance-Lite/Makefile24
-rw-r--r--math/p5-GIS-Distance-Lite/distinfo3
-rw-r--r--math/p5-GIS-Distance-Lite/pkg-descr10
-rw-r--r--math/p5-GIS-Distance-Lite/pkg-plist8
5 files changed, 46 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 37038c801455..a228136afafa 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -295,6 +295,7 @@
SUBDIR += p5-Date-Handler
SUBDIR += p5-GIS-Distance
SUBDIR += p5-GIS-Distance-Fast
+ SUBDIR += p5-GIS-Distance-Lite
SUBDIR += p5-Geo-Coordinates-UTM
SUBDIR += p5-Geo-Distance
SUBDIR += p5-Geo-Distance-XS
diff --git a/math/p5-GIS-Distance-Lite/Makefile b/math/p5-GIS-Distance-Lite/Makefile
new file mode 100644
index 000000000000..0228fc9b9b22
--- /dev/null
+++ b/math/p5-GIS-Distance-Lite/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-GIS-Distance-Lite
+# Date created: May 17, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GIS-Distance-Lite
+PORTVERSION= 1.0
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/J/JO/JOBERO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Calculate geographic distances in geodetic WGS84 format
+
+RUN_DEPENDS= p5-Math-Complex>1.0.3:${PORTSDIR}/math/p5-Math-Complex
+
+PERL_CONFIGURE= yes
+
+MAN3= GIS::Distance::Lite.3 \
+
+.include <bsd.port.mk>
diff --git a/math/p5-GIS-Distance-Lite/distinfo b/math/p5-GIS-Distance-Lite/distinfo
new file mode 100644
index 000000000000..7ff1e1ec599f
--- /dev/null
+++ b/math/p5-GIS-Distance-Lite/distinfo
@@ -0,0 +1,3 @@
+MD5 (GIS-Distance-Lite-1.0.tar.gz) = b898bc2fda77cb161188a47614ccb069
+SHA256 (GIS-Distance-Lite-1.0.tar.gz) = 761765eb47fe0c79d931bee71ce0d69e4c6bbbff0f46cab1d050649f0fdfdf76
+SIZE (GIS-Distance-Lite-1.0.tar.gz) = 2112
diff --git a/math/p5-GIS-Distance-Lite/pkg-descr b/math/p5-GIS-Distance-Lite/pkg-descr
new file mode 100644
index 000000000000..c47cbcd1945c
--- /dev/null
+++ b/math/p5-GIS-Distance-Lite/pkg-descr
@@ -0,0 +1,10 @@
+The module provides a method to calculate geographic distances
+between coordinates in geodetic WGS84 format using the Haversine
+formula.
+
+It is similar to GIS::Distance, but without the extra bells and
+whistles and without the additional dependencies. Same great taste,
+less filling. It exists for those who cannot, or prefer not to
+install Moose and its dependencies.
+
+WWW: http://search.cpan.org/dist/GIS-Distance-Lite/
diff --git a/math/p5-GIS-Distance-Lite/pkg-plist b/math/p5-GIS-Distance-Lite/pkg-plist
new file mode 100644
index 000000000000..ff0eefb1d388
--- /dev/null
+++ b/math/p5-GIS-Distance-Lite/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GIS/Distance/Lite/.packlist
+%%SITE_PERL%%/GIS/Distance/Lite.pm
+@dirrmtry %%SITE_PERL%%/GIS/Distance/Lite
+@dirrmtry %%SITE_PERL%%/GIS/Distance
+@dirrmtry %%SITE_PERL%%/GIS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/GIS/Distance/Lite
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/GIS/Distance
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/GIS