aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2005-11-05 09:21:14 +0000
committerKris Kennaway <kris@FreeBSD.org>2005-11-05 09:21:14 +0000
commit89a727e1d0c72cd76c0463101e12e5de499234bb (patch)
tree467d7f32a54f170c71df0820e619474b485f1f81 /math
parentff8b1e88ddc7452c70af86c2bcb41ab2960de741 (diff)
downloadports-89a727e1d0c72cd76c0463101e12e5de499234bb.tar.gz
ports-89a727e1d0c72cd76c0463101e12e5de499234bb.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile2
-rw-r--r--math/glove/Makefile103
-rw-r--r--math/glove/distinfo2
-rw-r--r--math/glove/files/patch-aa28
-rw-r--r--math/glove/files/patch-ab11
-rw-r--r--math/glove/files/patch-ac11
-rw-r--r--math/glove/files/patch-ad43
-rw-r--r--math/glove/pkg-descr8
-rw-r--r--math/glove/pkg-plist4
-rw-r--r--math/thx_1138/Makefile104
-rw-r--r--math/thx_1138/distinfo2
-rw-r--r--math/thx_1138/files/patch-aa28
-rw-r--r--math/thx_1138/files/patch-ab29
-rw-r--r--math/thx_1138/pkg-descr17
-rw-r--r--math/thx_1138/pkg-plist4
15 files changed, 0 insertions, 396 deletions
diff --git a/math/Makefile b/math/Makefile
index 20b5b373f266..0c84fcf818b6 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -73,7 +73,6 @@
SUBDIR += geonext
SUBDIR += gexpr
SUBDIR += glgraph
- SUBDIR += glove
SUBDIR += glpk
SUBDIR += gnumeric
SUBDIR += gnuplot
@@ -264,7 +263,6 @@
SUBDIR += superlu_mt
SUBDIR += surf
SUBDIR += taucs
- SUBDIR += thx_1138
SUBDIR += tomsfastmath
SUBDIR += topaz
SUBDIR += triangle
diff --git a/math/glove/Makefile b/math/glove/Makefile
deleted file mode 100644
index 0fd8aa4489ff..000000000000
--- a/math/glove/Makefile
+++ /dev/null
@@ -1,103 +0,0 @@
-# New ports collection makefile for: Glove
-# Date created: 14 June 2000
-# Whom: Mario S F Ferreira <lioux@linf.unb.br> et al.
-#
-# $FreeBSD$
-#
-
-PORTNAME= glove
-PORTVERSION= 1.0.1
-PORTREVISION= 1
-CATEGORIES= math
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= lioux
-DISTNAME= Glove_source-${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Data acquisition, manipulation, and analysis program for X
-
-EXTRACT_DEPENDS= ${NONEXISTENT}:${JXPORT}:configure
-BUILD_DEPENDS= makemake:${JXPORT}
-LIB_DEPENDS= jx-1_5_3.1:${JXPORT} \
- j2dplot-0_6_5.0:${PORTSDIR}/x11-toolkits/libj2dplot \
- jparser-1_1_8.1:${PORTSDIR}/x11-toolkits/libjparser
-
-WRKSRC= ${WRKDIR}/JX-1.5.3
-
-USE_XLIB= yes
-USE_GMAKE= yes
-MAKE_ARGS= CC="${CC}" CXX="${CXX}" \
- CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
-MAKE_ENV= JX_INSTALL_ROOT="${X11BASE}/bin" \
- JX_LIB_ROOT="${X11BASE}/lib"
-PLIST_SUB= PORTNAME="${PORTNAME}"
-
-# Make environment
-PORTINCLUDES= -I${X11BASE}/include/jx \
- -I${X11BASE}/include/jcore \
- -I${X11BASE}/include/j2dplot \
- -I${X11BASE}/include/jparser
-
-# Installs dir with proper permissions
-INSTALL_DATA_DIR= ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755
-# program files
-PROGRAMFILES= glove/glove
-# documents
-DOCFILES= LICENSE README.binary
-DOCDIR_PREFIX= ${PREFIX}/share/doc/${PORTNAME}
-# additional configuration and header files
-EXTRALIB_PREFIX= ${X11BASE}/lib/jx
-EXTRALIBFILES_MAKE_WRKSRC= include/make
-# main jx distribution files needed for building
-COPY_JXDIRS= include
-COPY_JXFILES= Makefile
-
-.include <bsd.port.pre.mk>
-
-# main jx distribution port wrksrc
-JXPORT= ${PORTSDIR}/x11-toolkits/jx
-JXPORT_WRKSRC!= cd ${JXPORT} && ${MAKE} -V WRKSRC
-JX_MAKE_CONSTANTS= j2dplot_constants jparser_constants
-
-.if ${OSVERSION} >= 300000
-ALL_TARGET= freebsd3.x
-.else
-ALL_TARGET= freebsd2.x
-.endif
-
-post-extract:
-.for i in ${COPY_JXDIRS}
- @${CP} -Rp ${JXPORT_WRKSRC}/${i} ${WRKSRC}
-.endfor
-.for i in ${COPY_JXFILES}
- @${CP} -p ${JXPORT_WRKSRC}/${i} ${WRKSRC}
-.endfor
-
-post-patch:
- @${ECHO_CMD} "SEARCHDIRS += ${PORTINCLUDES}" >> \
- ${WRKSRC}/${EXTRALIBFILES_MAKE_WRKSRC}/jx_constants
-
-pre-build:
-.for i in ${JX_MAKE_CONSTANTS}
- @${LN} -sf ${EXTRALIB_PREFIX}/make/${i} ${WRKSRC}/include/make
-.endfor
-
-post-build:
- @cd ${WRKSRC}/programs/${PORTNAME}; ${SETENV} ${MAKE_ENV} makemake; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
- ${MAKEFILE} ${MAKE_ARGS}
-
-do-install:
-.if !defined(NOPORTDOCS)
-# Install all documentation
- @${INSTALL_DATA_DIR} ${DOCDIR_PREFIX}
-.for i in ${DOCFILES}
- @${INSTALL_DATA} ${WRKSRC}/programs/${PORTNAME}/${i} ${DOCDIR_PREFIX}
-.endfor
-.endif # !defined(NOPORTDOCS)
-# Install all programs
-.for i in ${PROGRAMFILES}
- @${INSTALL_PROGRAM} ${WRKSRC}/programs/${i} ${PREFIX}/bin
-.endfor
-
-.include <bsd.port.post.mk>
diff --git a/math/glove/distinfo b/math/glove/distinfo
deleted file mode 100644
index 2ece10d88a96..000000000000
--- a/math/glove/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (Glove_source-1.0.1.tar.gz) = a1fda27724402d7a1556c491fdcd052f
-SIZE (Glove_source-1.0.1.tar.gz) = 122180
diff --git a/math/glove/files/patch-aa b/math/glove/files/patch-aa
deleted file mode 100644
index 18be5d2d2db3..000000000000
--- a/math/glove/files/patch-aa
+++ /dev/null
@@ -1,28 +0,0 @@
---- Makefile.orig Sat Sep 11 17:44:38 1999
-+++ Makefile Wed Jun 14 01:07:15 2000
-@@ -262,25 +262,11 @@
- freebsd2.x: prep
- @ln -s sys/FreeBSD-2.x_g++ \
- include/make/jx_config
-- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
-- include/jcore/jMissingProto.h
-- @ln -s config-freebsd.h \
-- ACE/ACE_wrappers/ace/config.h
-- @ln -s platform_freebsd.GNU \
-- ACE/ACE_wrappers/include/makeinclude/platform_macros.GNU
-- @${INSTALL_CMD}
-
- .PHONY : freebsd3.x
- freebsd3.x: prep
- @ln -s sys/FreeBSD-3.x_g++ \
- include/make/jx_config
-- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
-- include/jcore/jMissingProto.h
-- @ln -s config-freebsd-pthread.h \
-- ACE/ACE_wrappers/ace/config.h
-- @ln -s platform_freebsd_pthread.GNU \
-- ACE/ACE_wrappers/include/makeinclude/platform_macros.GNU
-- @${INSTALL_CMD}
-
- #
- # SunOS 4.x
diff --git a/math/glove/files/patch-ab b/math/glove/files/patch-ab
deleted file mode 100644
index 08f994d2573c..000000000000
--- a/math/glove/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/make/sys/FreeBSD-2.x_g++.orig Wed Jun 14 01:44:51 2000
-+++ include/make/sys/FreeBSD-2.x_g++ Wed Jun 14 01:45:00 2000
-@@ -35,7 +35,7 @@
- # Comment this out if ACE or other code gives you warnings that
- # you can't avoid.
-
--J_DIE_ON_WARNING := -Werror
-+#J_DIE_ON_WARNING := -Werror
-
- # Uncomment this if istrstream is broken. One way to check is to run
- # testjcore/testJFileArray.
diff --git a/math/glove/files/patch-ac b/math/glove/files/patch-ac
deleted file mode 100644
index 464c4221d3af..000000000000
--- a/math/glove/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/make/sys/FreeBSD-3.x_g++.orig Wed Jun 14 01:44:51 2000
-+++ include/make/sys/FreeBSD-3.x_g++ Wed Jun 14 01:45:00 2000
-@@ -35,7 +35,7 @@
- # Comment this out if ACE or other code gives you warnings that
- # you can't avoid.
-
--J_DIE_ON_WARNING := -Werror
-+#J_DIE_ON_WARNING := -Werror
-
- # Uncomment this if istrstream is broken. One way to check is to run
- # testjcore/testJFileArray.
diff --git a/math/glove/files/patch-ad b/math/glove/files/patch-ad
deleted file mode 100644
index 22ab10dde702..000000000000
--- a/math/glove/files/patch-ad
+++ /dev/null
@@ -1,43 +0,0 @@
---- programs/glove/Make.header.orig Fri Sep 24 15:41:45 1999
-+++ programs/glove/Make.header Wed Jun 14 22:55:54 2000
-@@ -17,14 +17,15 @@
-
- # Directories to search for header files
-
--SEARCHDIRS := -I- \
-+SEARCHDIRS = -I- \
- -I${CODEDIR} \
- -I${PLOTDIR} \
- -I${JCOREDIR} \
- -I${JXDIR} \
- -I${JPARSEDIR} \
- -I${J2DPLOTDIR} \
-- -I${ACE_ROOT}
-+ -I${ACE_ROOT} \
-+ ${J_X11_INCLUDE_DIR}
-
- # other constants
-
-@@ -41,13 +42,6 @@
-
- # library dependencies
-
--ifdef J_BUILD_SHARED_LIB
-- LIB_DEPS := ${JLIBDIR}/libjparser-${JPARSER_LIB_VERSION}.so \
-- ${JLIBDIR}/libj2dplot-${J2DPLOT_LIB_VERSION}.so
--else
-- LIB_DEPS := ${JLIBDIR}/libjparser-${JPARSER_LIB_VERSION}.a \
-- ${JLIBDIR}/libj2dplot-${J2DPLOT_LIB_VERSION}.a
--endif
-
- # make variables
-
-@@ -64,7 +58,7 @@
- #####
-
- .PHONY : default
--default: libs glove
-+default: glove
-
- .PHONY : Makefiles
- Makefiles:
diff --git a/math/glove/pkg-descr b/math/glove/pkg-descr
deleted file mode 100644
index 99d65132d67a..000000000000
--- a/math/glove/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-Glove
-
-Glove was developed for use in Caltech physics labs to provide an
-interface to data acquisition systems, sophisticated (and correct)
-statistical analysis, a flexible plotting tool, and the ability to
-easily and intuitively manipulate the data.
-
-WWW: http://www.newplanetsoftware.com/glove/
diff --git a/math/glove/pkg-plist b/math/glove/pkg-plist
deleted file mode 100644
index 24a9044ba4ae..000000000000
--- a/math/glove/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/glove
-%%PORTDOCS%%share/doc/%%PORTNAME%%/LICENSE
-%%PORTDOCS%%share/doc/%%PORTNAME%%/README.binary
-%%PORTDOCS%%@dirrm share/doc/%%PORTNAME%%
diff --git a/math/thx_1138/Makefile b/math/thx_1138/Makefile
deleted file mode 100644
index 5a420e5b41a3..000000000000
--- a/math/thx_1138/Makefile
+++ /dev/null
@@ -1,104 +0,0 @@
-# New ports collection makefile for: thx-1138
-# Date created: 14 June 2000
-# Whom: Mario S F Ferreira <lioux@linf.unb.br> et al.
-#
-# $FreeBSD$
-#
-
-PORTNAME= thx_1138
-PORTVERSION= 1.0.5
-PORTREVISION= 1
-CATEGORIES= math
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= lioux
-DISTNAME= ${PORTNAME:S,_,-,}_source-${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Electronic Paper for Calculations and Graphs
-
-EXTRACT_DEPENDS= ${NONEXISTENT}:${JXPORT}:configure
-BUILD_DEPENDS= makemake:${JXPORT}
-LIB_DEPENDS= jx-1_5_3.1:${JXPORT} \
- j2dplot-0_6_5.0:${PORTSDIR}/x11-toolkits/libj2dplot \
- jparser-1_1_8.1:${PORTSDIR}/x11-toolkits/libjparser
-
-WRKSRC= ${WRKDIR}/JX-1.5.3
-
-USE_XLIB= yes
-USE_GMAKE= yes
-MAKE_ARGS= CC="${CC}" CXX="${CXX}" \
- CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
-MAKE_ENV= JX_INSTALL_ROOT="${X11BASE}/bin" \
- JX_LIB_ROOT="${X11BASE}/lib"
-PLIST_SUB= PORTNAME="${PORTNAME:S,_,-,}"
-
-# Make environment
-PORTINCLUDES= -I${X11BASE}/include/jx \
- -I${X11BASE}/include/jcore \
- -I${X11BASE}/include/j2dplot \
- -I${X11BASE}/include/jparser \
- -I${X11BASE}/include
-
-# Installs dir with proper permissions
-INSTALL_DATA_DIR= ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755
-# program files
-PROGRAMFILES= thx-1138/thx-1138
-# documents
-DOCFILES= LICENSE README.binary
-DOCDIR_PREFIX= ${PREFIX}/share/doc/${PORTNAME:S,_,-,}
-# additional configuration and header files
-EXTRALIB_PREFIX= ${X11BASE}/lib/jx
-EXTRALIBFILES_MAKE_WRKSRC= include/make
-# main jx distribution files needed for building
-COPY_JXDIRS= include
-COPY_JXFILES= Makefile
-
-.include <bsd.port.pre.mk>
-
-# main jx distribution port wrksrc
-JXPORT= ${PORTSDIR}/x11-toolkits/jx
-JXPORT_WRKSRC!= cd ${JXPORT} && ${MAKE} -V WRKSRC
-JX_MAKE_CONSTANTS= j2dplot_constants jparser_constants
-
-.if ${OSVERSION} >= 300000
-ALL_TARGET= freebsd3.x
-.else
-ALL_TARGET= freebsd2.x
-.endif
-
-post-extract:
-.for i in ${COPY_JXDIRS}
- @${CP} -Rp ${JXPORT_WRKSRC}/${i} ${WRKSRC}
-.endfor
-.for i in ${COPY_JXFILES}
- @${CP} -p ${JXPORT_WRKSRC}/${i} ${WRKSRC}
-.endfor
-
-post-patch:
- @${ECHO_CMD} "SEARCHDIRS += ${PORTINCLUDES}" >> \
- ${WRKSRC}/${EXTRALIBFILES_MAKE_WRKSRC}/jx_constants
-
-pre-build:
-.for i in ${JX_MAKE_CONSTANTS}
- @${LN} -sf ${EXTRALIB_PREFIX}/make/${i} ${WRKSRC}/include/make
-.endfor
-
-post-build:
- @cd ${WRKSRC}/programs/${PORTNAME:S,_,-,}; ${SETENV} ${MAKE_ENV} makemake; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
- ${MAKEFILE} ${MAKE_ARGS}
-
-do-install:
-.if !defined(NOPORTDOCS)
-# Install all documentation
- @${INSTALL_DATA_DIR} ${DOCDIR_PREFIX}
-.for i in ${DOCFILES}
- @${INSTALL_DATA} ${WRKSRC}/programs/${PORTNAME:S,_,-,}/${i} ${DOCDIR_PREFIX}
-.endfor
-.endif # !defined(NOPORTDOCS)
-# Install all programs
-.for i in ${PROGRAMFILES}
- @${INSTALL_PROGRAM} ${WRKSRC}/programs/${i} ${PREFIX}/bin
-.endfor
-
-.include <bsd.port.post.mk>
diff --git a/math/thx_1138/distinfo b/math/thx_1138/distinfo
deleted file mode 100644
index b14736db54c4..000000000000
--- a/math/thx_1138/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (thx-1138_source-1.0.5.tar.gz) = a0b87c02def611b7399717e144820333
-SIZE (thx-1138_source-1.0.5.tar.gz) = 36080
diff --git a/math/thx_1138/files/patch-aa b/math/thx_1138/files/patch-aa
deleted file mode 100644
index 18be5d2d2db3..000000000000
--- a/math/thx_1138/files/patch-aa
+++ /dev/null
@@ -1,28 +0,0 @@
---- Makefile.orig Sat Sep 11 17:44:38 1999
-+++ Makefile Wed Jun 14 01:07:15 2000
-@@ -262,25 +262,11 @@
- freebsd2.x: prep
- @ln -s sys/FreeBSD-2.x_g++ \
- include/make/jx_config
-- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
-- include/jcore/jMissingProto.h
-- @ln -s config-freebsd.h \
-- ACE/ACE_wrappers/ace/config.h
-- @ln -s platform_freebsd.GNU \
-- ACE/ACE_wrappers/include/makeinclude/platform_macros.GNU
-- @${INSTALL_CMD}
-
- .PHONY : freebsd3.x
- freebsd3.x: prep
- @ln -s sys/FreeBSD-3.x_g++ \
- include/make/jx_config
-- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
-- include/jcore/jMissingProto.h
-- @ln -s config-freebsd-pthread.h \
-- ACE/ACE_wrappers/ace/config.h
-- @ln -s platform_freebsd_pthread.GNU \
-- ACE/ACE_wrappers/include/makeinclude/platform_macros.GNU
-- @${INSTALL_CMD}
-
- #
- # SunOS 4.x
diff --git a/math/thx_1138/files/patch-ab b/math/thx_1138/files/patch-ab
deleted file mode 100644
index ece2573e263d..000000000000
--- a/math/thx_1138/files/patch-ab
+++ /dev/null
@@ -1,29 +0,0 @@
---- programs/thx-1138/Make.header.orig Thu Jun 15 00:07:41 2000
-+++ programs/thx-1138/Make.header Thu Jun 15 00:08:06 2000
-@@ -47,17 +47,6 @@
-
- # library dependencies
-
--ifdef J_BUILD_SHARED_LIB
-- LIB_DEPS := ${JLIBDIR}/libjcore-${JX_LIB_VERSION}.so \
-- ${JLIBDIR}/libjx-${JX_LIB_VERSION}.so \
-- ${JLIBDIR}/libjparser-${JPARSER_LIB_VERSION}.so \
-- ${JLIBDIR}/libj2dplot-${J2DPLOT_LIB_VERSION}.so
--else
-- LIB_DEPS := ${JLIBDIR}/libjcore-${JX_LIB_VERSION}.a \
-- ${JLIBDIR}/libjx-${JX_LIB_VERSION}.a \
-- ${JLIBDIR}/libjparser-${JPARSER_LIB_VERSION}.a \
-- ${JLIBDIR}/libj2dplot-${J2DPLOT_LIB_VERSION}.a
--endif
-
- # make variables
-
-@@ -68,7 +57,7 @@
- #####
-
- .PHONY : default
--default: libs thx-1138
-+default: thx-1138
-
- .PHONY : Makefiles
- Makefiles:
diff --git a/math/thx_1138/pkg-descr b/math/thx_1138/pkg-descr
deleted file mode 100644
index a9d06bb4aab9..000000000000
--- a/math/thx_1138/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-THX-1138
-
-From the software readme:
-
-THX-1138 is the calculator you've always wanted, short of handwriting
-recognition.
-
-THX-1138 (pronounced "thex") provides a calculator and the ability
-to plot functions.
-
-I chose the name as a tribute to the character in George Lucas'
-movie. Free software and old SF movies do not compete, and I
-encourage everybody to rent the movie, but if anybody still wants
-to sue me, please remember that I don't have enough money to make
-it worth the trouble, so just notify me, and I'll change the name.
-
-WWW: http://www.newplanetsoftware.com/thx/
diff --git a/math/thx_1138/pkg-plist b/math/thx_1138/pkg-plist
deleted file mode 100644
index edd208503693..000000000000
--- a/math/thx_1138/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/thx-1138
-%%PORTDOCS%%share/doc/%%PORTNAME%%/LICENSE
-%%PORTDOCS%%share/doc/%%PORTNAME%%/README.binary
-%%PORTDOCS%%@dirrm share/doc/%%PORTNAME%%