aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2015-02-01 22:04:52 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2015-02-01 22:04:52 +0000
commit364fed1ae0ef72a573338d9876c9be007f54a736 (patch)
treefa6090db93f7cbdcdba1ef8d71f9d490807a394d /math
parentd22fafe1b139a69ac1bf1a1a66cd31d5bf2913dd (diff)
downloadports-364fed1ae0ef72a573338d9876c9be007f54a736.tar.gz
ports-364fed1ae0ef72a573338d9876c9be007f54a736.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-interval/Makefile27
-rw-r--r--math/octave-forge-interval/distinfo2
-rw-r--r--math/octave-forge-interval/files/patch-Makefile11
-rw-r--r--math/octave-forge-interval/pkg-descr12
-rw-r--r--math/octave-forge-interval/pkg-plist1
6 files changed, 54 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 60787b1c26b0..0004460db881 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -303,6 +303,7 @@
SUBDIR += octave-forge-image
SUBDIR += octave-forge-informationtheory
SUBDIR += octave-forge-integration
+ SUBDIR += octave-forge-interval
SUBDIR += octave-forge-io
SUBDIR += octave-forge-irsa
SUBDIR += octave-forge-linear-algebra
diff --git a/math/octave-forge-interval/Makefile b/math/octave-forge-interval/Makefile
new file mode 100644
index 000000000000..3b9d93fa4585
--- /dev/null
+++ b/math/octave-forge-interval/Makefile
@@ -0,0 +1,27 @@
+# Created by: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+# $FreeBSD$
+
+PORTNAME= octave-forge-interval
+PORTVERSION= 0.1.1
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libmpfr.so:${PORTSDIR}/math/mpfr
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-interval/distinfo b/math/octave-forge-interval/distinfo
new file mode 100644
index 000000000000..583482b96067
--- /dev/null
+++ b/math/octave-forge-interval/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/interval-0.1.1.tar.gz) = 84a33f0aa6c9adbb49847f3eb5d83dad64a639ab30df0744f940451a0d339aad
+SIZE (octave-forge/interval-0.1.1.tar.gz) = 99113
diff --git a/math/octave-forge-interval/files/patch-Makefile b/math/octave-forge-interval/files/patch-Makefile
new file mode 100644
index 000000000000..0b3c33b34f8b
--- /dev/null
+++ b/math/octave-forge-interval/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile-orig 2015-02-01 21:41:06.000000000 +0000
++++ Makefile 2015-02-01 21:41:39.000000000 +0000
+@@ -9,7 +9,7 @@
+ all: $(OBJ)
+
+ mpfr_%.oct: mpfr_%.cc mpfr_commons.cc
+- $(MKOCTFILE) $(CFLAGS) -o $@ $(LDFLAGS) $(LDFLAGS_MPFR) $<
++ $(MKOCTFILE) -o $@ $(LDFLAGS_MPFR) $<
+
+ # The following build target are not required for the package installation
+ # process, but are used during development of the package.
diff --git a/math/octave-forge-interval/pkg-descr b/math/octave-forge-interval/pkg-descr
new file mode 100644
index 000000000000..aaaf4f5c5763
--- /dev/null
+++ b/math/octave-forge-interval/pkg-descr
@@ -0,0 +1,12 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is interval.
+
+ The package provides data types for verified computing. The implementation
+ of intervals in inf-sup format is based on interval boundaries represented
+ by binary64 numbers and is standard conforming to IEEE 1788.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-interval/pkg-plist b/math/octave-forge-interval/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-interval/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty