aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-06-22 18:33:20 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-06-22 18:33:20 +0000
commit6e5719ca80bba1b1c1a97fa29ba2147a5c1ba81e (patch)
treebdb6dbf3e5d4ada04784a3327eb91e0145530524 /math
parentb8355694f11dec2ab058a135acfc1a0f3c8967c0 (diff)
Notes
Diffstat (limited to 'math')
-rw-r--r--math/R/Makefile2
-rw-r--r--math/giacxcas/Makefile3
-rw-r--r--math/grace/Makefile3
-rw-r--r--math/ploticus/Makefile2
-rw-r--r--math/reduce/Makefile4
-rw-r--r--math/sage/Makefile5
-rw-r--r--math/surf/Makefile4
-rw-r--r--math/vtk5/Makefile3
-rw-r--r--math/vtk6/Makefile3
9 files changed, 12 insertions, 17 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index 011d299e801d..6aef58114e5d 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -200,7 +200,7 @@ USE_GHOSTSCRIPT_RUN= yes
.endif
.if ${PORT_OPTIONS:MJPEG}
-LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
+USES+= jpeg
CONFIGURE_ARGS+= --with-jpeglib
.else
CONFIGURE_ARGS+= --without-jpeglib
diff --git a/math/giacxcas/Makefile b/math/giacxcas/Makefile
index 2f25292d4eab..fef1f4d2ee8a 100644
--- a/math/giacxcas/Makefile
+++ b/math/giacxcas/Makefile
@@ -20,7 +20,6 @@ BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
${LOCALBASE}/lib/libntl.a:${PORTSDIR}/math/ntl
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpari.so:${PORTSDIR}/math/pari \
libmpfr.so:${PORTSDIR}/math/mpfr \
libgsl.so:${PORTSDIR}/math/gsl \
@@ -29,7 +28,7 @@ LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
NO_CDROM= French documentation is for non-commercial use only
GNU_CONFIGURE= yes
-USES= desktop-file-utils gettext gmake libtool shebangfix
+USES= desktop-file-utils gettext gmake jpeg libtool shebangfix
USE_GL= gl
USE_XORG= x11 xcursor xft xi
USE_TEX= latex:build dvipsk:build
diff --git a/math/grace/Makefile b/math/grace/Makefile
index 07d9fe4ea705..d51749057d41 100644
--- a/math/grace/Makefile
+++ b/math/grace/Makefile
@@ -16,12 +16,11 @@ COMMENT= Powerful 2D plotting tool (successor of xmgr)
LICENSE= GPLv2
LIB_DEPENDS= libt1.so:${PORTSDIR}/devel/t1lib \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng.so:${PORTSDIR}/graphics/png \
libXbae.so:${PORTSDIR}/x11-toolkits/xbae
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
-USES= gmake motif
+USES= gmake jpeg motif
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-grace-home=${DATADIR} \
--with-extra-incpath=${LOCALBASE}/include \
diff --git a/math/ploticus/Makefile b/math/ploticus/Makefile
index 4c24e0cdd928..c8d77da0b5c0 100644
--- a/math/ploticus/Makefile
+++ b/math/ploticus/Makefile
@@ -12,11 +12,11 @@ MAINTAINER?= linimon@FreeBSD.org
COMMENT?= Generates plots and graphs from data
LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libming.so:${PORTSDIR}/graphics/ming \
libpng.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2
+USES= jpeg
BUILD_WRKSRC= ${WRKSRC}/src
FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
diff --git a/math/reduce/Makefile b/math/reduce/Makefile
index 0ff3a6fa35b6..4d15dd02cc09 100644
--- a/math/reduce/Makefile
+++ b/math/reduce/Makefile
@@ -38,9 +38,9 @@ OPTIONS_SUB= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCSL}
-LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
+USES+= jpeg
CPPFLAGS+= `freetype-config --cflags`
LDFLAGS+= `freetype-config --libs`
.else
diff --git a/math/sage/Makefile b/math/sage/Makefile
index 064b518916a4..c8ebd2d3a84f 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -23,8 +23,7 @@ BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
automake:${PORTSDIR}/devel/automake \
autoconf:${PORTSDIR}/devel/autoconf
LIB_DEPENDS= libatlas.so:${PORTSDIR}/math/atlas \
- liblapack.so:${PORTSDIR}/math/lapack \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
+ liblapack.so:${PORTSDIR}/math/lapack
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
pre-extract:
@@ -37,7 +36,7 @@ pre-extract:
PLIST_FILES= bin/sage
USE_TEX= latex:build
-USES= gmake iconv tk perl5
+USES= gmake iconv jpeg tk perl5
MAKE_JOBS_SAFE= yes
# Optimization flags will be defined by the source
diff --git a/math/surf/Makefile b/math/surf/Makefile
index 050bf3dabab2..2cb6a24770e8 100644
--- a/math/surf/Makefile
+++ b/math/surf/Makefile
@@ -12,10 +12,10 @@ COMMENT= Visualize some real algebraic geometry
LICENSE= GPLv2
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libtiff.so:${PORTSDIR}/graphics/tiff \
+LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libgmp.so:${PORTSDIR}/math/gmp
+USES= jpeg
USE_XORG= x11 xmu
USE_GNOME= gtk12
GNU_CONFIGURE= yes
diff --git a/math/vtk5/Makefile b/math/vtk5/Makefile
index 7ccd78e91ce1..44ec24d3d0c8 100644
--- a/math/vtk5/Makefile
+++ b/math/vtk5/Makefile
@@ -16,7 +16,6 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/Copyright.txt
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
@@ -26,7 +25,7 @@ CONFLICTS= vtk-4*
SUB_FILES= vtk.3
-USES= cmake:outsource
+USES= cmake:outsource jpeg
USE_XORG= xt
USE_LDCONFIG= ${PREFIX}/lib/vtk-${PORTVERSION:R}
CXXFLAGS+= -DUSE_INTERP_ERRORLINE
diff --git a/math/vtk6/Makefile b/math/vtk6/Makefile
index dce565dc5c83..d55d8fb0f0ff 100644
--- a/math/vtk6/Makefile
+++ b/math/vtk6/Makefile
@@ -16,7 +16,6 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libpng.so:${PORTSDIR}/graphics/png \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libexpat.so:${PORTSDIR}/textproc/expat2
@@ -29,7 +28,7 @@ UNIQUENAME= ${PKGBASE}
CONFLICTS= vtk-4*
USE_LDCONFIG= ${PREFIX}/lib/vtk-${VTK_SHORT_VER}
USE_XORG= xt
-USES= cmake:outsource
+USES= cmake:outsource jpeg
CXXFLAGS+= -I${LOCALBASE}/include
VTK_SHORT_VER= ${PORTVERSION:R}