aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-01-13 09:35:55 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-01-13 09:35:55 +0000
commitb0ccea25412abd6a3c7888ea5934c8e3d398df75 (patch)
tree901457e9f0aeedc36a478d5532735b52b9400a85 /math
parenta3ad47de4a47cc6082530a2f15778facdf7edfa1 (diff)
Notes
Diffstat (limited to 'math')
-rw-r--r--math/it++/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/math/it++/Makefile b/math/it++/Makefile
index 91dc260579c6..c0989d21d495 100644
--- a/math/it++/Makefile
+++ b/math/it++/Makefile
@@ -8,6 +8,7 @@
PORTNAME= it++
PORTVERSION= 3.8.0
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= itpp
@@ -16,14 +17,26 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Mathematical, signal processing and communication library
-LIB_DEPENDS= atlas.1:${PORTSDIR}/math/atlas
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+WITH_ATLAS= yes
+.endif
+.if defined(WITH_ATLAS)
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+BLAS= -lf77blas -latlas
+.else
+LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
+BLAS= -lblas
+.endif
HAS_CONFIGURE= yes
CONFIGURE_ARGS= opt
USE_GMAKE= yes
USE_GCC= 3.3+
-
-.include <bsd.port.pre.mk>
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
post-patch:
@${REINPLACE_CMD} -e "s|sparc|__sparc__|" \