aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 17:16:10 +0000
commit19a718ac4c38750e766de7abf027f0491981495d (patch)
tree8fad9fa05facfd939ca92589f047e5224dffd236 /math
parent47c68887b223642a73baccd0fa69c8caf7845044 (diff)
downloadports-19a718ac4c38750e766de7abf027f0491981495d.tar.gz
ports-19a718ac4c38750e766de7abf027f0491981495d.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/gnumeric/Makefile8
-rw-r--r--math/gnumeric2/Makefile8
-rw-r--r--math/guppi/Makefile10
-rw-r--r--math/guppi/files/patch-Makefile.in16
4 files changed, 15 insertions, 27 deletions
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index 38eac4e72346..9edf58e312bb 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -24,7 +24,8 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs bonobo libglade gal
USE_PYTHON= yes
USE_REINPLACE= yes
USE_LIBTOOL= yes
@@ -36,12 +37,9 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}-bonobo
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
- s|[(]datadir[)]/locale|(prefix)/share/locale|g'
post-install:
.for dir in share/gnome lib
diff --git a/math/gnumeric2/Makefile b/math/gnumeric2/Makefile
index 38eac4e72346..9edf58e312bb 100644
--- a/math/gnumeric2/Makefile
+++ b/math/gnumeric2/Makefile
@@ -24,7 +24,8 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs bonobo libglade gal
USE_PYTHON= yes
USE_REINPLACE= yes
USE_LIBTOOL= yes
@@ -36,12 +37,9 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION=${PORTVERSION}-bonobo
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
- s|[(]datadir[)]/locale|(prefix)/share/locale|g'
post-install:
.for dir in share/gnome lib
diff --git a/math/guppi/Makefile b/math/guppi/Makefile
index 82488c817e93..7f40bb5df4d4 100644
--- a/math/guppi/Makefile
+++ b/math/guppi/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= guile.10:${PORTSDIR}/lang/guile
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs bonobo libglade gal
USE_PYTHON= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
@@ -36,11 +37,8 @@ PLIST_SUB= VERSION="${PORTVERSION}"
post-extract:
@cd ${PORTSDIR}/math/gnumeric && ${MAKE} patch
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/math/guppi/files/patch-Makefile.in b/math/guppi/files/patch-Makefile.in
index b8891ef7e9f9..de132b24be95 100644
--- a/math/guppi/files/patch-Makefile.in
+++ b/math/guppi/files/patch-Makefile.in
@@ -1,24 +1,18 @@
$FreeBSD$
---- Makefile.in.orig Fri Nov 23 18:19:00 2001
-+++ Makefile.in Fri Nov 23 18:19:44 2001
-@@ -205,12 +205,12 @@
+--- Makefile.in.orig Thu Jul 11 04:03:22 2002
++++ Makefile.in Thu Jul 11 04:04:37 2002
+@@ -197,7 +197,7 @@
#appdir = $(datadir)/apps/Applications
#app_DATA = guppi.desktop
-confexecdir = $(libdir)
-+confexecdir = $(prefix)/etc
++confexecdir = $(sysconfdir)
confexec_DATA = libguppiConf.sh
CLEANFILES = libguppiConf.sh xml-i18n-extract xml-i18n-merge xml-i18n-update
-
--aclocaldir = $(datadir)/aclocal
-+aclocaldir = $(prefix)/share/aclocal
- aclocal_DATA = libguppi.m4
-
- EXTRA_DIST = ChangeLog README AUTHORS NEWS BIBLIOGRAPHY libguppiConf.sh.in libguppi.m4 xml-i18n-extract.in xml-i18n-merge.in xml-i18n-update.in
-@@ -545,10 +545,10 @@
+@@ -537,10 +537,10 @@
libguppiConf.sh: libguppiConf.sh.in Makefile