aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2014-01-24 15:44:33 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2014-01-24 15:44:33 +0000
commit3cf915a146f21020f9e298f0377cbe7875146d5d (patch)
tree822590b38881578673bd2b58a743f3b22ad73068 /math
parent829691ae86cfb6afe6fbbf18213e6536361bc536 (diff)
downloadports-3cf915a146f21020f9e298f0377cbe7875146d5d.tar.gz
ports-3cf915a146f21020f9e298f0377cbe7875146d5d.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/gringo/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/math/gringo/Makefile b/math/gringo/Makefile
index 674f5b93e2fe..0a16823c9f98 100644
--- a/math/gringo/Makefile
+++ b/math/gringo/Makefile
@@ -4,6 +4,7 @@
PORTNAME= gringo
PORTVERSION= 4.2.1
DISTVERSIONSUFFIX= -source
+PORTREVISION= 1
CATEGORIES= math devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= potassco/${PORTNAME}/${PORTVERSION}
@@ -11,17 +12,24 @@ MASTER_SITE_SUBDIR= potassco/${PORTNAME}/${PORTVERSION}
MAINTAINER= vsevolod@FreeBSD.org
COMMENT= Grounding algorithm based on semi-naive database evaluation
+LICENSE= GPLv3
+
BUILD_DEPENDS= re2c:${PORTSDIR}/devel/re2c
-USES= scons lua:51+ bison
+USES= scons bison
-MAKE_ARGS+= ${MAKE_ENV} WITH_LUA="lua-${LUA_VER}"
-CXXFLAGS+= -std=c++11 -I${LUA_INCDIR}
-LDFLAGS+= -L${LUA_LIBDIR}
+MAKE_ARGS+= ${MAKE_ENV}
+CXXFLAGS+= -std=c++11
PLIST_FILES= bin/${PORTNAME}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000000
+USE_GCC= 4.8+
+.endif
+
do-install:
${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/build/release/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>