aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>1999-03-09 01:13:40 +0000
committerJacques Vidrine <nectar@FreeBSD.org>1999-03-09 01:13:40 +0000
commitf4442a7aa7d134c8de8574845b26edddcac65935 (patch)
tree0f55c576fb88ce09083373c32ab8312529d29dc5 /math
parentf642b1eef53afa46d333b0f0cb5bf670d5bd8df1 (diff)
downloadports-f4442a7aa7d134c8de8574845b26edddcac65935.tar.gz
ports-f4442a7aa7d134c8de8574845b26edddcac65935.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/gnumeric/Makefile31
-rw-r--r--math/gnumeric/distinfo2
-rw-r--r--math/gnumeric/files/patch-aa53
-rw-r--r--math/gnumeric/pkg-plist15
-rw-r--r--math/gnumeric2/Makefile31
-rw-r--r--math/gnumeric2/distinfo2
-rw-r--r--math/gnumeric2/files/patch-aa53
-rw-r--r--math/gnumeric2/pkg-plist15
8 files changed, 118 insertions, 84 deletions
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index 2ae3475b4854..7a585b282742 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -1,32 +1,35 @@
# New ports collection makefile for: gnumeric
-# Version required: 0.6
+# Version required: 0.15
# Date created: 08 October 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
-# $Id: Makefile,v 1.6 1999/01/14 20:58:40 vanilla Exp $
+# $Id: Makefile,v 1.7 1999/01/27 08:31:51 fenner Exp $
#
-DISTNAME= gnumeric-0.6
-CATEGORIES= math
+DISTNAME= gnumeric-0.15
+CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= gnumeric
+MASTER_SITE_SUBDIR= gnome-1.0/sources
MAINTAINER= nacai@iname.com
-RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
-LIB_DEPENDS= xml.0:${PORTSDIR}/textproc/libxml \
- gnome.1:${PORTSDIR}/x11/gnomelibs \
- guile.4:${PORTSDIR}/lang/guile
+BUILD_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
+ python:${PORTSDIR}/lang/python
+RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
+ python:${PORTSDIR}/lang/python
+LIB_DEPENDS= xml.0:${PORTSDIR}/textproc/libxml
+
+# implicit dependencies:
+# gettext, xpm, gtk12, guile, gnomelibs
USE_X_PREFIX= yes
+USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome \
- --with-gnome=${X11BASE}
-CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
- -I${X11BASE}/include" \
- GTK_CONFIG="${X11BASE}/bin/gtk11d-config" \
- GLIB_CONFIG="${LOCALBASE}/bin/glib11d-config" \
+ --with-gnome=${X11BASE} --with-guile
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ GTK_CONFIG="${X11BASE}/bin/gtk12-config" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
post-install:
diff --git a/math/gnumeric/distinfo b/math/gnumeric/distinfo
index 0b5453e9d40c..2be32608a144 100644
--- a/math/gnumeric/distinfo
+++ b/math/gnumeric/distinfo
@@ -1 +1 @@
-MD5 (gnumeric-0.6.tar.gz) = 269b2cf9d07c7ff53ef2cd789c05184f
+MD5 (gnumeric-0.15.tar.gz) = e9f51ca42004b5ce0a91cca16b5ab7ee
diff --git a/math/gnumeric/files/patch-aa b/math/gnumeric/files/patch-aa
index 19da91d790de..1c57a9bcda2d 100644
--- a/math/gnumeric/files/patch-aa
+++ b/math/gnumeric/files/patch-aa
@@ -1,34 +1,15 @@
---- configure.orig Tue Jan 5 08:57:49 1999
-+++ configure Fri Jan 15 04:19:33 1999
-@@ -1085,13 +1085,13 @@
- fi
-
- if test "$no_gnome_config" = "yes"; then
-- echo $ac_n "checking for gnomeConf.sh file in $gnome_prefix""... $ac_c" 1>&6
--echo "configure:1090: checking for gnomeConf.sh file in $gnome_prefix" >&5
-- if test -f $gnome_prefix/gnomeConf.sh; then
-+ echo $ac_n "checking for gnomeConf.sh file in $prefix/share/gnome""... $ac_c" 1>&6
-+echo "configure:1090: checking for gnomeConf.sh file in $prefix/share/gnome" >&5
-+ if test -f $prefix/share/gnome/gnomeConf.sh; then
- echo "$ac_t""found" 1>&6
- echo "loading gnome configuration from" \
-- "$gnome_prefix/gnomeConf.sh"
-- . $gnome_prefix/gnomeConf.sh
-+ "$prefix/share/gnome/gnomeConf.sh"
-+ . $prefix/share/gnome/gnomeConf.sh
-
- else
- echo "$ac_t""not found" 1>&6
-@@ -2583,7 +2583,7 @@
+--- configure.orig Wed Feb 24 03:49:18 1999
++++ configure Wed Feb 24 18:46:00 1999
+@@ -3309,7 +3309,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-lxml `gnome-config --libs xml` $LIBS"
-+LIBS="-lxml -lz $LIBS"
++LIBS="`xml-config --libs` $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 2589 "configure"
+ #line 3315 "configure"
#include "confdefs.h"
-@@ -2614,7 +2614,7 @@
+@@ -3340,7 +3340,7 @@
@@ -37,3 +18,25 @@
else
echo "$ac_t""no" 1>&6
+@@ -5557,15 +5557,15 @@
+ fi
+
+
+- USE_INCLUDED_LIBINTL=yes
++# USE_INCLUDED_LIBINTL=yes
+ CATOBJEXT=.gmo
+ INSTOBJEXT=.mo
+ DATADIRNAME=share
+- INTLDEPS='$(top_builddir)/intl/libintl.a'
+- INTLLIBS=$INTLDEPS
+- LIBS=`echo $LIBS | sed -e 's/-lintl//'`
+- nls_cv_header_intl=intl/libintl.h
+- nls_cv_header_libgt=intl/libgettext.h
++# INTLDEPS='$(top_builddir)/intl/libintl.a'
++# INTLLIBS=$INTLDEPS
++# LIBS=`echo $LIBS | sed -e 's/-lintl//'`
++# nls_cv_header_intl=intl/libintl.h
++# nls_cv_header_libgt=intl/libgettext.h
+ fi
+
+ if test "$XGETTEXT" != ":"; then
diff --git a/math/gnumeric/pkg-plist b/math/gnumeric/pkg-plist
index 8f095f2dff65..cbaca5a75b5c 100644
--- a/math/gnumeric/pkg-plist
+++ b/math/gnumeric/pkg-plist
@@ -2,16 +2,24 @@ bin/gnumeric
bin/gnumeric-corba
share/gnome/apps/Applications/gnumeric.desktop
share/gnome/gnumeric/guile/gnumeric_startup.scm
+share/gnome/gnumeric/perl/startup.pl
share/gnome/gnumeric/plugins/libgnumguile.a
share/gnome/gnumeric/plugins/libgnumguile.la
share/gnome/gnumeric/plugins/libgnumguile.so
share/gnome/gnumeric/plugins/libgnumguile.so.0
+share/gnome/gnumeric/plugins/libpython.a
+share/gnome/gnumeric/plugins/libpython.la
+share/gnome/gnumeric/plugins/libpython.so
+share/gnome/gnumeric/plugins/libpython.so.0
share/gnome/gnumeric/plugins/libstat.a
share/gnome/gnumeric/plugins/libstat.la
share/gnome/gnumeric/plugins/libstat.so
share/gnome/gnumeric/plugins/libstat.so.0
+share/gnome/gnumeric/python/gnumeric_startup.py
+share/gnome/mc/templates/gnumeric.desktop
share/gnome/mime-info/gnumeric.keys
share/gnome/mime-info/gnumeric.mime
+share/gnome/pixmaps/gnome-gnumeric-xl.png
share/gnome/pixmaps/gnome-gnumeric.png
share/locale/cs/LC_MESSAGES/gnumeric.mo
share/locale/de/LC_MESSAGES/gnumeric.mo
@@ -29,8 +37,11 @@ share/locale/it/LC_MESSAGES/gnumeric.mo
share/locale/ja/LC_MESSAGES/gnumeric.mo
share/locale/ko/LC_MESSAGES/gnumeric.mo
share/locale/no/LC_MESSAGES/gnumeric.mo
-share/locale/no_NO/LC_MESSAGES/gnumeric.mo
+share/locale/pl/LC_MESSAGES/gnumeric.mo
share/locale/pt/LC_MESSAGES/gnumeric.mo
-@dirrm share/gnome/gnumeric/guile
+share/locale/ru/LC_MESSAGES/gnumeric.mo
+@dirrm share/gnome/gnumeric/python
@dirrm share/gnome/gnumeric/plugins
+@dirrm share/gnome/gnumeric/perl
+@dirrm share/gnome/gnumeric/guile
@dirrm share/gnome/gnumeric
diff --git a/math/gnumeric2/Makefile b/math/gnumeric2/Makefile
index 2ae3475b4854..7a585b282742 100644
--- a/math/gnumeric2/Makefile
+++ b/math/gnumeric2/Makefile
@@ -1,32 +1,35 @@
# New ports collection makefile for: gnumeric
-# Version required: 0.6
+# Version required: 0.15
# Date created: 08 October 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
-# $Id: Makefile,v 1.6 1999/01/14 20:58:40 vanilla Exp $
+# $Id: Makefile,v 1.7 1999/01/27 08:31:51 fenner Exp $
#
-DISTNAME= gnumeric-0.6
-CATEGORIES= math
+DISTNAME= gnumeric-0.15
+CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= gnumeric
+MASTER_SITE_SUBDIR= gnome-1.0/sources
MAINTAINER= nacai@iname.com
-RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
-LIB_DEPENDS= xml.0:${PORTSDIR}/textproc/libxml \
- gnome.1:${PORTSDIR}/x11/gnomelibs \
- guile.4:${PORTSDIR}/lang/guile
+BUILD_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
+ python:${PORTSDIR}/lang/python
+RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
+ python:${PORTSDIR}/lang/python
+LIB_DEPENDS= xml.0:${PORTSDIR}/textproc/libxml
+
+# implicit dependencies:
+# gettext, xpm, gtk12, guile, gnomelibs
USE_X_PREFIX= yes
+USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome \
- --with-gnome=${X11BASE}
-CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
- -I${X11BASE}/include" \
- GTK_CONFIG="${X11BASE}/bin/gtk11d-config" \
- GLIB_CONFIG="${LOCALBASE}/bin/glib11d-config" \
+ --with-gnome=${X11BASE} --with-guile
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ GTK_CONFIG="${X11BASE}/bin/gtk12-config" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
post-install:
diff --git a/math/gnumeric2/distinfo b/math/gnumeric2/distinfo
index 0b5453e9d40c..2be32608a144 100644
--- a/math/gnumeric2/distinfo
+++ b/math/gnumeric2/distinfo
@@ -1 +1 @@
-MD5 (gnumeric-0.6.tar.gz) = 269b2cf9d07c7ff53ef2cd789c05184f
+MD5 (gnumeric-0.15.tar.gz) = e9f51ca42004b5ce0a91cca16b5ab7ee
diff --git a/math/gnumeric2/files/patch-aa b/math/gnumeric2/files/patch-aa
index 19da91d790de..1c57a9bcda2d 100644
--- a/math/gnumeric2/files/patch-aa
+++ b/math/gnumeric2/files/patch-aa
@@ -1,34 +1,15 @@
---- configure.orig Tue Jan 5 08:57:49 1999
-+++ configure Fri Jan 15 04:19:33 1999
-@@ -1085,13 +1085,13 @@
- fi
-
- if test "$no_gnome_config" = "yes"; then
-- echo $ac_n "checking for gnomeConf.sh file in $gnome_prefix""... $ac_c" 1>&6
--echo "configure:1090: checking for gnomeConf.sh file in $gnome_prefix" >&5
-- if test -f $gnome_prefix/gnomeConf.sh; then
-+ echo $ac_n "checking for gnomeConf.sh file in $prefix/share/gnome""... $ac_c" 1>&6
-+echo "configure:1090: checking for gnomeConf.sh file in $prefix/share/gnome" >&5
-+ if test -f $prefix/share/gnome/gnomeConf.sh; then
- echo "$ac_t""found" 1>&6
- echo "loading gnome configuration from" \
-- "$gnome_prefix/gnomeConf.sh"
-- . $gnome_prefix/gnomeConf.sh
-+ "$prefix/share/gnome/gnomeConf.sh"
-+ . $prefix/share/gnome/gnomeConf.sh
-
- else
- echo "$ac_t""not found" 1>&6
-@@ -2583,7 +2583,7 @@
+--- configure.orig Wed Feb 24 03:49:18 1999
++++ configure Wed Feb 24 18:46:00 1999
+@@ -3309,7 +3309,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-lxml `gnome-config --libs xml` $LIBS"
-+LIBS="-lxml -lz $LIBS"
++LIBS="`xml-config --libs` $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 2589 "configure"
+ #line 3315 "configure"
#include "confdefs.h"
-@@ -2614,7 +2614,7 @@
+@@ -3340,7 +3340,7 @@
@@ -37,3 +18,25 @@
else
echo "$ac_t""no" 1>&6
+@@ -5557,15 +5557,15 @@
+ fi
+
+
+- USE_INCLUDED_LIBINTL=yes
++# USE_INCLUDED_LIBINTL=yes
+ CATOBJEXT=.gmo
+ INSTOBJEXT=.mo
+ DATADIRNAME=share
+- INTLDEPS='$(top_builddir)/intl/libintl.a'
+- INTLLIBS=$INTLDEPS
+- LIBS=`echo $LIBS | sed -e 's/-lintl//'`
+- nls_cv_header_intl=intl/libintl.h
+- nls_cv_header_libgt=intl/libgettext.h
++# INTLDEPS='$(top_builddir)/intl/libintl.a'
++# INTLLIBS=$INTLDEPS
++# LIBS=`echo $LIBS | sed -e 's/-lintl//'`
++# nls_cv_header_intl=intl/libintl.h
++# nls_cv_header_libgt=intl/libgettext.h
+ fi
+
+ if test "$XGETTEXT" != ":"; then
diff --git a/math/gnumeric2/pkg-plist b/math/gnumeric2/pkg-plist
index 8f095f2dff65..cbaca5a75b5c 100644
--- a/math/gnumeric2/pkg-plist
+++ b/math/gnumeric2/pkg-plist
@@ -2,16 +2,24 @@ bin/gnumeric
bin/gnumeric-corba
share/gnome/apps/Applications/gnumeric.desktop
share/gnome/gnumeric/guile/gnumeric_startup.scm
+share/gnome/gnumeric/perl/startup.pl
share/gnome/gnumeric/plugins/libgnumguile.a
share/gnome/gnumeric/plugins/libgnumguile.la
share/gnome/gnumeric/plugins/libgnumguile.so
share/gnome/gnumeric/plugins/libgnumguile.so.0
+share/gnome/gnumeric/plugins/libpython.a
+share/gnome/gnumeric/plugins/libpython.la
+share/gnome/gnumeric/plugins/libpython.so
+share/gnome/gnumeric/plugins/libpython.so.0
share/gnome/gnumeric/plugins/libstat.a
share/gnome/gnumeric/plugins/libstat.la
share/gnome/gnumeric/plugins/libstat.so
share/gnome/gnumeric/plugins/libstat.so.0
+share/gnome/gnumeric/python/gnumeric_startup.py
+share/gnome/mc/templates/gnumeric.desktop
share/gnome/mime-info/gnumeric.keys
share/gnome/mime-info/gnumeric.mime
+share/gnome/pixmaps/gnome-gnumeric-xl.png
share/gnome/pixmaps/gnome-gnumeric.png
share/locale/cs/LC_MESSAGES/gnumeric.mo
share/locale/de/LC_MESSAGES/gnumeric.mo
@@ -29,8 +37,11 @@ share/locale/it/LC_MESSAGES/gnumeric.mo
share/locale/ja/LC_MESSAGES/gnumeric.mo
share/locale/ko/LC_MESSAGES/gnumeric.mo
share/locale/no/LC_MESSAGES/gnumeric.mo
-share/locale/no_NO/LC_MESSAGES/gnumeric.mo
+share/locale/pl/LC_MESSAGES/gnumeric.mo
share/locale/pt/LC_MESSAGES/gnumeric.mo
-@dirrm share/gnome/gnumeric/guile
+share/locale/ru/LC_MESSAGES/gnumeric.mo
+@dirrm share/gnome/gnumeric/python
@dirrm share/gnome/gnumeric/plugins
+@dirrm share/gnome/gnumeric/perl
+@dirrm share/gnome/gnumeric/guile
@dirrm share/gnome/gnumeric