aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMaxime Henrion <mux@FreeBSD.org>2007-02-10 14:38:16 +0000
committerMaxime Henrion <mux@FreeBSD.org>2007-02-10 14:38:16 +0000
commit27c870c2ea9b3e491f57547681d6433e9022fcca (patch)
tree57477228115d497ecb34ecc3c076e6c56c3bcc84 /math
parent579fa0c27b14b3b38cd600533039671659dc39ff (diff)
downloadports-27c870c2ea9b3e491f57547681d6433e9022fcca.tar.gz
ports-27c870c2ea9b3e491f57547681d6433e9022fcca.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-BigInt-GMP/Makefile27
-rw-r--r--math/p5-Math-BigInt-GMP/distinfo3
-rw-r--r--math/p5-Math-BigInt-GMP/pkg-descr9
-rw-r--r--math/p5-Math-BigInt-GMP/pkg-plist9
5 files changed, 49 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 14c62dce7179..85d4c931ea46 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -189,6 +189,7 @@
SUBDIR += p5-Math-Bezier
SUBDIR += p5-Math-Bezier-Convert
SUBDIR += p5-Math-BigInt
+ SUBDIR += p5-Math-BigInt-GMP
SUBDIR += p5-Math-BigRat
SUBDIR += p5-Math-Calc-Units
SUBDIR += p5-Math-Cephes
diff --git a/math/p5-Math-BigInt-GMP/Makefile b/math/p5-Math-BigInt-GMP/Makefile
new file mode 100644
index 000000000000..82e6c60e7c76
--- /dev/null
+++ b/math/p5-Math-BigInt-GMP/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: math/p5-Math-BigInt-GMP
+# Date created: 7 February 2007
+# Whom: Maxime Henrion <mux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-BigInt-GMP
+PORTVERSION= 1.19
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Math::BigInt::GMP - Use the GMP library for Math::BigInt routines
+
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+BUILD_DEPENDS= p5-Math-BigInt>=1.78:${PORTSDIR}/math/p5-Math-BigInt
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS+= INC="-I${LOCALBASE}/include"
+
+MAN3= Math::BigInt::GMP.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-BigInt-GMP/distinfo b/math/p5-Math-BigInt-GMP/distinfo
new file mode 100644
index 000000000000..dea550a92853
--- /dev/null
+++ b/math/p5-Math-BigInt-GMP/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-BigInt-GMP-1.19.tar.gz) = a965d3b30abf0f85b64d943f0688e87c
+SHA256 (Math-BigInt-GMP-1.19.tar.gz) = bd7dd4d74988e94d6487fd9363720d882e7e02bbb88be0341b11251f2f35baae
+SIZE (Math-BigInt-GMP-1.19.tar.gz) = 37602
diff --git a/math/p5-Math-BigInt-GMP/pkg-descr b/math/p5-Math-BigInt-GMP/pkg-descr
new file mode 100644
index 000000000000..aad1ae4c5532
--- /dev/null
+++ b/math/p5-Math-BigInt-GMP/pkg-descr
@@ -0,0 +1,9 @@
+Math::BigInt::GMP - Use the GMP library for Math::BigInt routines.
+
+Provides support for big integer calculations via means of the GMP c-library.
+
+Math::BigInt::GMP now no longer uses Math::GMP, but provides its own XS layer
+to access the GMP c-library. This cuts out another (perl sub routine) layer and
+also reduces the memory footprint by not loading Math::GMP and Carp at all.
+
+WWW: http://search.cpan.org/dist/Math-BigInt-GMP/
diff --git a/math/p5-Math-BigInt-GMP/pkg-plist b/math/p5-Math-BigInt-GMP/pkg-plist
new file mode 100644
index 000000000000..479fed311a77
--- /dev/null
+++ b/math/p5-Math-BigInt-GMP/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/BigInt/GMP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/BigInt/GMP/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/BigInt/GMP/GMP.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/BigInt/GMP/GMP.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/BigInt/GMP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/BigInt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/BigInt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math