aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2008-06-12 08:58:33 +0000
committerJohan van Selst <johans@FreeBSD.org>2008-06-12 08:58:33 +0000
commit6a86a0fde7e084af96762273210bb40245a5743a (patch)
tree1e29cea138b0edae6dc5362892fa87b2dfd4af51 /math
parent0c9e2954a81f35c11ad60daea959bcfb7de2f21d (diff)
downloadports-6a86a0fde7e084af96762273210bb40245a5743a.tar.gz
ports-6a86a0fde7e084af96762273210bb40245a5743a.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/gap/Makefile2
-rw-r--r--math/gap/distinfo6
-rw-r--r--math/gap/files/patch-gap4r4_src_sysfiles.c58
3 files changed, 60 insertions, 6 deletions
diff --git a/math/gap/Makefile b/math/gap/Makefile
index 20da251009a8..a118a06ab110 100644
--- a/math/gap/Makefile
+++ b/math/gap/Makefile
@@ -34,7 +34,7 @@ OPTIONS= COMPRESSED_TOMLIB "Compress tomlib files" On \
.include <bsd.port.pre.mk>
GAP_VERSION= gap4r4
-GAP_PKGTIME= 2008_03_14-15_33_UTC
+GAP_PKGTIME= 2008_06_06-16_58_UTC
GAP_PKGDATE= ${GAP_PKGTIME:C/-.*//:S/_//g}
GAP_WRKSRC= ${WRKSRC}/${GAP_VERSION}
GAP_LIBDIR= ${PREFIX}/lib/${GAP_VERSION}
diff --git a/math/gap/distinfo b/math/gap/distinfo
index 7dd47d6996d0..0c45d030a810 100644
--- a/math/gap/distinfo
+++ b/math/gap/distinfo
@@ -1,6 +1,6 @@
-MD5 (gap/packages-2008_03_14-15_33_UTC.tar.bz2) = 4e66234e8eb006a8475afd871d7ad3c5
-SHA256 (gap/packages-2008_03_14-15_33_UTC.tar.bz2) = 367c887aa778f22c4a3e724aaddef281b6e63365508801b03fe25ff56bc48d15
-SIZE (gap/packages-2008_03_14-15_33_UTC.tar.bz2) = 59937111
+MD5 (gap/packages-2008_06_06-16_58_UTC.tar.bz2) = 0234e44b28f0027418df263e5d66d106
+SHA256 (gap/packages-2008_06_06-16_58_UTC.tar.bz2) = 712c920ac3eb00960f9d4912e9afdb974248ce505953e760711560d1a2d3e2a9
+SIZE (gap/packages-2008_06_06-16_58_UTC.tar.bz2) = 61206056
MD5 (gap/gap4r4p10.tar.bz2) = 8b7d5fbe420cc5d8fc59c187374bc4f4
SHA256 (gap/gap4r4p10.tar.bz2) = 21e4880091ab90d5a5aad74359bff45ea41c8ac0e4e6fea0cfdc621172cb67b9
SIZE (gap/gap4r4p10.tar.bz2) = 45666068
diff --git a/math/gap/files/patch-gap4r4_src_sysfiles.c b/math/gap/files/patch-gap4r4_src_sysfiles.c
index 2accfc204b37..eeb7afc1510b 100644
--- a/math/gap/files/patch-gap4r4_src_sysfiles.c
+++ b/math/gap/files/patch-gap4r4_src_sysfiles.c
@@ -1,5 +1,5 @@
---- gap4r4/src/sysfiles.c Mon Oct 23 01:20:54 2006
-+++ gap4r4/src/sysfiles.c Mon Mar 26 18:28:38 2007
+--- gap4r4/src/sysfiles.c.orig 2006-11-13 07:25:20.000000000 +0100
++++ gap4r4/src/sysfiles.c 2008-06-12 08:23:32.000000000 +0200
@@ -1522,7 +1522,7 @@
** to cooked mode before stopping GAP and back to raw mode when continueing.
*/
@@ -18,3 +18,57 @@
void syStopraw (
Int fid )
+@@ -2759,7 +2759,7 @@
+ **
+ *f syEchoch( <ch>, <fid> ) . . . . . . . . . . . . . . . . . . . . BSD/MACH
+ */
+-#if SYS_BSD || SYS_MACH || HAVE_SGTTY_H
++#if (SYS_BSD || SYS_MACH || HAVE_SGTTY_H) && !HAVE_TERMIOS_H
+
+ void syEchoch (
+ Int ch,
+@@ -2785,7 +2785,7 @@
+ **
+ *f syEchoch( <ch>, <fid> ) . . . . . . . . . . . . . . . . . . . . . . . USG
+ */
+-#if SYS_USG || HAVE_TERMIO_H
++#if SYS_USG || HAVE_TERMIO_H || HAVE_TERMIOS_H
+
+ void syEchoch (
+ Int ch,
+@@ -2973,7 +2973,7 @@
+ **
+ *f syEchos( <ch>, <fid> ) . . . . . . . . . . . . . . . . . . . . BSD/MACH
+ */
+-#if SYS_BSD || SYS_MACH || HAVE_SGTTY_H
++#if (SYS_BSD || SYS_MACH || HAVE_SGTTY_H) && !HAVE_TERMIOS_H
+
+ void syEchos (
+ Char * str,
+@@ -2995,7 +2995,7 @@
+ **
+ *f syEchos( <ch>, <fid> ) . . . . . . . . . . . . . . . . . . . . . . . USG
+ */
+-#if SYS_USG || HAVE_TERMIO_H
++#if SYS_USG || HAVE_TERMIO_H || HAVE_TERMIOS_H
+
+ void syEchos (
+ Char * str,
+@@ -3148,7 +3148,7 @@
+ **
+ *f SyFputs( <line>, <fid> ) . . . . . . . BSD/MACH/USG/OS2 EMX/VMS/MAC MPW
+ */
+-#if SYS_BSD||SYS_MACH||SYS_USG||SYS_OS2_EMX||SYS_VMS||SYS_MAC_MPW||HAVE_SGTTY_H||HAVE_TERMIO_H
++#if SYS_BSD||SYS_MACH||SYS_USG||SYS_OS2_EMX||SYS_VMS||SYS_MAC_MPW||HAVE_SGTTY_H||HAVE_TERMIO_H||HAVE_TERMIOS_H
+
+ void SyFputs (
+ Char * line,
+@@ -3475,7 +3475,7 @@
+ ** that return odd things rather than waiting for a key
+ **
+ */
+-#if SYS_BSD || SYS_MACH || HAVE_SGTTY_H ||SYS_USG || HAVE_TERMIO_H
++#if SYS_BSD || SYS_MACH || HAVE_SGTTY_H ||SYS_USG || HAVE_TERMIO_H || HAVE_TERMIOS_H
+
+ /* In the cygwin environment it is not predictable if text files get the
+ * '\r' in their line ends filtered out *before* GAP sees them. This leads