aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-08-29 14:28:15 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-08-29 14:28:15 +0000
commit7a9549db7e6eb4250721bd765183a1bf046f5236 (patch)
treeb5f6ea4a3309d454be7c9a965bc1fe93603c30f0 /math
parenta7fa5665e16ecb7c90fa56692a7f3b63b449c5bd (diff)
downloadports-7a9549db7e6eb4250721bd765183a1bf046f5236.tar.gz
ports-7a9549db7e6eb4250721bd765183a1bf046f5236.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/libtommath/Makefile23
-rw-r--r--math/libtommath/distinfo2
-rw-r--r--math/libtommath/files/patch-makefile15
-rw-r--r--math/libtommath/pkg-descr5
-rw-r--r--math/libtommath/pkg-plist4
6 files changed, 50 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 79bd6fb41ee0..021920f322d5 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -108,6 +108,7 @@
SUBDIR += libneural
SUBDIR += libqalculate
SUBDIR += libranlib
+ SUBDIR += libtommath
SUBDIR += linalg
SUBDIR += linpack
SUBDIR += linux-relview
diff --git a/math/libtommath/Makefile b/math/libtommath/Makefile
new file mode 100644
index 000000000000..f57fa688cfc1
--- /dev/null
+++ b/math/libtommath/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: libtommath
+# Date created: 05 Aug 2005
+# Whom: Wesley Shields <wxs@csh.rit.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtommath
+PORTVERSION= 0.36
+CATEGORIES= math
+MASTER_SITES= http://math.libtomcrypt.org/files/
+DISTNAME= ltm-${PORTVERSION}
+
+MAINTAINER= wxs@csh.rit.edu
+COMMENT= Comprehensive, modular and portable mathematical routines
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+MAKEFILE= makefile
+USE_BZIP2= yes
+USE_GMAKE= yes
+ALL_TARGET= default
+
+.include <bsd.port.mk>
diff --git a/math/libtommath/distinfo b/math/libtommath/distinfo
new file mode 100644
index 000000000000..f95c6f97934a
--- /dev/null
+++ b/math/libtommath/distinfo
@@ -0,0 +1,2 @@
+MD5 (ltm-0.36.tar.bz2) = cd4f9305e1b721b3c3eb7bcdc25abfc6
+SIZE (ltm-0.36.tar.bz2) = 1924150
diff --git a/math/libtommath/files/patch-makefile b/math/libtommath/files/patch-makefile
new file mode 100644
index 000000000000..d1fe13056fce
--- /dev/null
+++ b/math/libtommath/files/patch-makefile
@@ -0,0 +1,15 @@
+--- makefile.orig Fri Aug 5 09:34:54 2005
++++ makefile Fri Aug 5 09:36:36 2005
+@@ -48,9 +48,9 @@
+ #INCPATH-The directory to install the header files for libtommath.
+ #DATAPATH-The directory to install the pdf docs.
+ DESTDIR=
+-LIBPATH=/usr/lib
+-INCPATH=/usr/include
+-DATAPATH=/usr/share/doc/libtommath/pdf
++LIBPATH=${PREFIX}/lib
++INCPATH=${PREFIX}/include
++DATAPATH=${PREFIX}/share/doc/libtommath/pdf
+
+ OBJECTS=bncore.o bn_mp_init.o bn_mp_clear.o bn_mp_exch.o bn_mp_grow.o bn_mp_shrink.o \
+ bn_mp_clamp.o bn_mp_zero.o bn_mp_set.o bn_mp_set_int.o bn_mp_init_size.o bn_mp_copy.o \
diff --git a/math/libtommath/pkg-descr b/math/libtommath/pkg-descr
new file mode 100644
index 000000000000..9cd70bdc45e5
--- /dev/null
+++ b/math/libtommath/pkg-descr
@@ -0,0 +1,5 @@
+LibTomMath provides highly optimized and portable routines for a vast
+majority of integer based number theoretic applications (including
+public key cryptography).
+
+WWW: http://math.libtomcrypt.org
diff --git a/math/libtommath/pkg-plist b/math/libtommath/pkg-plist
new file mode 100644
index 000000000000..b0e3aa88cefa
--- /dev/null
+++ b/math/libtommath/pkg-plist
@@ -0,0 +1,4 @@
+include/tommath.h
+include/tommath_class.h
+include/tommath_superclass.h
+lib/libtommath.a