aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2005-11-18 12:50:57 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2005-11-18 12:50:57 +0000
commite473fbf387da198f74e986973c9e0533b8cd49ab (patch)
tree980f8341e8e337ad552aee7d5fa4edd2c89d012a /math
parent32f2a2adbbf51a4d425c981a3d813043b24c5dfd (diff)
downloadports-e473fbf387da198f74e986973c9e0533b8cd49ab.tar.gz
ports-e473fbf387da198f74e986973c9e0533b8cd49ab.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/py-numarray/Makefile1
-rw-r--r--math/py-numarray/files/patch-Include::numarray::nummacro.h14
2 files changed, 15 insertions, 0 deletions
diff --git a/math/py-numarray/Makefile b/math/py-numarray/Makefile
index 48b89e5fcf9b..886478be2b86 100644
--- a/math/py-numarray/Makefile
+++ b/math/py-numarray/Makefile
@@ -7,6 +7,7 @@
PORTNAME= numarray
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= numpy
diff --git a/math/py-numarray/files/patch-Include::numarray::nummacro.h b/math/py-numarray/files/patch-Include::numarray::nummacro.h
new file mode 100644
index 000000000000..1cb40e378d5f
--- /dev/null
+++ b/math/py-numarray/files/patch-Include::numarray::nummacro.h
@@ -0,0 +1,14 @@
+--- Include/numarray/nummacro.h.orig Fri Nov 18 20:42:15 2005
++++ Include/numarray/nummacro.h Fri Nov 18 20:43:33 2005
+@@ -24,7 +24,11 @@
+ int n_outs, PyObject*outs[]);
+ typedef struct {
+ PyObject_HEAD
++#ifdef __cplusplus
++ PyObject *operator_; /* ufunc name */
++#else
+ PyObject *operator; /* ufunc name */
++#endif
+ PyObject *identity; /* identity value, e.g. 0 for + or 1 for * */
+ int n_inputs, n_outputs;
+ _ufunc_function call;