aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-01-25 10:21:01 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-01-25 10:21:01 +0000
commitf234761615f8529aaccfa21e36ab5705dc45b91d (patch)
tree4782d327bb4bd50632012205426aad765d88d7d1 /math
parent1a193f8a71d970fe161b9dd9c97de74af5e75812 (diff)
Notes
Diffstat (limited to 'math')
-rw-r--r--math/cantor/Makefile6
-rw-r--r--math/cantor/distinfo4
-rw-r--r--math/cantor/pkg-plist2
-rw-r--r--math/kalgebra/Makefile1
-rw-r--r--math/kalgebra/distinfo4
-rw-r--r--math/kalgebra/files/patch-CMakeLists.txt8
-rw-r--r--math/kalgebra/pkg-plist19
-rw-r--r--math/kbruch/distinfo4
-rw-r--r--math/kcalc/distinfo4
-rw-r--r--math/kcalc/pkg-plist2
-rw-r--r--math/kig/distinfo4
-rw-r--r--math/kmplot/distinfo4
-rw-r--r--math/rocs/distinfo4
13 files changed, 50 insertions, 16 deletions
diff --git a/math/cantor/Makefile b/math/cantor/Makefile
index 30d3c5880b6e..3e26e303b4e0 100644
--- a/math/cantor/Makefile
+++ b/math/cantor/Makefile
@@ -35,7 +35,11 @@ OPTIONS= KALGEBRA "KAlgebra backend" on \
.include <bsd.port.options.mk>
.ifndef(WITHOUT_KALGEBRA)
-RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kalgebra:${PORTSDIR}/math/kalgebra
+LIB_DEPENDS+= analitza.5:${PORTSDIR}/math/kalgebra
+PLIST_SUB+= KALGEBRA=""
+.else
+CMAKE_ARGS+= -DWITH_Analitza:BOOL=FALSE
+PLIST_SUB+= KALGEBRA="@comment "
.endif
.ifdef(WITH_MAXIMA)
diff --git a/math/cantor/distinfo b/math/cantor/distinfo
index 5d527bd1e26a..b8b422374763 100644
--- a/math/cantor/distinfo
+++ b/math/cantor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/cantor-4.7.3.tar.bz2) = 7451843080e2e5f68112e5da7f8b4d08c579a9436d816a4958d7d8253218d73d
-SIZE (KDE/cantor-4.7.3.tar.bz2) = 499214
+SHA256 (KDE/cantor-4.7.4.tar.bz2) = 2a1b40275e6360142154449406bebf5da4a1cbfd104447d25c6218ba9204f571
+SIZE (KDE/cantor-4.7.4.tar.bz2) = 500119
diff --git a/math/cantor/pkg-plist b/math/cantor/pkg-plist
index 498da72cedf5..62e9bd62ba2e 100644
--- a/math/cantor/pkg-plist
+++ b/math/cantor/pkg-plist
@@ -25,6 +25,7 @@ lib/kde4/cantor_eigenvectorsassistant.so
lib/kde4/cantor_helppanelplugin.so
lib/kde4/cantor_integrateassistant.so
lib/kde4/cantor_invertmatrixassistant.so
+%%KALGEBRA%%lib/kde4/cantor_kalgebrabackend.so
lib/kde4/cantor_maximabackend.so
lib/kde4/cantor_nullbackend.so
lib/kde4/cantor_octavebackend.so
@@ -93,6 +94,7 @@ share/kde4/services/cantor/eigenvectorsassistant.desktop
share/kde4/services/cantor/helppanelplugin.desktop
share/kde4/services/cantor/integrateassistant.desktop
share/kde4/services/cantor/invertmatrixassistant.desktop
+%%KALGEBRA%%share/kde4/services/cantor/kalgebrabackend.desktop
share/kde4/services/cantor/maximabackend.desktop
share/kde4/services/cantor/nullbackend.desktop
share/kde4/services/cantor/octavebackend.desktop
diff --git a/math/kalgebra/Makefile b/math/kalgebra/Makefile
index d0789cda0eb2..8a09fa1cf978 100644
--- a/math/kalgebra/Makefile
+++ b/math/kalgebra/Makefile
@@ -25,6 +25,7 @@ USE_QT_VER= 4
QT_COMPONENTS= gui opengl script scripttools xml \
moc_build qmake_build rcc_build uic_build
USE_BZIP2= yes
+CMAKE_ARGS+= -DINSTALL_ANALITZA_HEADERS:BOOL=TRUE
MAKE_JOBS_SAFE= yes
OPTIONS= READLINE "Install console interface" on
diff --git a/math/kalgebra/distinfo b/math/kalgebra/distinfo
index f4a0399d4a1a..9f233214eaec 100644
--- a/math/kalgebra/distinfo
+++ b/math/kalgebra/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/kalgebra-4.7.3.tar.bz2) = 59a498304606204ad12ea26460643dc1422ee35167f2bdc8c9584bc8d7547bf0
-SIZE (KDE/kalgebra-4.7.3.tar.bz2) = 233440
+SHA256 (KDE/kalgebra-4.7.4.tar.bz2) = 295266cd721a552e4df175fa5c39dbedc959e7746f265742be938499bd3ee011
+SIZE (KDE/kalgebra-4.7.4.tar.bz2) = 233979
diff --git a/math/kalgebra/files/patch-CMakeLists.txt b/math/kalgebra/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..9e4bf9b9109b
--- /dev/null
+++ b/math/kalgebra/files/patch-CMakeLists.txt
@@ -0,0 +1,8 @@
+--- ./CMakeLists.txt.orig 2011-12-12 11:26:46.061238287 +0100
++++ ./CMakeLists.txt 2011-12-12 11:29:33.561244057 +0100
+@@ -48,3 +48,5 @@
+ macro_display_feature_log()
+ endif (${CMAKE_CURRENT_SOURCE_DIR} STREQUAL ${CMAKE_SOURCE_DIR})
+
++set(module_install_dir ${DATA_INSTALL_DIR}/cmake/modules)
++install(FILES ${CMAKE_SOURCE_DIR}/cmake/FindAnalitza.cmake DESTINATION ${module_install_dir})
diff --git a/math/kalgebra/pkg-plist b/math/kalgebra/pkg-plist
index 4cdb1b426268..cf2f9155c4af 100644
--- a/math/kalgebra/pkg-plist
+++ b/math/kalgebra/pkg-plist
@@ -1,6 +1,22 @@
%%READLINE%%bin/calgebra
bin/kalgebra
bin/kalgebramobile
+include/analitza/abstractlexer.h
+include/analitza/analitzaexport.h
+include/analitza/analitzautils.h
+include/analitza/analyzer.h
+include/analitza/builtinmethods.h
+include/analitza/expression.h
+include/analitza/expressiontype.h
+include/analitza/object.h
+include/analitza/operations.h
+include/analitza/operator.h
+include/analitza/value.h
+include/analitza/variables.h
+include/analitzagui/algebrahighlighter.h
+include/analitzagui/analitzaguiexport.h
+include/analitzagui/operatorsmodel.h
+include/analitzagui/variablesmodel.h
lib/kde4/plasma_applet_kalgebra.so
lib/libanalitza.so
lib/libanalitza.so.5
@@ -10,6 +26,7 @@ lib/libanalitzagui.so.5
lib/libanalitzagui.so.5.0.1
share/applications/kde4/kalgebra.desktop
share/applications/kde4/kalgebramobile.desktop
+share/apps/cmake/modules/FindAnalitza.cmake
share/apps/kalgebra/scripts/console/console.js
share/apps/kalgebra/scripts/console/kalgebraconsole.desktop
share/apps/kalgebra/scripts/plot2d/kalgebraplot2d.desktop
@@ -38,3 +55,5 @@ share/kde4/servicetypes/kalgebrascript.desktop
@dirrm share/apps/kalgebra/scripts/console
@dirrm share/apps/kalgebra/scripts
@dirrm share/apps/kalgebra
+@dirrm include/analitzagui
+@dirrm include/analitza
diff --git a/math/kbruch/distinfo b/math/kbruch/distinfo
index a56004e70899..2a2f659827a2 100644
--- a/math/kbruch/distinfo
+++ b/math/kbruch/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/kbruch-4.7.3.tar.bz2) = a77f3490721c50d3cefd13ca815419212103a9cefb02be275dda562e00e7a507
-SIZE (KDE/kbruch-4.7.3.tar.bz2) = 964151
+SHA256 (KDE/kbruch-4.7.4.tar.bz2) = 2bfef14741746f1adace532b57309d8f1c7c1352b5032e283944afd14a9910b6
+SIZE (KDE/kbruch-4.7.4.tar.bz2) = 963676
diff --git a/math/kcalc/distinfo b/math/kcalc/distinfo
index 0e23ed964282..2df4c25591af 100644
--- a/math/kcalc/distinfo
+++ b/math/kcalc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/kdeutils-4.7.3.tar.bz2) = a8c802f32b9e918d806a4487c25485f86019e4c473f0de6d3086d8ea8e492839
-SIZE (KDE/kdeutils-4.7.3.tar.bz2) = 3802391
+SHA256 (KDE/kdeutils-4.7.4.tar.bz2) = bb50a5069808a0280eff671b2f9c0053f5bbbfdc432760bc35ccf654de833c68
+SIZE (KDE/kdeutils-4.7.4.tar.bz2) = 3802873
diff --git a/math/kcalc/pkg-plist b/math/kcalc/pkg-plist
index 075e9e1e6330..2b26cef5db6e 100644
--- a/math/kcalc/pkg-plist
+++ b/math/kcalc/pkg-plist
@@ -175,7 +175,7 @@ share/doc/HTML/en/ktimer/index.cache.bz2
share/doc/HTML/en/ktimer/index.docbook
share/doc/HTML/en/ktimer/main.png
share/doc/HTML/en/ktimer/running.png
-share/doc/HTML/en/ktimer/two.at.once.png
+share/doc/HTML/en/ktimer/two_at_once.png
share/doc/HTML/en/kwallet/common
share/doc/HTML/en/kwallet/edit1.png
share/doc/HTML/en/kwallet/edit2.png
diff --git a/math/kig/distinfo b/math/kig/distinfo
index 1c1f5e3ae298..0a831500517d 100644
--- a/math/kig/distinfo
+++ b/math/kig/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/kig-4.7.3.tar.bz2) = 218a5084aa9fce7c32978de173358a0b7ddd28ace8dc04dd40d5580dc676fed4
-SIZE (KDE/kig-4.7.3.tar.bz2) = 1592779
+SHA256 (KDE/kig-4.7.4.tar.bz2) = a096ec85e04798e39cf090618557b4c00da22402d35940434055c52ca4e515e8
+SIZE (KDE/kig-4.7.4.tar.bz2) = 1592509
diff --git a/math/kmplot/distinfo b/math/kmplot/distinfo
index e8755a1d07da..7e3cb7a46abc 100644
--- a/math/kmplot/distinfo
+++ b/math/kmplot/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/kmplot-4.7.3.tar.bz2) = a843eee79452beb48b336f7157f7bfb2ac4d4f7209f0ca0d86b52c4d2f7ec7b6
-SIZE (KDE/kmplot-4.7.3.tar.bz2) = 707516
+SHA256 (KDE/kmplot-4.7.4.tar.bz2) = 39afdb57d1a3564c5c6ddbfe2895601028edf8f3db91e3aa3e1801a0bc7da537
+SIZE (KDE/kmplot-4.7.4.tar.bz2) = 707436
diff --git a/math/rocs/distinfo b/math/rocs/distinfo
index 1691a3e4da43..c190ecb27b5d 100644
--- a/math/rocs/distinfo
+++ b/math/rocs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/rocs-4.7.3.tar.bz2) = 1b3ef7226c98debdb7f27457fef8b913f8312ee4c54710a0bd293fcc41e57c2c
-SIZE (KDE/rocs-4.7.3.tar.bz2) = 344842
+SHA256 (KDE/rocs-4.7.4.tar.bz2) = 644ca36be6cf7e7dbcbd86c5d26500f32b70d9ca71818876495f12a355771f63
+SIZE (KDE/rocs-4.7.4.tar.bz2) = 344810