aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2005-01-12 17:50:39 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2005-01-12 17:50:39 +0000
commit1fcf66691d0c3772198f5a53c04a08c836518a51 (patch)
tree5e5585449c131ef333115c1fb0c02179d5bca6ad /math
parentd84fb4e2f6191ec53a4f029388f25e19235c77b2 (diff)
downloadports-1fcf66691d0c3772198f5a53c04a08c836518a51.tar.gz
ports-1fcf66691d0c3772198f5a53c04a08c836518a51.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/py-numeric/files/patch-Src_umathmodule.c4
-rw-r--r--math/py-numeric/files/patch-setup.py32
2 files changed, 17 insertions, 19 deletions
diff --git a/math/py-numeric/files/patch-Src_umathmodule.c b/math/py-numeric/files/patch-Src_umathmodule.c
index 8a4ef7e5dfb8..b773065933b2 100644
--- a/math/py-numeric/files/patch-Src_umathmodule.c
+++ b/math/py-numeric/files/patch-Src_umathmodule.c
@@ -1,5 +1,5 @@
---- Src/umathmodule.c.orig Sat Aug 2 01:10:09 2003
-+++ Src/umathmodule.c Sat Aug 2 01:10:43 2003
+--- Src/umathmodule.c.orig Wed Jan 12 12:45:18 2005
++++ Src/umathmodule.c Wed Jan 12 12:45:29 2005
@@ -1,9 +1,9 @@
+#include <math.h>
diff --git a/math/py-numeric/files/patch-setup.py b/math/py-numeric/files/patch-setup.py
index eef6d8c66cf5..3aff4d580963 100644
--- a/math/py-numeric/files/patch-setup.py
+++ b/math/py-numeric/files/patch-setup.py
@@ -1,13 +1,13 @@
---- setup.py.orig Wed Sep 29 01:50:45 2004
-+++ setup.py Wed Oct 20 09:31:06 2004
-@@ -33,21 +33,21 @@
+--- setup.py.orig Wed Jan 12 12:46:37 2005
++++ setup.py Wed Jan 12 12:48:15 2005
+@@ -33,19 +33,19 @@
# delete all but the first one in this list if using your own LAPACK/BLAS
sourcelist = [os.path.join('Src', 'lapack_litemodule.c'),
--# os.path.join('Src', 'blas_lite.c'),
--# os.path.join('Src', 'f2c_lite.c'),
--# os.path.join('Src', 'zlapack_lite.c'),
--# os.path.join('Src', 'dlapack_lite.c')
+- #os.path.join('Src', 'blas_lite.c'),
+- #os.path.join('Src', 'f2c_lite.c'),
+- #os.path.join('Src', 'zlapack_lite.c'),
+- #os.path.join('Src', 'dlapack_lite.c')
+ os.path.join('Src', 'blas_lite.c'),
+ os.path.join('Src', 'f2c_lite.c'),
+ os.path.join('Src', 'zlapack_lite.c'),
@@ -18,15 +18,13 @@
-library_dirs_list = ['/usr/lib/atlas']
-libraries_list = ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
+library_dirs_list = []
-+libraries_list = []
- # if you also set `use_dotblas` (see below), you'll need:
- # ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
++libraries_list = []
# set to true (1), if you also want BLAS optimized matrixmultiply/dot/innerproduct
--use_dotblas = 1
--include_dirs = ['/usr/include/atlas'] # You may need to set this to find cblas.h
-+use_dotblas = 0
-+include_dirs = [] # You may need to set this to find cblas.h
- # e.g. on UNIX using ATLAS this should be ['/usr/include/atlas']
-
- # The packages are split in this way to allow future optional inclusion
+-use_dotblas = 1
+-include_dirs = ['/usr/include/atlas']
++use_dotblas = 0
++include_dirs = []
+ # You may need to set this to find cblas.h
+ # e.g. on UNIX using ATLAS this should be ['/usr/include/atlas']
+ extra_link_args = []