aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2020-03-27 14:59:07 +0000
committerGleb Popov <arrowd@FreeBSD.org>2020-03-27 14:59:07 +0000
commit3086d6bc157f013c7f5ad8f74f87bfa4c4f6d925 (patch)
tree5eea3f3225cb11b02a35e8e08b64167502437233 /math
parent01a446e6084d05c884dde6a8b3d5f04e8115f4eb (diff)
downloadports-3086d6bc157f013c7f5ad8f74f87bfa4c4f6d925.tar.gz
ports-3086d6bc157f013c7f5ad8f74f87bfa4c4f6d925.zip
math/stp and math/cryptominisat: Use correct patch (at STP side) for specifying dependency on
cryptomisat.
Notes
Notes: svn path=/head/; revision=529255
Diffstat (limited to 'math')
-rw-r--r--math/cryptominisat/Makefile2
-rw-r--r--math/cryptominisat/files/patch-cryptominisat5Config.cmake.in13
-rw-r--r--math/stp/Makefile2
-rw-r--r--math/stp/files/patch-STPConfig.cmake.in12
4 files changed, 14 insertions, 15 deletions
diff --git a/math/cryptominisat/Makefile b/math/cryptominisat/Makefile
index 1879f5b80151..e21327e28440 100644
--- a/math/cryptominisat/Makefile
+++ b/math/cryptominisat/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cryptominisat
DISTVERSION= 5.6.8
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= math
MAINTAINER= arrowd@FreeBSD.org
diff --git a/math/cryptominisat/files/patch-cryptominisat5Config.cmake.in b/math/cryptominisat/files/patch-cryptominisat5Config.cmake.in
deleted file mode 100644
index 1656db2c7e94..000000000000
--- a/math/cryptominisat/files/patch-cryptominisat5Config.cmake.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- cryptominisat5Config.cmake.in.orig 2019-02-19 20:49:20 UTC
-+++ cryptominisat5Config.cmake.in
-@@ -12,8 +12,8 @@ set(CRYPTOMINISAT5_INCLUDE_DIRS "@CONF_INCLUDE_DIRS@")
- include("${CRYPTOMINISAT5_CMAKE_DIR}/@CRYPTOMINISAT5_TARGETS_FILENAME@")
-
- # These are IMPORTED targets created by @CRYPTOMINISAT5_TARGETS_FILENAME@
--set(CRYPTOMINISAT5_LIBRARIES cryptominisat5)
--set(CRYPTOMINISAT5_STATIC_LIBRARIES cryptominisat5)
-+set(CRYPTOMINISAT5_LIBRARIES "@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_LIBDIR@/libcryptominisat5.so")
-+set(CRYPTOMINISAT5_STATIC_LIBRARIES "@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_LIBDIR@/libcryptominisat5.a")
- set(CRYPTOMINISAT5_STATIC_LIBRARIES_DEPS @CRYPTOMINISAT5_STATIC_DEPS@)
- set(CRYPTOMINISAT5_VERSION_MAJOR @PROJECT_VERSION_MAJOR@)
- set(CRYPTOMINISAT5_VERSION_MINOR @PROJECT_VERSION_MINOR@)
diff --git a/math/stp/Makefile b/math/stp/Makefile
index a2dae5d4fc3d..0c0c239fd9b9 100644
--- a/math/stp/Makefile
+++ b/math/stp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= stp
DISTVERSION= 2.3.3
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= math
diff --git a/math/stp/files/patch-STPConfig.cmake.in b/math/stp/files/patch-STPConfig.cmake.in
new file mode 100644
index 000000000000..ee70478bf021
--- /dev/null
+++ b/math/stp/files/patch-STPConfig.cmake.in
@@ -0,0 +1,12 @@
+--- STPConfig.cmake.in.orig 2019-03-02 14:26:01 UTC
++++ STPConfig.cmake.in
+@@ -11,6 +11,9 @@
+ get_filename_component(STP_CMAKE_DIR "${CMAKE_CURRENT_LIST_FILE}" PATH)
+ set(STP_INCLUDE_DIRS "@CONF_INCLUDE_DIRS@")
+
++include(CMakeFindDependencyMacro)
++find_dependency(cryptominisat5)
++
+ # Our library dependencies (contains definitions for IMPORTED targets)
+ include("${STP_CMAKE_DIR}/@STP_TARGETS_FILENAME@")
+