aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-06-12 06:44:49 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-06-12 06:44:49 +0000
commit3cfe0e6a5d5b547ed7a9f26bb872e9dd785008f5 (patch)
treeb33f8685ce5d90652202659c81b8b9b2228c34d7 /math
parent591529ed72109e63cd84074ff4191e00c2ea3f85 (diff)
downloadports-3cfe0e6a5d5b547ed7a9f26bb872e9dd785008f5.tar.gz
ports-3cfe0e6a5d5b547ed7a9f26bb872e9dd785008f5.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/gcalctool/Makefile40
-rw-r--r--math/gcalctool/distinfo1
-rw-r--r--math/gcalctool/files/patch-gcalctool_Makefile.in11
-rw-r--r--math/gcalctool/pkg-comment1
-rw-r--r--math/gcalctool/pkg-descr5
-rw-r--r--math/gcalctool/pkg-plist3
7 files changed, 62 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 916ab36b2467..f5621891f144 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -32,6 +32,7 @@
SUBDIR += fudgit
SUBDIR += fxt
SUBDIR += gap
+ SUBDIR += gcalctool
SUBDIR += geg
SUBDIR += gexpr
SUBDIR += glove
diff --git a/math/gcalctool/Makefile b/math/gcalctool/Makefile
new file mode 100644
index 000000000000..45bcdff2c894
--- /dev/null
+++ b/math/gcalctool/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: gcalctool
+# Date created: 12 Jun 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gcalctool
+PORTVERSION= 4.1.0
+CATEGORIES= math gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/sources/gcalctool
+DIST_SUBDIR= gnome2
+
+MAINTAINER= marcus@FreeBSD.org
+
+LIB_DEPENDS= gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+MAN1= calctool.1
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @find ${WRKSRC} -name "*.[ch]" | xargs ${PERL} -pi -e \
+ 's|malloc\.h|stdlib.h|g'
+
+.include <bsd.port.mk>
diff --git a/math/gcalctool/distinfo b/math/gcalctool/distinfo
new file mode 100644
index 000000000000..4fc78ed414f9
--- /dev/null
+++ b/math/gcalctool/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/gcalctool-4.1.0.tar.bz2) = 8ea71ea69c35e6fe84425ee47846f068
diff --git a/math/gcalctool/files/patch-gcalctool_Makefile.in b/math/gcalctool/files/patch-gcalctool_Makefile.in
new file mode 100644
index 000000000000..fab5a43bc0b7
--- /dev/null
+++ b/math/gcalctool/files/patch-gcalctool_Makefile.in
@@ -0,0 +1,11 @@
+--- gcalctool/Makefile.in.orig Wed Jun 12 02:34:38 2002
++++ gcalctool/Makefile.in Wed Jun 12 02:34:53 2002
+@@ -114,7 +114,7 @@
+ extern.h
+
+
+-gcalctool_LDADD = @PACKAGE_LIBS@ -lX11 -lsocket -lnsl
++gcalctool_LDADD = @PACKAGE_LIBS@ -lX11
+
+ pkgdata_DATA = calctool.gif
+
diff --git a/math/gcalctool/pkg-comment b/math/gcalctool/pkg-comment
new file mode 100644
index 000000000000..47df6a24661c
--- /dev/null
+++ b/math/gcalctool/pkg-comment
@@ -0,0 +1 @@
+A GTK+-2.0 calculator tool based on the old calctool for OpenWindows
diff --git a/math/gcalctool/pkg-descr b/math/gcalctool/pkg-descr
new file mode 100644
index 000000000000..30e69fa214f9
--- /dev/null
+++ b/math/gcalctool/pkg-descr
@@ -0,0 +1,5 @@
+Gcalctool is a powerful graphical calulator with financial, logical and
+scientific modes. It uses a multiple precision package to do its arithmetic to
+give a high degree of accuracy.
+
+WWW: http://calctool.sourceforge.net/
diff --git a/math/gcalctool/pkg-plist b/math/gcalctool/pkg-plist
new file mode 100644
index 000000000000..f00fefc5d253
--- /dev/null
+++ b/math/gcalctool/pkg-plist
@@ -0,0 +1,3 @@
+bin/gcalctool
+share/gnome/gcalctool/calctool.gif
+@dirrm share/gnome/gcalctool