aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-15 08:12:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-15 08:12:21 +0000
commit4fe531dc49121b519863914068da27706985f61c (patch)
tree419d3a4eac5a4a43d73f7f838c5d4e8487b1b7a2 /math
parent18a0bbd5468c9e82b9079bf5a413262d55c7f928 (diff)
New port: math/py-PySCIPOpt: Python interface and modeling environment for SCIP
Notes
Notes: svn path=/head/; revision=467372
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-PySCIPOpt/Makefile22
-rw-r--r--math/py-PySCIPOpt/distinfo3
-rw-r--r--math/py-PySCIPOpt/pkg-descr3
4 files changed, 29 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 57e2344f0ad3..341dd4b6d290 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -638,6 +638,7 @@
SUBDIR += pure-mpfr
SUBDIR += pure-rational
SUBDIR += py-Diofant
+ SUBDIR += py-PySCIPOpt
SUBDIR += py-PyWavelets
SUBDIR += py-Pyomo
SUBDIR += py-altgraph
diff --git a/math/py-PySCIPOpt/Makefile b/math/py-PySCIPOpt/Makefile
new file mode 100644
index 000000000000..7a8d03d3b99e
--- /dev/null
+++ b/math/py-PySCIPOpt/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= PySCIPOpt
+DISTVERSION= 1.4.3
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python interface and modeling environment for SCIP
+
+LICENSE= MIT
+
+LIB_DEPENDS= libscip.so:math/SCIP
+
+USES= localbase python
+USE_PYTHON= distutils cython autoplist
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/pyscipopt/scip.so
+
+.include <bsd.port.mk>
diff --git a/math/py-PySCIPOpt/distinfo b/math/py-PySCIPOpt/distinfo
new file mode 100644
index 000000000000..82010287cd9f
--- /dev/null
+++ b/math/py-PySCIPOpt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523778755
+SHA256 (PySCIPOpt-1.4.3.tar.gz) = 2f5741acf41e50787fc28c73eee5840d553f6c9a7e800c6ad61e6cce3b0f95fa
+SIZE (PySCIPOpt-1.4.3.tar.gz) = 469159
diff --git a/math/py-PySCIPOpt/pkg-descr b/math/py-PySCIPOpt/pkg-descr
new file mode 100644
index 000000000000..f63f441679f4
--- /dev/null
+++ b/math/py-PySCIPOpt/pkg-descr
@@ -0,0 +1,3 @@
+This project provides an interface from Python to the SCIP Optimization Suite.
+
+WWW: https://github.com/SCIP-Interfaces/PySCIPOpt