aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-18 12:36:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-18 12:36:04 +0000
commita289f0dfc90070025f9c9e8663af4185b6a1e590 (patch)
tree3362facaca1eb2be5fb6562d013e4da83da03284 /math
parentcf079c26d5050fa010f3fc7ce4722a91de5ce311 (diff)
igraph is a free software package for creating and manipulating
undirected and directed graphs. It includes implementations for classic graph theory problems like minimum spanning trees and network flow, and also implements algorithms for some recent network analysis methods, like community structure search. igraph contains functions for generating regular and random graphs, manipulating graphs, assigning attributes to vertices and edges. It can calculate various structural properties, includes heuristics for community structure detection, supports many file formats. WWW: http://cneurocvs.rmki.kfki.hu/igraph/ PR: ports/125534 Submitted by: Wen Heping <wenheping at gmail.com>
Notes
Notes: svn path=/head/; revision=217031
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/igraph/Makefile30
-rw-r--r--math/igraph/distinfo3
-rw-r--r--math/igraph/pkg-descr12
-rw-r--r--math/igraph/pkg-plist35
5 files changed, 81 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index bfa540baf2b2..7baf96116c2d 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -103,6 +103,7 @@
SUBDIR += gsl
SUBDIR += guppi
SUBDIR += hexcalc
+ SUBDIR += igraph
SUBDIR += isabelle
SUBDIR += it++
SUBDIR += itl
diff --git a/math/igraph/Makefile b/math/igraph/Makefile
new file mode 100644
index 000000000000..67209122bb30
--- /dev/null
+++ b/math/igraph/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: igarph
+# Date created: 07 July 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= igraph
+PORTVERSION= 0.5
+CATEGORIES= math
+MASTER_SITES= http://cneurocvs.rmki.kfki.hu/igraph/download/
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Package For Manipulating Undirected And Directed Graphs
+
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS+= --enable-gmp
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|@libdir@/pkgconfig|@prefix@/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/math/igraph/distinfo b/math/igraph/distinfo
new file mode 100644
index 000000000000..c973731ac479
--- /dev/null
+++ b/math/igraph/distinfo
@@ -0,0 +1,3 @@
+MD5 (igraph-0.5.tar.gz) = 515dde48ad99b6a1b19696c9c8ba13a8
+SHA256 (igraph-0.5.tar.gz) = 0a9be03ad0c8b0d71b7c527c9707344e59ec8bcedc2ae499fe12f5db5111bdde
+SIZE (igraph-0.5.tar.gz) = 1555039
diff --git a/math/igraph/pkg-descr b/math/igraph/pkg-descr
new file mode 100644
index 000000000000..cd5b9faa5b53
--- /dev/null
+++ b/math/igraph/pkg-descr
@@ -0,0 +1,12 @@
+igraph is a free software package for creating and manipulating
+undirected and directed graphs. It includes implementations for
+classic graph theory problems like minimum spanning trees and
+network flow, and also implements algorithms for some recent
+network analysis methods, like community structure search.
+
+igraph contains functions for generating regular and random graphs,
+manipulating graphs, assigning attributes to vertices and edges.
+It can calculate various structural properties, includes heuristics
+for community structure detection, supports many file formats.
+
+WWW: http://cneurocvs.rmki.kfki.hu/igraph/
diff --git a/math/igraph/pkg-plist b/math/igraph/pkg-plist
new file mode 100644
index 000000000000..9f5b391b115e
--- /dev/null
+++ b/math/igraph/pkg-plist
@@ -0,0 +1,35 @@
+libdata/pkgconfig/igraph.pc
+lib/libigraph.a
+lib/libigraph.la
+lib/libigraph.so
+lib/libigraph.so.0
+include/igraph/NetDataTypes.h
+include/igraph/NetRoutines.h
+include/igraph/arpack.h
+include/igraph/arpack_internal.h
+include/igraph/array.h
+include/igraph/array.pmt
+include/igraph/attributes.h
+include/igraph/dqueue.h
+include/igraph/dqueue.pmt
+include/igraph/error.h
+include/igraph/f2c.h
+include/igraph/gml_tree.h
+include/igraph/heap.h
+include/igraph/heap.pmt
+include/igraph/igraph.h
+include/igraph/igraph_pmt.h
+include/igraph/igraph_pmt_off.h
+include/igraph/interrupt.h
+include/igraph/matrix.h
+include/igraph/matrix.pmt
+include/igraph/pottsmodel_2.h
+include/igraph/stack.h
+include/igraph/stack.pmt
+include/igraph/types.h
+include/igraph/vector.h
+include/igraph/vector.pmt
+include/igraph/walktrap_communities.h
+include/igraph/walktrap_graph.h
+include/igraph/walktrap_heap.h
+@dirrm include/igraph