aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-03-31 17:25:31 +0000
committerThierry Thomas <thierry@FreeBSD.org>2020-03-31 17:25:31 +0000
commitdcfae172f209aa0d8b0d959a5f30caeca4a7aec5 (patch)
treec19cd48db3b1f9a1bd6ac441ad6d8056a56c9d05 /math
parent5eeeb6cb2b8d593acfff28aa760bbe8f23f12dfa (diff)
downloadports-dcfae172f209aa0d8b0d959a5f30caeca4a7aec5.tar.gz
ports-dcfae172f209aa0d8b0d959a5f30caeca4a7aec5.zip
Adding rankwidth / rw, a program to calculate rank-width and rank-
decompositions. To be used by SageMath.
Notes
Notes: svn path=/head/; revision=529989
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/rankwidth/Makefile23
-rw-r--r--math/rankwidth/distinfo3
-rw-r--r--math/rankwidth/pkg-descr7
-rw-r--r--math/rankwidth/pkg-plist10
5 files changed, 44 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 62e77ca96a23..3318f8e3ea49 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -840,6 +840,7 @@
SUBDIR += qtiplot-doc
SUBDIR += qwtplot3d
SUBDIR += randlib
+ SUBDIR += rankwidth
SUBDIR += rapid
SUBDIR += reduce
SUBDIR += reduce-psl
diff --git a/math/rankwidth/Makefile b/math/rankwidth/Makefile
new file mode 100644
index 000000000000..4cac6c438261
--- /dev/null
+++ b/math/rankwidth/Makefile
@@ -0,0 +1,23 @@
+# Created by: thierry@pompo.net
+# $FreeBSD$
+
+PORTNAME= rw
+PORTVERSION= 0.8
+CATEGORIES= math
+MASTER_SITES= SF/rankwidth/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Calculation of rank-width and rank-decompositions
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libigraph.so:math/igraph
+
+USES= autoreconf libtool localbase pkgconfig
+
+OPTIONS_DEFINE= DOCS
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/math/rankwidth/distinfo b/math/rankwidth/distinfo
new file mode 100644
index 000000000000..e1c872d1d6a5
--- /dev/null
+++ b/math/rankwidth/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1585644841
+SHA256 (rw-0.8.tar.gz) = 60fd5320bef28a5156284fc224534376405f2655c6777a12a05fcacc0576d700
+SIZE (rw-0.8.tar.gz) = 217215
diff --git a/math/rankwidth/pkg-descr b/math/rankwidth/pkg-descr
new file mode 100644
index 000000000000..0210ebd44e42
--- /dev/null
+++ b/math/rankwidth/pkg-descr
@@ -0,0 +1,7 @@
+rw calculates rank-width and rank-decompositions. It is based on ideas from
+"Computing rank-width exactly" by Sang-il Oum, "Sopra una formula numerica" by
+Ernesto Pascal, "Generation of a Vector from the Lexicographical Index" by B.P.
+Buckles and M. Lybanon and "Fast additions on masked integers" by Michael D.
+Adams and David S. Wise.
+
+WWW: https://sourceforge.net/projects/rankwidth/
diff --git a/math/rankwidth/pkg-plist b/math/rankwidth/pkg-plist
new file mode 100644
index 000000000000..fe155e750c66
--- /dev/null
+++ b/math/rankwidth/pkg-plist
@@ -0,0 +1,10 @@
+bin/rw
+include/rw.h
+lib/librw.a
+lib/librw.so
+lib/librw.so.0
+lib/librw.so.0.0.0
+%%PORTDOCS%%%%DOCSDIR%%/Hängematte
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/grid
+%%PORTDOCS%%%%DOCSDIR%%/igrid