aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-12-13 13:43:17 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-12-13 13:43:17 +0000
commitf610f4ceab3c4c095c68d64396b8902b51d74a16 (patch)
tree4c6155ec366c3ef25e178d5d7106f105804ed4dd /math
parent7365cece2cb01f639401b807b379c99ae2bec856 (diff)
Notes
Diffstat (limited to 'math')
-rw-r--r--math/octave/Makefile10
-rw-r--r--math/octave/files/patch-configure11
-rw-r--r--math/octave/files/patch-libgnu-math.in.h11
-rw-r--r--math/octave/files/patch-liboctave-eigs-base.cc11
4 files changed, 37 insertions, 6 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index ca62ecf8bca0..76006f4aa796 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -3,7 +3,7 @@
PORTNAME= octave
PORTVERSION= 3.6.4
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= math
MASTER_SITES= ftp://ftp.gnu.org/gnu/octave/ \
ftp://ftp.u-aizu.ac.jp/pub/SciEng/numanal/Octave/bleeding-edge/
@@ -32,7 +32,7 @@ LIB_DEPENDS= GraphicsMagick:${PORTSDIR}/graphics/GraphicsMagick \
umfpack.1:${PORTSDIR}/math/suitesparse \
glpk:${PORTSDIR}/math/glpk
-USES= charsetfix gmake perl5 pkgconfig
+USES= charsetfix fortran gmake perl5 pkgconfig
USE_BZIP2= yes
USE_PERL5= build
USE_TEX= dvipsk:build
@@ -74,8 +74,6 @@ BLAS= -lptf77blas
LAPACK= -lalapack -lptcblas
.endif
-USE_FORTRAN= yes
-
OCTAVE_VERSION= ${PORTVERSION}
GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
PLIST_SUB= OCTAVE_VERSION=${OCTAVE_VERSION} GNU_HOST=${GNU_HOST}
@@ -140,7 +138,7 @@ post-install:
${ECHO_CMD} @dirrm share/octave >> ${WRKDIR}/PLIST
cd ${WRKDIR} ; ${SED} -i -e "/PLIST/ r PLIST" ${TMPPLIST}
-check:
- (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} check)
+check regression-test: build
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} check)
.include <bsd.port.post.mk>
diff --git a/math/octave/files/patch-configure b/math/octave/files/patch-configure
new file mode 100644
index 000000000000..14bcdaaef08f
--- /dev/null
+++ b/math/octave/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2013-02-21 21:21:49.000000000 +0100
++++ configure 2013-11-22 20:34:49.000000000 +0100
+@@ -58248,7 +58248,7 @@
+ main ()
+ {
+
+- std::unordered_map m;
++ std::unordered_map<int, int> m;
+
+ ;
+ return 0;
diff --git a/math/octave/files/patch-libgnu-math.in.h b/math/octave/files/patch-libgnu-math.in.h
new file mode 100644
index 000000000000..e6e185025978
--- /dev/null
+++ b/math/octave/files/patch-libgnu-math.in.h
@@ -0,0 +1,11 @@
+--- libgnu/math.in.h.orig 2013-02-21 21:21:17.000000000 +0100
++++ libgnu/math.in.h 2013-11-22 12:35:47.000000000 +0100
+@@ -17,7 +17,7 @@
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>. */
+
+-#ifndef _@GUARD_PREFIX@_MATH_H
++#if 1
+
+ #if __GNUC__ >= 3
+ @PRAGMA_SYSTEM_HEADER@
diff --git a/math/octave/files/patch-liboctave-eigs-base.cc b/math/octave/files/patch-liboctave-eigs-base.cc
new file mode 100644
index 000000000000..a08e6cbc7336
--- /dev/null
+++ b/math/octave/files/patch-liboctave-eigs-base.cc
@@ -0,0 +1,11 @@
+--- liboctave/eigs-base.cc.orig 2013-02-21 21:19:24.000000000 +0100
++++ liboctave/eigs-base.cc 2013-11-22 20:19:19.000000000 +0100
+@@ -3832,7 +3832,7 @@
+ bool cholB = 0, int disp = 0, int maxit = 300);
+ #endif
+
+-#ifndef _MSC_VER
++#if !defined(_MSC_VER) && !defined(__clang__)
+ template static octave_idx_type
+ lusolve (const SparseMatrix&, const SparseMatrix&, Matrix&);
+