aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
commit0f583d87000061087521fb77c44c9055d122d787 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /math
parent558a51279c03199a7a20966174a8f0a1f33dc9b2 (diff)
downloadports-0f583d87000061087521fb77c44c9055d122d787.tar.gz
ports-0f583d87000061087521fb77c44c9055d122d787.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/abakus/Makefile4
-rw-r--r--math/analitza/Makefile4
-rw-r--r--math/cantor/Makefile4
-rw-r--r--math/kalgebra/Makefile5
-rw-r--r--math/kbruch/Makefile4
-rw-r--r--math/kcalc/Makefile4
-rw-r--r--math/kig/Makefile4
-rw-r--r--math/kmplot/Makefile4
-rw-r--r--math/labplot/Makefile4
-rw-r--r--math/rkward-kde4/Makefile6
-rw-r--r--math/rocs/Makefile4
11 files changed, 24 insertions, 23 deletions
diff --git a/math/abakus/Makefile b/math/abakus/Makefile
index 5339b8c1c6d1..0a0fef7a8b8f 100644
--- a/math/abakus/Makefile
+++ b/math/abakus/Makefile
@@ -15,9 +15,9 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex
LIB_DEPENDS= libmpfr.so:math/mpfr
-USE_KDE4= automoc4 kdelibs
+USES= bison cmake kde:4 tar:bzip2
+USE_KDE= automoc4 kdelibs
USE_QT4= moc_build qmake_build rcc_build uic_build
-USES= bison cmake tar:bzip2
CMAKE_ARGS= -DCMAKE_REQUIRED_INCLUDES:STRING="${LOCALBASE}/include" \
-DCMAKE_REQUIRED_FLAGS:STRING="${LDFLAGS}" \
-DFLEX_EXECUTABLE:FILEPATH=${LOCALBASE}/bin/flex
diff --git a/math/analitza/Makefile b/math/analitza/Makefile
index 8f5836720a23..c1093c6e077e 100644
--- a/math/analitza/Makefile
+++ b/math/analitza/Makefile
@@ -10,8 +10,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Library from KDE Education project
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= corelib gui opengl svg xml \
moc_build qmake_build rcc_build uic_build
USE_GL= glu
diff --git a/math/cantor/Makefile b/math/cantor/Makefile
index 90718b6c15e2..487b5870e0ab 100644
--- a/math/cantor/Makefile
+++ b/math/cantor/Makefile
@@ -14,8 +14,8 @@ LIB_DEPENDS= libspectre.so:print/libspectre \
libqalculate.so:math/libqalculate \
libanalitza.so:math/analitza
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource pkgconfig python:2 tar:xz
+USES= cmake:outsource kde:4 pkgconfig python:2 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= corelib qtestlib_build xml xmlpatterns \
moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/math/kalgebra/Makefile b/math/kalgebra/Makefile
index 3726c569660e..154ff7c93e5c 100644
--- a/math/kalgebra/Makefile
+++ b/math/kalgebra/Makefile
@@ -12,9 +12,10 @@ COMMENT= KDE graph calculator
LIB_DEPENDS= libanalitza.so:math/analitza
CMAKE_ARGS= -DBUILD_mobile:BOOL=FALSE
+
+USES= cmake:outsource kde:4 tar:xz
USE_GL= glu
-USE_KDE4= kdelibs libkdeedu automoc4
-USES= cmake:outsource tar:xz
+USE_KDE= kdelibs libkdeedu automoc4
USE_QT4= corelib declarative gui opengl \
moc_build qmake_build rcc_build uic_build
diff --git a/math/kbruch/Makefile b/math/kbruch/Makefile
index 7cf2bc46f5fe..0e734b345b19 100644
--- a/math/kbruch/Makefile
+++ b/math/kbruch/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE 4 application to exercise fractions
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
index fd6222a7c7e9..6fd5a50ae8ef 100644
--- a/math/kcalc/Makefile
+++ b/math/kcalc/Makefile
@@ -12,8 +12,8 @@ COMMENT= Scientific calculator for KDE
LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr
-USE_KDE4= automoc4 kdelibs
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= automoc4 kdelibs
USE_QT4= xml qmake_build moc_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/math/kig/Makefile b/math/kig/Makefile
index 6eb0f871d7e3..36912f3562db 100644
--- a/math/kig/Makefile
+++ b/math/kig/Makefile
@@ -11,8 +11,8 @@ COMMENT= KDE 4 interactive geometry application
LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource compiler:c++11-lib tar:xz
+USES= cmake:outsource compiler:c++11-lib kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= gui xml moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/math/kmplot/Makefile b/math/kmplot/Makefile
index c477069269e7..745b5496dfc1 100644
--- a/math/kmplot/Makefile
+++ b/math/kmplot/Makefile
@@ -9,8 +9,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Mathematical function plotter for KDE 4
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource tar:xz
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= xml moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index 7be86dd9492e..ac80d4d9b570 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -15,10 +15,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgsl.so:math/gsl
-USES= cmake shared-mime-info tar:bzip2
+USES= cmake kde:4 shared-mime-info tar:bzip2
USE_XORG= xft xpm
USE_GCC= yes
-USE_KDE4= automoc4 kdelibs
+USE_KDE= automoc4 kdelibs
USE_QT4= moc_build qmake_build rcc_build uic_build
post-patch:
diff --git a/math/rkward-kde4/Makefile b/math/rkward-kde4/Makefile
index f8d38649811f..8c7744371ffa 100644
--- a/math/rkward-kde4/Makefile
+++ b/math/rkward-kde4/Makefile
@@ -15,13 +15,13 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/bin/R:math/R
LIB_DEPENDS= libsoprano.so:textproc/soprano
RUN_DEPENDS= ${LOCALBASE}/bin/R:math/R \
- ${KDE4_PREFIX}/lib/kde4/katepart.so:editors/kate
+ ${KDE_PREFIX}/lib/kde4/katepart.so:editors/kate
+USES= cmake gettext fortran kde:4 php:cli shared-mime-info
USE_QT4= corelib dbus gui qmake_build moc_build network phonon rcc_build \
script svg uic_build webkit xml
USE_XORG= x11
-USE_KDE4= automoc4 kdelibs
-USES= cmake gettext fortran php:cli shared-mime-info
+USE_KDE= automoc4 kdelibs
INSTALLS_ICONS= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/math/rocs/Makefile b/math/rocs/Makefile
index f1d04eb8e996..b9515df4b230 100644
--- a/math/rocs/Makefile
+++ b/math/rocs/Makefile
@@ -12,8 +12,8 @@ COMMENT= KDE Graph theory IDE
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
-USE_KDE4= kdelibs automoc4
-USES= cmake:outsource grantlee:4 tar:xz
+USES= cmake:outsource grantlee:4 kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= gui qtestlib script scripttools webkit xml \
moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes