aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-18 03:06:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-18 03:06:29 +0000
commit1253d3b83bb7ef1b578a9b438c43b340cf3a56f9 (patch)
treec12d0484dd1a0dcfe5e10ed623cfbc2ed85bb369 /math
parente5dd5141eb30c337b673fef75930c7e6c6653318 (diff)
downloadports-1253d3b83bb7ef1b578a9b438c43b340cf3a56f9.tar.gz
ports-1253d3b83bb7ef1b578a9b438c43b340cf3a56f9.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-pyFFTW/Makefile23
-rw-r--r--math/py-pyFFTW/distinfo3
-rw-r--r--math/py-pyFFTW/files/patch-setup.py13
-rw-r--r--math/py-pyFFTW/pkg-descr10
5 files changed, 50 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 56d5ca1496b8..2b06f6435851 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -696,6 +696,7 @@
SUBDIR += py-piranha
SUBDIR += py-plastex
SUBDIR += py-probstat
+ SUBDIR += py-pyFFTW
SUBDIR += py-pyasp
SUBDIR += py-pybloom
SUBDIR += py-pycosat
diff --git a/math/py-pyFFTW/Makefile b/math/py-pyFFTW/Makefile
new file mode 100644
index 000000000000..caf1e634fa8d
--- /dev/null
+++ b/math/py-pyFFTW/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= pyFFTW
+DISTVERSION= 0.10.4
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Pythonic wrapper around FFTW, the FFT library
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYNUMPY}
+LIB_DEPENDS= libfftw3.so:math/fftw3 \
+ libfftw3f.so:math/fftw3-float
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python localbase:ldflags
+USE_PYTHON= distutils cython autoplist
+
+.include <bsd.port.mk>
diff --git a/math/py-pyFFTW/distinfo b/math/py-pyFFTW/distinfo
new file mode 100644
index 000000000000..a6a8c146f112
--- /dev/null
+++ b/math/py-pyFFTW/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529290455
+SHA256 (pyFFTW-0.10.4.tar.gz) = 739b436b7c0aeddf99a48749380260364d2dc027cf1d5f63dafb5f50068ede1a
+SIZE (pyFFTW-0.10.4.tar.gz) = 365496
diff --git a/math/py-pyFFTW/files/patch-setup.py b/math/py-pyFFTW/files/patch-setup.py
new file mode 100644
index 000000000000..af46cfc16189
--- /dev/null
+++ b/math/py-pyFFTW/files/patch-setup.py
@@ -0,0 +1,13 @@
+--- setup.py.orig 2016-06-06 16:40:50 UTC
++++ setup.py
+@@ -121,8 +121,8 @@ def get_libraries():
+ libraries = ['libfftw3-3', 'libfftw3f-3', 'libfftw3l-3']
+
+ else:
+- libraries = ['fftw3', 'fftw3f', 'fftw3l', 'fftw3_threads',
+- 'fftw3f_threads', 'fftw3l_threads']
++ libraries = ['fftw3', 'fftw3f', 'fftw3_threads',
++ 'fftw3f_threads']
+
+ return libraries
+
diff --git a/math/py-pyFFTW/pkg-descr b/math/py-pyFFTW/pkg-descr
new file mode 100644
index 000000000000..93015938383d
--- /dev/null
+++ b/math/py-pyFFTW/pkg-descr
@@ -0,0 +1,10 @@
+pyFFTW is a pythonic wrapper around FFTW, the speedy FFT library. The ultimate
+aim is to present a unified interface for all the possible transforms that FFTW
+can perform.
+
+Both the complex DFT and the real DFT are supported, as well as on arbitrary
+axes of abitrary shaped and strided arrays, which makes it almost feature
+equivalent to standard and real FFT functions of numpy.fft (indeed, it supports
+the clongdouble dtype which numpy.fft does not).
+
+WWW: http://hgomersall.github.io/pyFFTW/