aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-06-28 20:43:37 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-06-28 20:43:37 +0000
commit39ecc138366ee9b7d30285954c46f89eb3f3cb50 (patch)
tree1ea311706ec8490c6304f7c9e9668c2a9cb7536d /math
parent26bcffc64285b0e4d8251393114d6c63d9e06bdb (diff)
downloadports-39ecc138366ee9b7d30285954c46f89eb3f3cb50.tar.gz
ports-39ecc138366ee9b7d30285954c46f89eb3f3cb50.zip
math/onednn: fix build on non-amd64 non-aarch64
onednn seems to support only amd64 and aarch64, but there is also generic target which also works on other architectures.
Notes
Notes: svn path=/head/; revision=540729
Diffstat (limited to 'math')
-rw-r--r--math/onednn/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/math/onednn/Makefile b/math/onednn/Makefile
index 47f70844c0e1..0fb71008e2a3 100644
--- a/math/onednn/Makefile
+++ b/math/onednn/Makefile
@@ -31,6 +31,12 @@ OPENMP_BROKEN_OFF= still requires omp.h, see https://github.com/intel/mkl-dnn/is
CXXFLAGS_amd64= -msse4.1
CXXFLAGS_i386= -msse4.1
+.include <bsd.port.options.mk>
+
+.if ${ARCH} != aarch64 && ${ARCH} != amd64
+CMAKE_ARGS+= -DDNNL_TARGET_ARCH:STRING="GENERIC"
+.endif
+
post-install:
@${RM} -r ${STAGEDIR}${PREFIX}/share/doc