aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-11-09 16:54:01 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-11-09 16:54:01 +0000
commit6c2224077f9c29eb175c7281cd233677c102eeb6 (patch)
treee10029a4b268bc187a6a9613740eb53ed3d26032 /math
parent26873a40b354485bfda6cc20c12277cd4628adb6 (diff)
downloadports-6c2224077f9c29eb175c7281cd233677c102eeb6.tar.gz
ports-6c2224077f9c29eb175c7281cd233677c102eeb6.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/msieve/Makefile8
-rw-r--r--math/msieve/distinfo6
-rw-r--r--math/msieve/files/patch-Makefile4
-rw-r--r--math/msieve/pkg-descr2
4 files changed, 8 insertions, 12 deletions
diff --git a/math/msieve/Makefile b/math/msieve/Makefile
index d4c8254272b4..31df50a19378 100644
--- a/math/msieve/Makefile
+++ b/math/msieve/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= msieve
-PORTVERSION= 1.34
+PORTVERSION= 1.38
CATEGORIES= math
MASTER_SITES= http://www.boo.net/~jasonp/ \
http://mirror.roe.ch/dist/msieve/
@@ -39,13 +39,9 @@ CFLAGS+= -O3 -ffast-math -fomit-frame-pointer -D_FILE_OFFSET_BITS=64
CFLAGS+= -D_FILE_OFFSET_BITS=64
.endif
-# Does not build with GCC 4.2
-.if ${OSVERSION} >= 700042
-USE_GCC= 3.4
-.if ${ARCH} == "sparc64"
+.if ${OSVERSION} >= 700042 && ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64-7
.endif
-.endif
ALL_TARGET= generic
.if ${ARCH} == "i386"
diff --git a/math/msieve/distinfo b/math/msieve/distinfo
index 223bc21b1795..8cd78827623f 100644
--- a/math/msieve/distinfo
+++ b/math/msieve/distinfo
@@ -1,3 +1,3 @@
-MD5 (msieve134.tar.gz) = 22ce5db1ddeb2c54978a074176eeee4f
-SHA256 (msieve134.tar.gz) = 570c131d4d1131129b3a68e0e2426f779f4581b9db29d61d891a70df32efba5c
-SIZE (msieve134.tar.gz) = 314962
+MD5 (msieve138.tar.gz) = e6d296466f01f0ae261219f8ee2d3277
+SHA256 (msieve138.tar.gz) = f3856abd5280b1d911569bba438b5ce8a4bfe215df71e85d495a27f77fb3aedb
+SIZE (msieve138.tar.gz) = 305807
diff --git a/math/msieve/files/patch-Makefile b/math/msieve/files/patch-Makefile
index eaa6c80ab47b..b4d794e1d74c 100644
--- a/math/msieve/files/patch-Makefile
+++ b/math/msieve/files/patch-Makefile
@@ -7,8 +7,8 @@
-CC = gcc
+#CC = gcc
WARN_FLAGS = -Wall -W -Wconversion
--OPT_FLAGS = -O3 -fomit-frame-pointer -march=athlon -D_FILE_OFFSET_BITS=64
-+#OPT_FLAGS = -O3 -fomit-frame-pointer -march=athlon -D_FILE_OFFSET_BITS=64
+-OPT_FLAGS = -O3 -fomit-frame-pointer -march=athlon-xp -D_FILE_OFFSET_BITS=64
++#OPT_FLAGS = -O3 -fomit-frame-pointer -march=athlon-xp -D_FILE_OFFSET_BITS=64
#OPT_FLAGS = -O3 -fomit-frame-pointer -march=k8
-CFLAGS = $(OPT_FLAGS) $(MACHINE_FLAGS) $(WARN_FLAGS) -Iinclude -Ignfs/poly
diff --git a/math/msieve/pkg-descr b/math/msieve/pkg-descr
index 0bca3d19f9d8..c85118a2cc54 100644
--- a/math/msieve/pkg-descr
+++ b/math/msieve/pkg-descr
@@ -1,7 +1,7 @@
Msieve is a library and utility for factoring large integers using the most
powerful modern algorithms. It features a stable and very fast implementation
of a self-initializing multiple polynomial quadratic sieve (MPQS), plus a
-somewhat experimental general number field sieve (GNFS) code.
+somewhat experimental general number field sieve (GNFS) implementation.
Primary design goals are speed, portability and ease of use. Msieve claims to
be the fastest implementation for factoring general inputs between 40 and 100