aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /math
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/GiNaC/Makefile5
-rw-r--r--math/algae/Makefile2
-rw-r--r--math/asymptote/Makefile8
-rw-r--r--math/blas/Makefile2
-rw-r--r--math/cgal/Makefile2
-rw-r--r--math/cln/Makefile6
-rw-r--r--math/dieharder/Makefile1
-rw-r--r--math/drgeo/Makefile4
-rw-r--r--math/eispack/Makefile2
-rw-r--r--math/fftw3/Makefile8
-rw-r--r--math/fityk/Makefile5
-rw-r--r--math/freemat/Makefile2
-rw-r--r--math/fung-calc/Makefile2
-rw-r--r--math/galculator/Makefile4
-rw-r--r--math/gambit/Makefile5
-rw-r--r--math/gcalctool/Makefile4
-rw-r--r--math/geg/Makefile4
-rw-r--r--math/gexpr/Makefile3
-rw-r--r--math/giacxcas/Makefile2
-rw-r--r--math/glpk/Makefile1
-rw-r--r--math/gnumeric/Makefile2
-rw-r--r--math/goblin/Makefile2
-rw-r--r--math/graphthing/Makefile5
-rw-r--r--math/gretl/Makefile3
-rw-r--r--math/guppi/Makefile4
-rw-r--r--math/jags/Makefile1
-rw-r--r--math/labplot/Makefile4
-rw-r--r--math/lapacke/Makefile2
-rw-r--r--math/levmar/Makefile2
-rw-r--r--math/lrng/Makefile2
-rw-r--r--math/msieve/Makefile2
-rw-r--r--math/mtrxmath/Makefile2
-rw-r--r--math/ndiff/Makefile1
-rw-r--r--math/octave-devel/Makefile5
-rw-r--r--math/octave/Makefile5
-rw-r--r--math/oleo/Makefile4
-rw-r--r--math/orpie/Makefile4
-rw-r--r--math/pgcalc/Makefile4
-rw-r--r--math/plplot/Makefile6
-rw-r--r--math/prng/Makefile1
-rw-r--r--math/pspp/Makefile5
-rw-r--r--math/py-numpy/Makefile2
-rw-r--r--math/rpy/Makefile1
-rw-r--r--math/scilab/Makefile3
-rw-r--r--math/sdpa-gmp/Makefile5
-rw-r--r--math/surf/Makefile4
-rw-r--r--math/tablix/Makefile7
-rw-r--r--math/testu01/Makefile1
-rw-r--r--math/unuran/Makefile1
-rw-r--r--math/xspread/Makefile4
50 files changed, 73 insertions, 93 deletions
diff --git a/math/GiNaC/Makefile b/math/GiNaC/Makefile
index d8d192121597..c5f6e996f2a9 100644
--- a/math/GiNaC/Makefile
+++ b/math/GiNaC/Makefile
@@ -22,14 +22,13 @@ USE_BZIP2= yes
USE_GNOME= gnomehack pkgconfig
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
MAN1= ginsh.1 viewgar.1
INFO= ginac ginac-examples
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
diff --git a/math/algae/Makefile b/math/algae/Makefile
index bb52f788dee0..6e0750bdf267 100644
--- a/math/algae/Makefile
+++ b/math/algae/Makefile
@@ -24,7 +24,7 @@ MAN1= algae.1
INFO= algae
USE_FORTRAN= yes
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L`${CAT} ${WRKSRC}/LIBDIR`/../../.. -L`${CAT} ${WRKSRC}/LIBDIR` -L${LOCALBASE}/lib"
+LDFLAGS+= -L`${CAT} ${WRKSRC}/LIBDIR`/../../.. -L`${CAT} ${WRKSRC}/LIBDIR` -L${LOCALBASE}/lib
FORTRANLIBS= gfortranbegin gfortran
post-patch:
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index bdb26481ab72..04b9d01f236c 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -50,10 +50,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-latex=${LOCALBASE}/share/texmf/tex/latex \
--with-context=${LOCALBASE}/share/texmf/tex/context/third
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include $${CPPFLAGS}" \
- LFLAGS="-L${LOCALBASE}/lib $${LFLAGS}" \
- CFLAGS="-I${LOCALBASE}/include $${CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib $${LDFLAGS}"
+CONFIGURE_ENV= LFLAGS="-L${LOCALBASE}/lib $${LFLAGS}"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
MAKE_ENV+= ${CONFIGURE_ENV}
MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
diff --git a/math/blas/Makefile b/math/blas/Makefile
index ae585e080897..20ac9ee40438 100644
--- a/math/blas/Makefile
+++ b/math/blas/Makefile
@@ -30,7 +30,7 @@ PLIST_FILES= lib/libblas.a lib/libblas.so lib/libblas.so.${SHLIB_MAJOR}
LDFLAGS+= ${FFLAGS}
LDADD ?= -lgfortran -lm
SRCCONF= ${NONEXISTENT}
-MAKE_ENV+= LDADD="${LDADD}" LDFLAGS="${LDFLAGS}" \
+MAKE_ENV+= LDADD="${LDADD}" \
SHLIB_MAJOR="${SHLIB_MAJOR}" SRCCONF="${SRCCONF}"
.for _u in AR NM RANLIB
MAKE_ENV+= ${_u}="${LOCALBASE}/bin/${_u:L}"
diff --git a/math/cgal/Makefile b/math/cgal/Makefile
index af6d549632fa..85ee5f78bc8c 100644
--- a/math/cgal/Makefile
+++ b/math/cgal/Makefile
@@ -35,7 +35,7 @@ CMAKE_USE_PTHREAD= yes
QT_COMPONENTS= corelib opengl qmake_build gui moc_build rcc_build
HAS_CONFIGURE= yes
DOCSDIR= ${PREFIX}/share/doc/CGAL-3.4
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= cgal_create_cmake_script.1
diff --git a/math/cln/Makefile b/math/cln/Makefile
index c377f05cc5f8..03f223cb54c5 100644
--- a/math/cln/Makefile
+++ b/math/cln/Makefile
@@ -23,9 +23,7 @@ USE_BZIP2= yes
USE_GNOME= gnomehack pkgconfig
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-gmp
-MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
INFO= cln
@@ -34,8 +32,8 @@ MAN1= pi.1
STRIP= # none
CFLAGS+= -fPIC
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
diff --git a/math/dieharder/Makefile b/math/dieharder/Makefile
index 7918a55d2145..016762a03203 100644
--- a/math/dieharder/Makefile
+++ b/math/dieharder/Makefile
@@ -23,7 +23,6 @@ USE_DOS2UNIX= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
MAN1= dieharder.1
MAN3= libdieharder.3
diff --git a/math/drgeo/Makefile b/math/drgeo/Makefile
index a83c8239bb3e..3895ba2ba53f 100644
--- a/math/drgeo/Makefile
+++ b/math/drgeo/Makefile
@@ -20,8 +20,8 @@ USE_GETTEXT= yes
USE_GNOME= gnomehack gnomeprefix intlhack libglade2
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e 's|#!/bin/bash|#!/bin/sh|g' \
diff --git a/math/eispack/Makefile b/math/eispack/Makefile
index 3998a399ff15..cc1a009fe713 100644
--- a/math/eispack/Makefile
+++ b/math/eispack/Makefile
@@ -27,7 +27,7 @@ PLIST_FILES= lib/libeispack.a lib/libeispack.so lib/libeispack.so.${SHLIB_MAJOR}
LDFLAGS+= ${FFLAGS}
SRCCONF= ${NONEXISTENT}
-MAKE_ENV+= LDFLAGS="${LDFLAGS}" SHLIB_MAJOR="${SHLIB_MAJOR}" \
+MAKE_ENV+= SHLIB_MAJOR="${SHLIB_MAJOR}" \
SRCCONF="${SRCCONF}"
OPTIONS= PROFILE "Build and install a profiling library" Off
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 29cb41f99713..da05024549d6 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -27,8 +27,8 @@ USE_PERL5_BUILD=yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-shared --enable-threads
-CONFIGURE_ENV= CPPLAGS="${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CPPFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.if defined(FFTW3_FLAVOR) && ${FFTW3_FLAVOR}=="default"
MAN1= fftw-wisdom-to-conf.1 fftw-wisdom.1
@@ -43,7 +43,7 @@ OPTIONS= OPTIMIZED_CFLAGS "Enable optimized CFLAGS" off
.include <bsd.port.pre.mk>
.if defined(WITH_OPTIMIZED_CFLAGS)
-CONFIGURE_ENV+= CFLAGS="${CFLAGS:N-O:N-O*} -O2 -ffast-math -fomit-frame-pointer"
+CFLAGS:= ${CFLAGS:N-O:N-O*} -O2 -ffast-math -fomit-frame-pointer
.if ${FFTW3_FLAVOR}=="default" && ${MACHINE_CPU:Msse}
# !!Detect SSE and not SSE2!!
CONFIGURE_ARGS+=--enable-sse2
@@ -61,7 +61,7 @@ CFLAGS_3DNOW= ${CFLAGS:N-O:N-O*} -O3 -fomit-frame-pointer -fno-schedule-insns \
.if ${ARCH} != "amd64"
CFLAGS_3DNOW+= -malign-double
.endif
-CONFIGURE_ENV+= CFLAGS="${CFLAGS_3DNOW}"
+CFLAGS+= ${CFLAGS_3DNOW}
.endif
.endif # end WITH_OPTIMIZED_CFLAGS
diff --git a/math/fityk/Makefile b/math/fityk/Makefile
index 1b7daf2bd609..888e3a2b2820 100644
--- a/math/fityk/Makefile
+++ b/math/fityk/Makefile
@@ -31,7 +31,6 @@ USE_WX= 2.8+
WX_CONF_ARGS= absolute
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --without-doc --disable-xyconvert
USE_LDCONFIG= yes
@@ -39,9 +38,9 @@ MAN1= fityk.1 xyconv.1
PORTDOCS= *
CFLAGS+= -D_GNU_SOURCE
-CPPFLAGS= -I${WRKDIR}/${XYLIB_DISTNAME} \
+CPPFLAGS+= -I${WRKDIR}/${XYLIB_DISTNAME} \
-I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${WRKDIR}/${XYLIB_DISTNAME}/xylib/.libs \
+LDFLAGS+= -L${WRKDIR}/${XYLIB_DISTNAME}/xylib/.libs \
-L${LOCALBASE}/lib ${PTHREAD_LIBS}
XYLIB_DISTNAME= xylib-0.6
diff --git a/math/freemat/Makefile b/math/freemat/Makefile
index 8e3f82539856..1fd0a783a65f 100644
--- a/math/freemat/Makefile
+++ b/math/freemat/Makefile
@@ -39,7 +39,7 @@ USE_QT_VER= 4
USE_CMAKE= yes
QT_COMPONENTS= gui network opengl moc_build rcc_build uic_build \
qmake_build xml svg
-CPPFLAGS= ${CXXFLAGS} -I${LOCALBASE}/include ${AMDINC}
+CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include ${AMDINC}
SLAVEDIRS= math/freemat-mpi
diff --git a/math/fung-calc/Makefile b/math/fung-calc/Makefile
index ae62dc89af44..3e6830553ccf 100644
--- a/math/fung-calc/Makefile
+++ b/math/fung-calc/Makefile
@@ -18,7 +18,7 @@ USE_GL= glut
USE_GMAKE= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
pre-configure:
@${REINPLACE_CMD} -e 's|-O2|-fPIC|g; s|-lpthread|${PTHREAD_LIBS}|g' \
diff --git a/math/galculator/Makefile b/math/galculator/Makefile
index fcae29fe5757..06a9b36f5ec4 100644
--- a/math/galculator/Makefile
+++ b/math/galculator/Makefile
@@ -18,8 +18,8 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= libglade2
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_SAFE= yes
MAN1= galculator.1
diff --git a/math/gambit/Makefile b/math/gambit/Makefile
index bcb1c726487e..75b9bcafbe96 100644
--- a/math/gambit/Makefile
+++ b/math/gambit/Makefile
@@ -18,12 +18,11 @@ USE_GNOME= gtk20
WANT_UNICODE= yes
USE_WX= 2.6+
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS+=--with-wx-config=${WX_CONFIG}
USE_LDCONFIG= yes
-CPPFLAGS= ${PTHREAD_CFLAGS}
-LDFLAGS= ${PTHREAD_LIBS}
+CPPFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
.if !defined(CFLAGS) || ${CFLAGS:M-fno-strict-aliasing*} == ""
CFLAGS+= -O2 -fno-strict-aliasing
.endif
diff --git a/math/gcalctool/Makefile b/math/gcalctool/Makefile
index 874fe82d50f4..d89083ead85f 100644
--- a/math/gcalctool/Makefile
+++ b/math/gcalctool/Makefile
@@ -24,8 +24,8 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_GNOME= gnomeprefix gnomehack intlhack gconf2 gnomedocutils gtk20
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= gcalctool.1
GLIB_SCHEMAS= org.gnome.gcalctool.gschema.xml
diff --git a/math/geg/Makefile b/math/geg/Makefile
index a48e80035177..e23e7ad2ddde 100644
--- a/math/geg/Makefile
+++ b/math/geg/Makefile
@@ -19,8 +19,8 @@ COMMENT= Visualise multiple 2D-functions of one variable
USE_GNOME= gtk12
USE_AUTOTOOLS= automake autoconf
AUTOMAKE_ARGS= -a -i
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
MAN1= geg.1
PLIST_FILES= bin/geg
diff --git a/math/gexpr/Makefile b/math/gexpr/Makefile
index ae2b2983696b..8ef3eb44c34d 100644
--- a/math/gexpr/Makefile
+++ b/math/gexpr/Makefile
@@ -16,9 +16,6 @@ MASTER_SITE_SUBDIR= apps/math/calc
MAINTAINER= ports@FreeBSD.org
COMMENT= A shell calculator
-MAKE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
-
MAN1= gexpr.1
PLIST_FILES= bin/gexpr
diff --git a/math/giacxcas/Makefile b/math/giacxcas/Makefile
index 1ac3f375a2a1..898f0b66e6f3 100644
--- a/math/giacxcas/Makefile
+++ b/math/giacxcas/Makefile
@@ -46,8 +46,6 @@ CONFIGURE_ARGS= --disable-pari
CXXFLAGS+= -DSMARTPTR64 -D_I386_ -fPIC
.endif
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-
WRKSRC= ${WRKDIR}/giac-${PORTVERSION}
FLTKDEV-GIAC= ${WRKDIR}/fltk-1.3.x-r6916
COCOALIB-GIAC= ${WRKDIR}/CoCoALib-0.9937
diff --git a/math/glpk/Makefile b/math/glpk/Makefile
index dbddfb48407c..99e725888c61 100644
--- a/math/glpk/Makefile
+++ b/math/glpk/Makefile
@@ -27,7 +27,6 @@ USE_LDCONFIG= yes
CFLAGS+= -trigraphs
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS+= --with-gmp --with-zlib
.include <bsd.port.pre.mk>
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index 5a314ec8725d..1b0935e6bbe1 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -39,7 +39,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gnome --disable-silent-rules
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -liconv ${PTHREAD_LIBS}" \
python_prog=${PYTHON_VERSION}
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
MAKE_JOBS_SAFE= yes
GLIB_SCHEMAS= org.gnome.gnumeric.dialogs.gschema.xml \
diff --git a/math/goblin/Makefile b/math/goblin/Makefile
index 00aac906486c..0e90e9171c9e 100644
--- a/math/goblin/Makefile
+++ b/math/goblin/Makefile
@@ -29,7 +29,7 @@ PLIST_SUB+= VERSION=${PORTVERSION:R}
CFLAGS+= -I${LOCALBASE}/include/tcl${TCL_VER} -I${LOCALBASE}/include/ \
-I${LOCALBASE}/include/tk${TK_VER} ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -ltcl${USE_TCL} -ltk${USE_TK} ${PTHREAD_LIBS}
+LDFLAGS+= -L${LOCALBASE}/lib -ltcl${USE_TCL} -ltk${USE_TK} ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
diff --git a/math/graphthing/Makefile b/math/graphthing/Makefile
index 4b8138ed6b4f..5f3ac7fecab7 100644
--- a/math/graphthing/Makefile
+++ b/math/graphthing/Makefile
@@ -25,13 +25,12 @@ USE_GMAKE= yes
USE_WX= 2.6
WX_CONF_ARGS= absolute
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAKEFILE= GNUmakefile
PLIST_FILES= bin/graphthing bin/gt
-CPPFLAGS= ${PTHREAD_CFLAGS}
-LDFLAGS= ${PTHREAD_LIBS}
+CPPFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/graphthing ${PREFIX}/bin
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index ca41c642400d..d75efd05662c 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -28,8 +28,7 @@ ALL_TARGET= # empty
CONFIGURE_ARGS = --enable-static --enable-shared --with-gmake --without-gnome
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= LAPACK_LIBS="${LAPACK} ${BLAS}" \
- LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= LAPACK_LIBS="${LAPACK} ${BLAS}"
MAN1= gretl.1
OPTIONS= ATLAS "Use Atlas for BLAS and LAPACK" off \
diff --git a/math/guppi/Makefile b/math/guppi/Makefile
index 585d3f54f7b7..f1c9199d58ef 100644
--- a/math/guppi/Makefile
+++ b/math/guppi/Makefile
@@ -26,9 +26,9 @@ USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gnumeric --enable-explicit-python-linking
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/libglade-1.0" \
- LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
GNUMERIC_IDLDIR="${WRKDIR}/gnumeric"
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libglade-1.0
PLIST_SUB= VERSION="${PORTVERSION}"
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
diff --git a/math/jags/Makefile b/math/jags/Makefile
index c090fb1aefac..748cf50e7900 100644
--- a/math/jags/Makefile
+++ b/math/jags/Makefile
@@ -34,7 +34,6 @@ WRKSRC= ${WRKDIR}/${PKGNAME:S/mcmc-//:U}
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
USE_FORTRAN= yes
USE_LDCONFIG= yes
USE_BISON= build
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index b7fefd157d0f..fee85831e65a 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -31,8 +31,8 @@ USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_GETTEXT= yes
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
CONFIGURE_ARGS+=--enable-system-qwtplot3d=yes --enable-system-liborigin=yes \
--enable-ocaml=no --enable-fftw=no
diff --git a/math/lapacke/Makefile b/math/lapacke/Makefile
index 80284cc12750..acc4f60ffce6 100644
--- a/math/lapacke/Makefile
+++ b/math/lapacke/Makefile
@@ -52,7 +52,7 @@ LAPACK= -lpthread -lalapack_r
LDFLAGS+= -L${LOCALBASE}/lib -lgfortran -lgcc_s
LDADD?= -lgfortran -lgcc_s
-MAKE_ENV= LDADD="${LDADD}" LDFLAGS="${LDFLAGS}"
+MAKE_ENV= LDADD="${LDADD}"
.if defined(WITHOUT_LAPACK_LATEST)
MAKE_ENV+= WITHOUT_LAPACK_LATEST=yes
.endif
diff --git a/math/levmar/Makefile b/math/levmar/Makefile
index 01c16baf5b5c..4d76f8ae0a91 100644
--- a/math/levmar/Makefile
+++ b/math/levmar/Makefile
@@ -50,7 +50,7 @@ LAPACK= -lalapack_r
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
SRCCONF= ${NONEXISTENT}
-MAKE_ENV= LDADD="${LAPACK} ${BLAS}" LDFLAGS="${LDFLAGS}" \
+MAKE_ENV= LDADD="${LAPACK} ${BLAS}" \
SRCCONF="${SRCCONF}"
.if !defined(NOPORTDOCS)
diff --git a/math/lrng/Makefile b/math/lrng/Makefile
index c9dc75966522..8dc7ad52eabe 100644
--- a/math/lrng/Makefile
+++ b/math/lrng/Makefile
@@ -29,7 +29,7 @@ LICENSE= GPLv3
CLEANFILES= ${SRCS}
LIB= ${PORTNAME}
LIBDIR = ${PREFIX}/lib
-MAKE_ENV+= CLEANFILES="${CLEANFILES}" LDFLAGS="${LDFLAGS}" \
+MAKE_ENV+= CLEANFILES="${CLEANFILES}" \
LIB="${LIB}" LIBDIR="${LIBDIR}" SHLIB_MAJOR="${SHLIB_MAJOR}" \
SRCS="${SRCS}" SRCCONF="${SRCCONF}"
NO_WRKSUBDIR= yes
diff --git a/math/msieve/Makefile b/math/msieve/Makefile
index 6aee0ef06a6c..a608c2f02768 100644
--- a/math/msieve/Makefile
+++ b/math/msieve/Makefile
@@ -22,7 +22,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_ENV= LDFLAGS="${LDFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}" ECM=1
+MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" ECM=1
HEADERS= mp.h msieve.h util.h
PLIST_FILES= bin/msieve lib/libmsieve.a ${HEADERS:S|^|include/msieve/|}
diff --git a/math/mtrxmath/Makefile b/math/mtrxmath/Makefile
index b3549951b2c9..00f691cacdbf 100644
--- a/math/mtrxmath/Makefile
+++ b/math/mtrxmath/Makefile
@@ -13,8 +13,6 @@ MASTER_SITES= http://www.angelfire.com/linux/linuxjeff/mtrxmath/files/
MAINTAINER= ports@FreeBSD.org
COMMENT= A small tool for matrix mathemetics
-MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-
PORTDOCS= README
PLIST_FILES= bin/mtrxmath
diff --git a/math/ndiff/Makefile b/math/ndiff/Makefile
index 90bc5e4084ae..37c74c07f1fc 100644
--- a/math/ndiff/Makefile
+++ b/math/ndiff/Makefile
@@ -22,7 +22,6 @@ LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-gmp
-CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
.else
.if ${ARCH} == sparc64
CONFIGURE_ARGS= --with-long-double
diff --git a/math/octave-devel/Makefile b/math/octave-devel/Makefile
index 073eb062a46a..d7a3225aee1b 100644
--- a/math/octave-devel/Makefile
+++ b/math/octave-devel/Makefile
@@ -73,16 +73,15 @@ OCTAVE_VERSION= ${PORTVERSION}
GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
PLIST_SUB= OCTAVE_VERSION=${OCTAVE_VERSION} GNU_HOST=${GNU_HOST}
INCLUDES= -I${LOCALBASE}/include -I${LOCALBASE}/include/metis
-MAKE_ENV+= CPPFLAGS="${CPPFLAGS} ${INCLUDES}" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CFLAGS+= ${INCLUDES}
CXXFLAGS+= ${INCLUDES}
CPPFLAGS+= ${INCLUDES}
CONFIGURE_ENV+= GPERF="${LOCALBASE}/bin/gperf" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CC="${CC}" \
CXX="${CXX}" \
TERMIOS_H="termios.h"
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ARGS= --host=${GNU_HOST} \
--with-blas="-L${LOCALBASE}/lib ${BLAS}" \
--with-lapack="${LAPACK}" \
diff --git a/math/octave/Makefile b/math/octave/Makefile
index f498a030d271..0e052897a58c 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -77,16 +77,15 @@ OCTAVE_VERSION= ${PORTVERSION}
GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
PLIST_SUB= OCTAVE_VERSION=${OCTAVE_VERSION} GNU_HOST=${GNU_HOST}
INCLUDES= -I${LOCALBASE}/include
-MAKE_ENV+= CPPFLAGS="${CPPFLAGS} ${INCLUDES}" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CFLAGS+= ${INCLUDES}
CXXFLAGS+= ${INCLUDES}
CPPFLAGS+= ${INCLUDES}
CONFIGURE_ENV+= GPERF="${LOCALBASE}/bin/gperf" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CC="${CC}" \
CXX="${CXX}" \
MAKEINFO=${PREFIX}/bin/makeinfo
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ARGS= --host=${GNU_HOST} \
--with-blas="-L${LOCALBASE}/lib ${BLAS}" \
--with-lapack="${LAPACK}" \
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index 46036b6c6093..c1c935fe9c99 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -18,8 +18,8 @@ COMMENT= The GNU spreadsheet for X11 and terminals
USE_PERL5_BUILD= yes
USE_BISON= build
USE_AUTOTOOLS= autoconf213
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS= --with-x --without-xlt --without-SciPlot
INFO= oleo
diff --git a/math/orpie/Makefile b/math/orpie/Makefile
index 92f63f80c61c..fa5704352f81 100644
--- a/math/orpie/Makefile
+++ b/math/orpie/Makefile
@@ -19,8 +19,8 @@ LIB_DEPENDS= gsl.16:${PORTSDIR}/math/gsl
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/orpie bin/orpie-curses-keys etc/orpierc
diff --git a/math/pgcalc/Makefile b/math/pgcalc/Makefile
index d0cde38f0301..079eb3db9809 100644
--- a/math/pgcalc/Makefile
+++ b/math/pgcalc/Makefile
@@ -19,8 +19,8 @@ USE_KDELIBS_VER= 3
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
INSTALLS_ICONS= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS= ARTS "Build with aRts support" on
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 6ce9457c3f76..28ddc9875d63 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -27,9 +27,9 @@ USE_CMAKE= yes
USE_PERL5_BUILD=yes
USE_GNOME= pango
USE_GHOSTSCRIPT=yes
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- WITH_FREETYPE=ON
+CONFIGURE_ENV+= WITH_FREETYPE=ON
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CMAKE_ARGS+= -DENABLE_java:BOOL=OFF -DENABLE_octave:BOOL=OFF \
-DENABLE_ada:BOOL=OFF -DENABLE_d:BOOL=OFF \
-DPLD_plmeta=ON
diff --git a/math/prng/Makefile b/math/prng/Makefile
index 4b252393fbdc..e2d70b7d36d6 100644
--- a/math/prng/Makefile
+++ b/math/prng/Makefile
@@ -15,7 +15,6 @@ LICENSE= GPLv2
CFLAGS+= -fgnu89-inline
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
INFO= prng
PLIST_FILES= include/prng.h lib/libprng.a
PORTDOCS= prng.dvi prng.pdf prng.ps prng.txt
diff --git a/math/pspp/Makefile b/math/pspp/Makefile
index 225ae0a2c8e7..492661ec09b0 100644
--- a/math/pspp/Makefile
+++ b/math/pspp/Makefile
@@ -26,12 +26,11 @@ USE_ICONV= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INFO= pspp pspp-dev
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
diff --git a/math/py-numpy/Makefile b/math/py-numpy/Makefile
index c1dccd30e641..b67560a6c0a8 100644
--- a/math/py-numpy/Makefile
+++ b/math/py-numpy/Makefile
@@ -75,6 +75,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e "s+%%FC%%+${FC}+" ${WRKSRC}/numpy/distutils/fcompiler/gnu.py
@${CP} ${FILESDIR}/site.cfg ${WRKSRC}/site.cfg
+# ignore LDFLAGS from env, as it overrides internal flags (e.g. -shared) for some reason
+ @${REINPLACE_CMD} -e "s|'LDFLAGS'|None|" ${WRKSRC}/numpy/distutils/fcompiler/__init__.py
GCCLIBDIR_CMDS= ${FC} -print-file-name=libgfortran.so|${SED} -e s/libgfortran.so//
pre-configure:
diff --git a/math/rpy/Makefile b/math/rpy/Makefile
index 30b2c2c4a905..40da72a8e3ec 100644
--- a/math/rpy/Makefile
+++ b/math/rpy/Makefile
@@ -26,7 +26,6 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
USE_PYTHON= yes
USE_PYDISTUTILS= yes
LDFLAGS+= -L${LOCALBASE}/lib/R/modules -L${LOCALBASE}/lib/R/lib
-MAKE_ENV= LDFLAGS="${LDFLAGS}"
post-patch:
@${REINPLACE_CMD} -e 's,^statichere ,,' ${WRKSRC}/src/rpymodule.c
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 4d7a0f58cac8..8f0f1c808c38 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -34,8 +34,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS = --with-gfortran
CONFIGURE_ENV= ac_cv_search_pthread_join="${PTHREAD_LIBS}" \
- BLAS_LIBS="${BLAS_LIBS}" LAPACK_LIBS="${LAPACK_LIBS}" \
- LDFLAGS="${LDFLAGS}"
+ BLAS_LIBS="${BLAS_LIBS}" LAPACK_LIBS="${LAPACK_LIBS}"
OPTIONS= ATLAS "Use Atlas instead of Blas" OFF \
FFTW "Use FFTW" ON \
diff --git a/math/sdpa-gmp/Makefile b/math/sdpa-gmp/Makefile
index 80dd0abd5472..acf7fe49857e 100644
--- a/math/sdpa-gmp/Makefile
+++ b/math/sdpa-gmp/Makefile
@@ -30,7 +30,10 @@ LIB_DEPENDS+= spooles:${PORTSDIR}/math/spooles \
mpfr.4:${PORTSDIR}/math/mpfr
CONFIGURE_ARGS+= --with-system-spooles
-CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles" CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles" CFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles" LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles
+CXXFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles
PLIST_SUB+= MANUALFILE=${MANUALFILE}
diff --git a/math/surf/Makefile b/math/surf/Makefile
index 0c594964a053..435a2d46d17f 100644
--- a/math/surf/Makefile
+++ b/math/surf/Makefile
@@ -22,8 +22,8 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
USE_XORG= x11 xmu
USE_GNOME= gtk12
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-cups --datadir=${PREFIX}/share
CONFLICTS= surf-0* # www/surf
diff --git a/math/tablix/Makefile b/math/tablix/Makefile
index 060cb3a36be6..869a3a9995b3 100644
--- a/math/tablix/Makefile
+++ b/math/tablix/Makefile
@@ -25,9 +25,10 @@ USE_GNOME= libxml2
GNU_CONFIGURE= yes
USE_GETTEXT= yes
-CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LIBS=-L${PREFIX}/lib \
- LDFLAGS=-L${PREFIX}/lib \
- PVM_ROOT=${PVM_ROOT} PVM_LIB=${PREFIX}/lib
+CONFIGURE_ENV= LIBS=-L${PREFIX}/lib \
+ PVM_ROOT=${PVM_ROOT} PVM_LIB=${PREFIX}/lib
+CPPFLAGS+= -I${PREFIX}/include
+LDFLAGS+= -L${PREFIX}/lib
MAN1= tablix2.1 tablix2_benchmark.1 tablix2_kernel.1 tablix2_output.1 \
tablix2_plot.1 tablix2_test.1
diff --git a/math/testu01/Makefile b/math/testu01/Makefile
index b19576fc87c9..f20a23f492f5 100644
--- a/math/testu01/Makefile
+++ b/math/testu01/Makefile
@@ -26,7 +26,6 @@ USE_GMAKE= yes
MAKE_ARGS= docdir="${DOCSDIR}" exdir="${EXAMPLESDIR}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
CFLAGS+= -fPIC
PLIST_SUB= PORTNAME="${PORTNAME}"
diff --git a/math/unuran/Makefile b/math/unuran/Makefile
index 4bfa3897d081..fa247ad1ca38 100644
--- a/math/unuran/Makefile
+++ b/math/unuran/Makefile
@@ -23,7 +23,6 @@ CONFIGURE_ARGS= --enable-shared --with-urng-rngstream --with-urng-default=rngstr
--enable-info
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
MAKE_ENV= MAKE="${GMAKE}"
USE_LDCONFIG= yes
diff --git a/math/xspread/Makefile b/math/xspread/Makefile
index 2461dd361ba3..cabcd1d5a1d2 100644
--- a/math/xspread/Makefile
+++ b/math/xspread/Makefile
@@ -18,8 +18,8 @@ COMMENT= A spreadsheet program for X and terminals
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
MAN1= xspread.1 pxspread.1