aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2019-11-21 23:42:26 +0000
committerGreg Lewis <glewis@FreeBSD.org>2019-11-21 23:42:26 +0000
commitbbaf74b749822437536980ee892cc316c45c0db8 (patch)
tree4fa3f7439c30b78325727f8edb0eeb6069147418 /math
parent9284189c601bc45bdf3e2c838579c9b8ecf246ad (diff)
downloadports-bbaf74b749822437536980ee892cc316c45c0db8.tar.gz
ports-bbaf74b749822437536980ee892cc316c45c0db8.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/gnuplot/Makefile2
-rw-r--r--math/gnuplot/files/patch-term-fig.trm15
2 files changed, 16 insertions, 1 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 81bc189d5223..3086d6c691f2 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gnuplot
PORTVERSION= 5.2.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math graphics
MASTER_SITES= SF
diff --git a/math/gnuplot/files/patch-term-fig.trm b/math/gnuplot/files/patch-term-fig.trm
new file mode 100644
index 000000000000..1957921c914c
--- /dev/null
+++ b/math/gnuplot/files/patch-term-fig.trm
@@ -0,0 +1,15 @@
+--- term/fig.trm.orig
++++ term/fig.trm
+@@ -680,11 +680,11 @@
+ double empirical_scale = 3.0;
+ (void) custom_dash_pattern; /* ignore */
+ if (type <= 0)
+- type = LT_SOLID;
++ type = SOLID_LINE;
+ FIG_type = type % 6;
+ /* FIXME: should pass through "dl" somehow */
+ FIG_spacing = empirical_scale * FIG_current_linewidth;
+- FIG_line.cap_style = (FIG_type == 0) ? CAP_BUTT : CAP_ROUND;
++ FIG_line.cap_style = (FIG_type == SOLID_LINE) ? CAP_BUTT : CAP_ROUND;
+ }
+