aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2014-03-04 10:17:29 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2014-03-04 10:17:29 +0000
commitbedee53426e318d43a869fcffc06138f2d643682 (patch)
treead916a34204134f87a0d2fc6fe677a99db31c17c /math
parentd3399db0aa4e4ef035d58b529870f9d5ce4f3459 (diff)
downloadports-bedee53426e318d43a869fcffc06138f2d643682.tar.gz
ports-bedee53426e318d43a869fcffc06138f2d643682.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/py-pandas/Makefile34
-rw-r--r--math/py-pandas/distinfo4
-rw-r--r--math/py-pandas/files/print_skipped.py51
3 files changed, 73 insertions, 16 deletions
diff --git a/math/py-pandas/Makefile b/math/py-pandas/Makefile
index 862ae0cf7d6d..d90086eca6f7 100644
--- a/math/py-pandas/Makefile
+++ b/math/py-pandas/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= pandas
-PORTVERSION= 0.13.0
+PORTVERSION= 0.13.1
CATEGORIES= math devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,26 +11,28 @@ COMMENT= Flexible, high-performance data analysis in Python
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= ${PYNUMPY} \
- cython:${PORTSDIR}/lang/cython
+BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS:= ${BUILD_DEPENDS} \
${PYTHON_PKGNAMEPREFIX}dateutil>0:${PORTSDIR}/devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
-TEST_DEPENDS= nosetests:${PORTSDIR}/devel/py-nose \
+TEST_DEPENDS= ${RUN_DEPENDS} \
+ nosetests:${PORTSDIR}/devel/py-nose \
cython:${PORTSDIR}/lang/cython \
- ${PYTHON_PKGNAMEPREFIX}numexpr>0:${PORTSDIR}/math/py-numexpr \
+ ${PYTHON_PKGNAMEPREFIX}boto>0:${PORTSDIR}/devel/py-boto \
+ ${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml \
${PYTHON_PKGNAMEPREFIX}tables>0:${PORTSDIR}/devel/py-tables \
- ${PYTHON_PKGNAMEPREFIX}scipy>0:${PORTSDIR}/science/py-scipy \
+ ${PYTHON_PKGNAMEPREFIX}bottleneck>0:${PORTSDIR}/math/py-bottleneck \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:${PORTSDIR}/math/py-matplotlib \
+ ${PYTHON_PKGNAMEPREFIX}numexpr>0:${PORTSDIR}/math/py-numexpr \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:${PORTSDIR}/science/py-scipy \
+ ${PYTHON_PKGNAMEPREFIX}openpyxl>0:${PORTSDIR}/textproc/py-openpyxl \
${PYTHON_PKGNAMEPREFIX}xlrd>0:${PORTSDIR}/textproc/py-xlrd \
${PYTHON_PKGNAMEPREFIX}xlwt>0:${PORTSDIR}/textproc/py-xlwt \
- ${PYTHON_PKGNAMEPREFIX}openpyxl>0:${PORTSDIR}/textproc/py-openpyxl \
- ${PYTHON_PKGNAMEPREFIX}statsmodels>0:${PORTSDIR}/math/py-statsmodels \
- ${PYTHON_PKGNAMEPREFIX}bottleneck>0:${PORTSDIR}/math/py-bottleneck \
${PYTHON_PKGNAMEPREFIX}beautifulsoup>0:${PORTSDIR}/www/py-beautifulsoup \
- ${PYTHON_PKGNAMEPREFIX}html5lib>0:${PORTSDIR}/www/py-html5lib \
- ${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml
+ ${PYTHON_PKGNAMEPREFIX}html5lib>0:${PORTSDIR}/www/py-html5lib
+# Note: we cannot include math/py-statsmodels in TEST_DEPENDS because it
+# depends upon us for BUILD and RUN.
SUB_FILES= pkg-message
@@ -42,12 +44,16 @@ PYDISTUTILS_AUTOPLIST= yes
# on a headless (X11-less) host (eg: RedPorts)
#USES= display:regression-test
+XUNITFILE= ${WRKDIR}/nosetests.xml
+NOSE_ENV= http_proxy=${HTTP_PROXY}
+NOSE_ARGS= ${PORTNAME} --exe --with-xunit --xunit-file=${XUNITFILE}
+
regression-test: build
@(cd ${WRKSRC} && \
${PYTHON_CMD} ${PYSETUP} build_ext --inplace && \
- ${PYTHON_CMD} ci/print_versions.py \
- ci/script.sh \
- ${PYTHON_CMD} ci/print_skipped.py \
+ ${PYTHON_CMD} -c 'import pandas.util.print_versions as pv; pv.show_versions()' && \
+ ( ${SETENV} ${NOSE_ENV} nosetests ${NOSE_ARGS} || ${TRUE} ) && \
+ ${PYTHON_CMD} ${SCRIPTDIR}/print_skipped.py ${XUNITFILE}
)
.include <bsd.port.mk>
diff --git a/math/py-pandas/distinfo b/math/py-pandas/distinfo
index 9e182f598e03..395b9da51c26 100644
--- a/math/py-pandas/distinfo
+++ b/math/py-pandas/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pandas-0.13.0.tar.gz) = f034cd298e0d68fee24a2b0a68a9b8da41978d6f39474f908f7f352904ef7f3c
-SIZE (pandas-0.13.0.tar.gz) = 3572047
+SHA256 (pandas-0.13.1.tar.gz) = 6813746caa796550969ed98069f16627f070f6d8d60686cfb3fa0e66c2e0312b
+SIZE (pandas-0.13.1.tar.gz) = 6096890
diff --git a/math/py-pandas/files/print_skipped.py b/math/py-pandas/files/print_skipped.py
new file mode 100644
index 000000000000..9fb05df64bce
--- /dev/null
+++ b/math/py-pandas/files/print_skipped.py
@@ -0,0 +1,51 @@
+#!/usr/bin/env python
+
+import sys
+import math
+import xml.etree.ElementTree as et
+
+
+def parse_results(filename):
+ tree = et.parse(filename)
+ root = tree.getroot()
+ skipped = []
+
+ current_class = old_class = ''
+ i = 1
+ assert i - 1 == len(skipped)
+ for el in root.findall('testcase'):
+ cn = el.attrib['classname']
+ for sk in el.findall('skipped'):
+ old_class = current_class
+ current_class = cn
+ name = '{classname}.{name}'.format(classname=current_class,
+ name=el.attrib['name'])
+ msg = sk.attrib['message']
+ out = ''
+ if old_class != current_class:
+ ndigits = int(math.log(i, 10) + 1)
+ out += ('-' * (len(name + msg) + 4 + ndigits) + '\n') # 4 for : + space + # + space
+ out += '#{i} {name}: {msg}'.format(i=i, name=name, msg=msg)
+ skipped.append(out)
+ i += 1
+ assert i - 1 == len(skipped)
+ assert i - 1 == len(skipped)
+ assert len(skipped) == int(root.attrib['skip'])
+ return '\n'.join(skipped)
+
+
+def main(args):
+ print('SKIPPED TESTS:')
+ print(parse_results(args.filename))
+ return 0
+
+
+def parse_args():
+ import argparse
+ parser = argparse.ArgumentParser()
+ parser.add_argument('filename', help='XUnit file to parse')
+ return parser.parse_args()
+
+
+if __name__ == '__main__':
+ sys.exit(main(parse_args()))