aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2013-02-05 22:26:31 +0000
committerGabor Pali <pgj@FreeBSD.org>2013-02-05 22:26:31 +0000
commitc731105b7f8e403a3db33599a7d7f1ce9257f375 (patch)
tree23d3f49a5183d8fbc5324dad9a1ae399f457b1d7 /math
parent32ca3ee61e3889801319024959589312eb652bfa (diff)
downloadports-c731105b7f8e403a3db33599a7d7f1ce9257f375.tar.gz
ports-c731105b7f8e403a3db33599a7d7f1ce9257f375.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile4
-rw-r--r--math/hs-Agda-executable/Makefile2
-rw-r--r--math/hs-Agda/Makefile4
-rw-r--r--math/hs-Agda/files/patch-Agda.cabal11
-rw-r--r--math/hs-Agda/files/patch-src__full__Agda__TypeChecking__Serialise.hs11
-rw-r--r--math/hs-NumInstances/Makefile2
-rw-r--r--math/hs-categories/Makefile2
-rw-r--r--math/hs-categories/distinfo4
-rw-r--r--math/hs-comonad-transformers/Makefile2
-rw-r--r--math/hs-comonad-transformers/distinfo4
-rw-r--r--math/hs-comonad/Makefile2
-rw-r--r--math/hs-comonad/distinfo4
-rw-r--r--math/hs-comonads-fd/Makefile16
-rw-r--r--math/hs-comonads-fd/distinfo2
-rw-r--r--math/hs-comonads-fd/pkg-descr3
-rw-r--r--math/hs-contravariant/Makefile2
-rw-r--r--math/hs-data-lens-template/Makefile1
-rw-r--r--math/hs-data-lens/Makefile1
-rw-r--r--math/hs-distributive/Makefile5
-rw-r--r--math/hs-distributive/distinfo4
-rw-r--r--math/hs-distributive/files/patch-distributive.cabal12
-rw-r--r--math/hs-erf/Makefile2
-rw-r--r--math/hs-groupoids/Makefile15
-rw-r--r--math/hs-groupoids/distinfo2
-rw-r--r--math/hs-groupoids/pkg-descr3
-rw-r--r--math/hs-ieee754/Makefile2
-rw-r--r--math/hs-math-functions/Makefile1
-rw-r--r--math/hs-mwc-random/Makefile1
-rw-r--r--math/hs-nats/Makefile13
-rw-r--r--math/hs-nats/distinfo2
-rw-r--r--math/hs-nats/pkg-descr3
-rw-r--r--math/hs-pointed/Makefile4
-rw-r--r--math/hs-pointed/distinfo4
-rw-r--r--math/hs-probability/Makefile2
-rw-r--r--math/hs-semigroupoid-extras/Makefile15
-rw-r--r--math/hs-semigroupoid-extras/distinfo2
-rw-r--r--math/hs-semigroupoid-extras/pkg-descr3
-rw-r--r--math/hs-semigroupoids/Makefile2
-rw-r--r--math/hs-semigroupoids/distinfo4
-rw-r--r--math/hs-semigroups/Makefile4
-rw-r--r--math/hs-semigroups/distinfo4
-rw-r--r--math/hs-statistics/Makefile1
-rw-r--r--math/hs-vector-space/Makefile1
43 files changed, 155 insertions, 33 deletions
diff --git a/math/Makefile b/math/Makefile
index 52f73dda5457..d06ed902271e 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -159,16 +159,20 @@
SUBDIR += hs-categories
SUBDIR += hs-comonad
SUBDIR += hs-comonad-transformers
+ SUBDIR += hs-comonads-fd
SUBDIR += hs-contravariant
SUBDIR += hs-data-lens
SUBDIR += hs-data-lens-template
SUBDIR += hs-distributive
SUBDIR += hs-erf
+ SUBDIR += hs-groupoids
SUBDIR += hs-ieee754
SUBDIR += hs-math-functions
SUBDIR += hs-mwc-random
+ SUBDIR += hs-nats
SUBDIR += hs-pointed
SUBDIR += hs-probability
+ SUBDIR += hs-semigroupoid-extras
SUBDIR += hs-semigroupoids
SUBDIR += hs-semigroups
SUBDIR += hs-statistics
diff --git a/math/hs-Agda-executable/Makefile b/math/hs-Agda-executable/Makefile
index 7d28ef0dbba0..44e6d041df17 100644
--- a/math/hs-Agda-executable/Makefile
+++ b/math/hs-Agda-executable/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Agda-executable
PORTVERSION= 2.3.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-Agda/Makefile b/math/hs-Agda/Makefile
index 6aaa8cf9d2c7..a323aeef942a 100644
--- a/math/hs-Agda/Makefile
+++ b/math/hs-Agda/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Agda
PORTVERSION= 2.3.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
@@ -11,7 +11,7 @@ COMMENT= A dependently typed functional programming language and proof assistant
CABAL_SETUP= Setup.hs
-USE_CABAL= hashable hashtables haskeline>=0.6.3.2 \
+USE_CABAL= hashable>=1.2 hashtables haskeline>=0.6.3.2 \
haskell-src-exts>=1.9.6 mtl QuickCheck>=2.3 syb>=0.1 \
xhtml zlib>=0.4.0.1
USE_ALEX= yes
diff --git a/math/hs-Agda/files/patch-Agda.cabal b/math/hs-Agda/files/patch-Agda.cabal
index d451dea27c94..ad9b3b70f9a2 100644
--- a/math/hs-Agda/files/patch-Agda.cabal
+++ b/math/hs-Agda/files/patch-Agda.cabal
@@ -1,5 +1,5 @@
--- ./Agda.cabal.orig 2012-03-12 11:09:34.000000000 +0100
-+++ ./Agda.cabal 2012-10-03 22:53:16.000000000 +0200
++++ ./Agda.cabal 2013-02-05 04:15:30.000000000 +0100
@@ -71,13 +71,13 @@
if flag(use-locale)
build-depends: base >= 4.2 && < 4.6
@@ -18,6 +18,15 @@
containers >= 0.1 && < 0.5,
pretty >= 1.0 && < 1.2,
directory >= 1.0 && < 1.2,
+@@ -90,7 +90,7 @@
+ process >= 1.0.1.0 && < 1.2,
+ haskeline >= 0.6.3.2 && < 0.7,
+ xhtml == 3000.2.*,
+- hashable == 1.1.*,
++ hashable == 1.2.*,
+ hashtables == 1.0.*,
+ syb >= 0.1 && < 0.4
+ build-tools: happy >= 1.15 && < 2,
@@ -334,7 +334,7 @@
if flag(use-locale)
build-depends: base >= 4.2 && < 4.6
diff --git a/math/hs-Agda/files/patch-src__full__Agda__TypeChecking__Serialise.hs b/math/hs-Agda/files/patch-src__full__Agda__TypeChecking__Serialise.hs
new file mode 100644
index 000000000000..ef6fa31298eb
--- /dev/null
+++ b/math/hs-Agda/files/patch-src__full__Agda__TypeChecking__Serialise.hs
@@ -0,0 +1,11 @@
+--- ./src/full/Agda/TypeChecking/Serialise.hs.orig 2012-03-12 11:09:33.000000000 +0100
++++ ./src/full/Agda/TypeChecking/Serialise.hs 2013-02-05 04:30:03.000000000 +0100
+@@ -119,7 +119,7 @@
+ -- | With direct access to the internals of 'TypeRep' this instance
+ -- could presumably be improved.
+ instance Hashable TypeRep' where
+- hash = hash . show . unTypeRep'
++ hashWithSalt n = hashWithSalt n . show . unTypeRep'
+
+ data St = St
+ { nodeE :: !(Array Int32 Node)
diff --git a/math/hs-NumInstances/Makefile b/math/hs-NumInstances/Makefile
index 1e37581f5b63..d1e974d076eb 100644
--- a/math/hs-NumInstances/Makefile
+++ b/math/hs-NumInstances/Makefile
@@ -2,7 +2,7 @@
PORTNAME= NumInstances
PORTVERSION= 1.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-categories/Makefile b/math/hs-categories/Makefile
index 3e9e07c0aba4..864f62e836a4 100644
--- a/math/hs-categories/Makefile
+++ b/math/hs-categories/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= categories
-PORTVERSION= 1.0.4
+PORTVERSION= 1.0.5
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-categories/distinfo b/math/hs-categories/distinfo
index 5307bec2f48e..5204cd51b157 100644
--- a/math/hs-categories/distinfo
+++ b/math/hs-categories/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/categories-1.0.4.tar.gz) = fd18fa344f79c5659b593738484c4305421e356d9fe27d43d1a0abc16ddcbec6
-SIZE (cabal/categories-1.0.4.tar.gz) = 7916
+SHA256 (cabal/categories-1.0.5.tar.gz) = 7fce017b35ae7e273250a93070e053396c763995d148c16cdcc0110a16ed739b
+SIZE (cabal/categories-1.0.5.tar.gz) = 8992
diff --git a/math/hs-comonad-transformers/Makefile b/math/hs-comonad-transformers/Makefile
index c3172f0eb326..753c865fb419 100644
--- a/math/hs-comonad-transformers/Makefile
+++ b/math/hs-comonad-transformers/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= comonad-transformers
-PORTVERSION= 3.0
+PORTVERSION= 3.0.1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-comonad-transformers/distinfo b/math/hs-comonad-transformers/distinfo
index 8adf3da15462..b173e983d25a 100644
--- a/math/hs-comonad-transformers/distinfo
+++ b/math/hs-comonad-transformers/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/comonad-transformers-3.0.tar.gz) = 447ced0e4ccf9e7b008b9f487d82095f13cf6548d7c01c4363b8fe9683e951ae
-SIZE (cabal/comonad-transformers-3.0.tar.gz) = 6319
+SHA256 (cabal/comonad-transformers-3.0.1.tar.gz) = b2246025fc1f62b4950d241efd418066d23d106e0bdbafbfa3c03ffd03f8acd2
+SIZE (cabal/comonad-transformers-3.0.1.tar.gz) = 7391
diff --git a/math/hs-comonad/Makefile b/math/hs-comonad/Makefile
index 992378a57508..dc29fc0526a5 100644
--- a/math/hs-comonad/Makefile
+++ b/math/hs-comonad/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= comonad
-PORTVERSION= 3.0.0.2
+PORTVERSION= 3.0.1.1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-comonad/distinfo b/math/hs-comonad/distinfo
index 9eafde869ed7..02bf21e22a82 100644
--- a/math/hs-comonad/distinfo
+++ b/math/hs-comonad/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/comonad-3.0.0.2.tar.gz) = 113aca5618a478d25ce2f71718e5226f41bd0a953d4b1c906cab5543c80a0707
-SIZE (cabal/comonad-3.0.0.2.tar.gz) = 4287
+SHA256 (cabal/comonad-3.0.1.1.tar.gz) = 82418cd6783a166e6b9c17040ea1be6b3d0a17b3f55b9f8db3a61bdf71eef807
+SIZE (cabal/comonad-3.0.1.1.tar.gz) = 4302
diff --git a/math/hs-comonads-fd/Makefile b/math/hs-comonads-fd/Makefile
new file mode 100644
index 000000000000..060347d9369d
--- /dev/null
+++ b/math/hs-comonads-fd/Makefile
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+PORTNAME= comonads-fd
+PORTVERSION= 3.0.1
+CATEGORIES= math haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Comonad transformers using functional dependencies
+
+LICENSE= BSD
+
+USE_CABAL= comonad>=3.0 comonad-transformers>=3.0 mtl>=2.0 \
+ semigroups>=0.8.3.1 transformers>=0.2
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/math/hs-comonads-fd/distinfo b/math/hs-comonads-fd/distinfo
new file mode 100644
index 000000000000..87725c14fc40
--- /dev/null
+++ b/math/hs-comonads-fd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/comonads-fd-3.0.1.tar.gz) = deb75179224f69d6987f5c7d4186b151afa2125d35243088fa0b8c000fd7e92a
+SIZE (cabal/comonads-fd-3.0.1.tar.gz) = 3494
diff --git a/math/hs-comonads-fd/pkg-descr b/math/hs-comonads-fd/pkg-descr
new file mode 100644
index 000000000000..2854ac4d1d2d
--- /dev/null
+++ b/math/hs-comonads-fd/pkg-descr
@@ -0,0 +1,3 @@
+Comonad transformers using functional dependencies.
+
+WWW: http://github.com/ekmett/comonads-fd/
diff --git a/math/hs-contravariant/Makefile b/math/hs-contravariant/Makefile
index c0dfb0b8ed67..5883a9326a0d 100644
--- a/math/hs-contravariant/Makefile
+++ b/math/hs-contravariant/Makefile
@@ -2,7 +2,7 @@
PORTNAME= contravariant
PORTVERSION= 0.2.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-data-lens-template/Makefile b/math/hs-data-lens-template/Makefile
index 1eef8f7d54ef..0d2fbd8c766e 100644
--- a/math/hs-data-lens-template/Makefile
+++ b/math/hs-data-lens-template/Makefile
@@ -2,6 +2,7 @@
PORTNAME= data-lens-template
PORTVERSION= 2.1.7
+PORTREVISION= 1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-data-lens/Makefile b/math/hs-data-lens/Makefile
index 3665a7f5687d..6c74b09e98a0 100644
--- a/math/hs-data-lens/Makefile
+++ b/math/hs-data-lens/Makefile
@@ -2,6 +2,7 @@
PORTNAME= data-lens
PORTVERSION= 2.10.2
+PORTREVISION= 1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-distributive/Makefile b/math/hs-distributive/Makefile
index 148ff33c9e89..de6f5ef4f374 100644
--- a/math/hs-distributive/Makefile
+++ b/math/hs-distributive/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= distributive
-PORTVERSION= 0.2.2
-PORTREVISION= 2
+PORTVERSION= 0.3
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,7 +9,7 @@ COMMENT= Haskell 98 distributive functors -- Dual to Traversable
LICENSE= BSD
-USE_CABAL= transformers>=0.2
+USE_CABAL= transformers>=0.3
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/math/hs-distributive/distinfo b/math/hs-distributive/distinfo
index c1be3f8dfc35..05e44530a908 100644
--- a/math/hs-distributive/distinfo
+++ b/math/hs-distributive/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/distributive-0.2.2.tar.gz) = 22c33561e42f105649f44ce051b17c913cb340c792b7d170c856c0b1b8c89b8f
-SIZE (cabal/distributive-0.2.2.tar.gz) = 2445
+SHA256 (cabal/distributive-0.3.tar.gz) = 4e8c782dea78698d7de89e20ddaa4c907ec0e3ba41267d53bf3b242ba6e2db7c
+SIZE (cabal/distributive-0.3.tar.gz) = 5899
diff --git a/math/hs-distributive/files/patch-distributive.cabal b/math/hs-distributive/files/patch-distributive.cabal
new file mode 100644
index 000000000000..6e956aa320cb
--- /dev/null
+++ b/math/hs-distributive/files/patch-distributive.cabal
@@ -0,0 +1,12 @@
+--- ./distributive.cabal.orig 2013-01-06 18:34:35.000000000 +0100
++++ ./distributive.cabal 2013-01-14 20:36:11.000000000 +0100
+@@ -33,8 +33,7 @@
+ library
+ build-depends:
+ base >= 4 && < 5,
+- transformers >= 0.2 && < 0.4,
+- transformers-compat >= 0.1 && < 0.2
++ transformers >= 0.3 && < 0.4
+
+ hs-source-dirs: src
+ exposed-modules: Data.Distributive
diff --git a/math/hs-erf/Makefile b/math/hs-erf/Makefile
index d42e2d6bba0f..f6e4be182050 100644
--- a/math/hs-erf/Makefile
+++ b/math/hs-erf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= erf
PORTVERSION= 2.0.0.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-groupoids/Makefile b/math/hs-groupoids/Makefile
new file mode 100644
index 000000000000..cf2050cc57af
--- /dev/null
+++ b/math/hs-groupoids/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+
+PORTNAME= groupoids
+PORTVERSION= 3.0.1.1
+CATEGORIES= math haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Haskell 98 Groupoids
+
+LICENSE= BSD
+
+USE_CABAL= semigroupoids>=3
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/math/hs-groupoids/distinfo b/math/hs-groupoids/distinfo
new file mode 100644
index 000000000000..6ed86ea9df96
--- /dev/null
+++ b/math/hs-groupoids/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/groupoids-3.0.1.1.tar.gz) = c35c27bdee4f43f86e649356a41635911e8c66c9701da19515a5b178b0979d64
+SIZE (cabal/groupoids-3.0.1.1.tar.gz) = 2935
diff --git a/math/hs-groupoids/pkg-descr b/math/hs-groupoids/pkg-descr
new file mode 100644
index 000000000000..20697c4e0785
--- /dev/null
+++ b/math/hs-groupoids/pkg-descr
@@ -0,0 +1,3 @@
+Haskell 98 Groupoids.
+
+WWW: http://github.com/ekmett/groupoids/
diff --git a/math/hs-ieee754/Makefile b/math/hs-ieee754/Makefile
index 55b863f8d55f..c91cc6288786 100644
--- a/math/hs-ieee754/Makefile
+++ b/math/hs-ieee754/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ieee754
PORTVERSION= 0.7.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-math-functions/Makefile b/math/hs-math-functions/Makefile
index 5b3e6f7ab231..9139b85d952a 100644
--- a/math/hs-math-functions/Makefile
+++ b/math/hs-math-functions/Makefile
@@ -3,6 +3,7 @@
PORTNAME= math-functions
PORTVERSION= 0.1.1.2
+PORTREVISION= 1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-mwc-random/Makefile b/math/hs-mwc-random/Makefile
index f98d85452521..7865c5c0dcbd 100644
--- a/math/hs-mwc-random/Makefile
+++ b/math/hs-mwc-random/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mwc-random
PORTVERSION= 0.12.0.1
+PORTREVISION= 1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-nats/Makefile b/math/hs-nats/Makefile
new file mode 100644
index 000000000000..81b7f08d7e63
--- /dev/null
+++ b/math/hs-nats/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+PORTNAME= nats
+PORTVERSION= 0.1
+CATEGORIES= math haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Haskell 98 natural numbers
+
+LICENSE= BSD
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/math/hs-nats/distinfo b/math/hs-nats/distinfo
new file mode 100644
index 000000000000..858b141455d4
--- /dev/null
+++ b/math/hs-nats/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/nats-0.1.tar.gz) = 7e87fa4ac81bc35a3f1dafca011c19b95f869ddd15e30a5348e0685ea53cf021
+SIZE (cabal/nats-0.1.tar.gz) = 3734
diff --git a/math/hs-nats/pkg-descr b/math/hs-nats/pkg-descr
new file mode 100644
index 000000000000..0fb820219cf3
--- /dev/null
+++ b/math/hs-nats/pkg-descr
@@ -0,0 +1,3 @@
+Haskell 98 natural numbers.
+
+WWW: http://github.com/ekmett/nats/
diff --git a/math/hs-pointed/Makefile b/math/hs-pointed/Makefile
index 4535847372cb..9b4b9f5ad349 100644
--- a/math/hs-pointed/Makefile
+++ b/math/hs-pointed/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= pointed
-PORTVERSION= 3.0.1
+PORTVERSION= 3.0.2
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
@@ -9,7 +9,7 @@ COMMENT= Haskell 98 pointed and copointed data
LICENSE= BSD
-USE_CABAL= comonad>=3.0 comonad-transformers>=3.0 data-default>=0.4 \
+USE_CABAL= comonad>=3 comonad-transformers>=3 data-default>=0.4 \
semigroupoids>=3.0 semigroups>=0.8.3.1 stm>=2.1.2.1 \
transformers>=0.2
diff --git a/math/hs-pointed/distinfo b/math/hs-pointed/distinfo
index 9c4505a73987..25262b978d4b 100644
--- a/math/hs-pointed/distinfo
+++ b/math/hs-pointed/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/pointed-3.0.1.tar.gz) = fbcde1ac290f111c39c150737d612bf6b2a2241a870672bc01e35140f8a9f9c6
-SIZE (cabal/pointed-3.0.1.tar.gz) = 2941
+SHA256 (cabal/pointed-3.0.2.tar.gz) = 10c6aae5d0d18ae10c7901a07b6dc53eb340eaa84eca2265f04aea3a4a27e8d8
+SIZE (cabal/pointed-3.0.2.tar.gz) = 3084
diff --git a/math/hs-probability/Makefile b/math/hs-probability/Makefile
index 51b1e03ddd5a..9a245b43106b 100644
--- a/math/hs-probability/Makefile
+++ b/math/hs-probability/Makefile
@@ -3,7 +3,7 @@
PORTNAME= probability
PORTVERSION= 0.2.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-semigroupoid-extras/Makefile b/math/hs-semigroupoid-extras/Makefile
new file mode 100644
index 000000000000..cf90c8c57d05
--- /dev/null
+++ b/math/hs-semigroupoid-extras/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+
+PORTNAME= semigroupoid-extras
+PORTVERSION= 3.0.1
+CATEGORIES= math haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Semigroupoids requiring Haskell extensions
+
+LICENSE= BSD
+
+USE_CABAL= comonad>=3 distributive>=0.2.2 groupoids>=3 semigroupoids>=3
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/math/hs-semigroupoid-extras/distinfo b/math/hs-semigroupoid-extras/distinfo
new file mode 100644
index 000000000000..f98545574921
--- /dev/null
+++ b/math/hs-semigroupoid-extras/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/semigroupoid-extras-3.0.1.tar.gz) = ed762d6c59ca75abc6fe0a7ed0119757588daca25d0ebc1681612be96bead1ac
+SIZE (cabal/semigroupoid-extras-3.0.1.tar.gz) = 5284
diff --git a/math/hs-semigroupoid-extras/pkg-descr b/math/hs-semigroupoid-extras/pkg-descr
new file mode 100644
index 000000000000..87c1c79973b3
--- /dev/null
+++ b/math/hs-semigroupoid-extras/pkg-descr
@@ -0,0 +1,3 @@
+Semigroupoids and semigroupoid operations requiring Haskell extensions.
+
+WWW: http://github.com/ekmett/semigroupoid-extras
diff --git a/math/hs-semigroupoids/Makefile b/math/hs-semigroupoids/Makefile
index 79b7b69a747c..d7af1561f6b7 100644
--- a/math/hs-semigroupoids/Makefile
+++ b/math/hs-semigroupoids/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= semigroupoids
-PORTVERSION= 3.0.0.1
+PORTVERSION= 3.0.2
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-semigroupoids/distinfo b/math/hs-semigroupoids/distinfo
index 4d32c8f8e662..40be9cf6c415 100644
--- a/math/hs-semigroupoids/distinfo
+++ b/math/hs-semigroupoids/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/semigroupoids-3.0.0.1.tar.gz) = d14017b00f96c632d1cdff41a117a289fd0b56af80678a66a8e9f2c8fdad9846
-SIZE (cabal/semigroupoids-3.0.0.1.tar.gz) = 11295
+SHA256 (cabal/semigroupoids-3.0.2.tar.gz) = 95bb528ddbf75fd357fbbada902060291400fa62a3734c7c7d5903ee543c234c
+SIZE (cabal/semigroupoids-3.0.2.tar.gz) = 12007
diff --git a/math/hs-semigroups/Makefile b/math/hs-semigroups/Makefile
index 38a9398a986e..2256a2dbd383 100644
--- a/math/hs-semigroups/Makefile
+++ b/math/hs-semigroups/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= semigroups
-PORTVERSION= 0.8.4.1
+PORTVERSION= 0.9
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
@@ -9,5 +9,7 @@ COMMENT= Haskell 98 semigroups
LICENSE= BSD
+USE_CABAL= nats>=0.1
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/math/hs-semigroups/distinfo b/math/hs-semigroups/distinfo
index e874457f890d..e596f3bf24f4 100644
--- a/math/hs-semigroups/distinfo
+++ b/math/hs-semigroups/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/semigroups-0.8.4.1.tar.gz) = d6640f352517b2aafbabed77745324336c0dc6a0df8ce462c8d88ef7aa2a9b17
-SIZE (cabal/semigroups-0.8.4.1.tar.gz) = 10240
+SHA256 (cabal/semigroups-0.9.tar.gz) = 2041f8e2abbf4098551e8980862e034dd586caba46b8f67deef7fd94a9949e33
+SIZE (cabal/semigroups-0.9.tar.gz) = 9450
diff --git a/math/hs-statistics/Makefile b/math/hs-statistics/Makefile
index 6df0e00460d0..895ac101efe8 100644
--- a/math/hs-statistics/Makefile
+++ b/math/hs-statistics/Makefile
@@ -3,6 +3,7 @@
PORTNAME= statistics
PORTVERSION= 0.10.2.0
+PORTREVISION= 1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/math/hs-vector-space/Makefile b/math/hs-vector-space/Makefile
index 9fb3ea902015..8ba80b0aff24 100644
--- a/math/hs-vector-space/Makefile
+++ b/math/hs-vector-space/Makefile
@@ -3,6 +3,7 @@
PORTNAME= vector-space
PORTVERSION= 0.8.6
+PORTREVISION= 1
CATEGORIES= math haskell
MAINTAINER= haskell@FreeBSD.org