aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2011-01-04 02:17:01 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2011-01-04 02:17:01 +0000
commitdd7417c07ed7c2d66005e2bb9dca99c800d89e57 (patch)
tree8cbe804cf288c3521e57ba0e29074a3c51a8fcc6 /math
parent7faad08001d3ab2c7be46a2581df821bce329776 (diff)
downloadports-dd7417c07ed7c2d66005e2bb9dca99c800d89e57.tar.gz
ports-dd7417c07ed7c2d66005e2bb9dca99c800d89e57.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/liblbfgs/Makefile10
-rw-r--r--math/liblbfgs/distinfo5
-rw-r--r--math/liblbfgs/files/patch-lib_arithmetic_sse_double.h19
3 files changed, 14 insertions, 20 deletions
diff --git a/math/liblbfgs/Makefile b/math/liblbfgs/Makefile
index 3c2311e3338a..f7c5aa25dce0 100644
--- a/math/liblbfgs/Makefile
+++ b/math/liblbfgs/Makefile
@@ -6,14 +6,16 @@
#
PORTNAME= liblbfgs
-PORTVERSION= 1.9
-PORTREVISION= 1
+PORTVERSION= 1.10
CATEGORIES= math
-MASTER_SITES= http://www.chokkan.org/software/dist/
+MASTER_SITES= http://cloud.github.com/downloads/chokkan/liblbfgs/
MAINTAINER= gaod@hychen.org
COMMENT= A library of Limited-memory Broyden-Fletcher-Goldfarb-Shanno
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:env
@@ -30,7 +32,7 @@ IGNORE= does not install properly on 6.x
CONFIGURE_ARGS+= --enable-sse2
.endif
-PLIST_FILES= lib/liblbfgs-1.9.so.0.0 lib/liblbfgs.a lib//liblbfgs.la \
+PLIST_FILES= lib/liblbfgs-1.10.so.0.0 lib/liblbfgs.a lib//liblbfgs.la \
lib/liblbfgs.so.0.0 include/lbfgs.h
PORTDOCS= README INSTALL COPYING AUTHORS ChangeLog NEWS
diff --git a/math/liblbfgs/distinfo b/math/liblbfgs/distinfo
index 74770012b406..6b53f9de8b2f 100644
--- a/math/liblbfgs/distinfo
+++ b/math/liblbfgs/distinfo
@@ -1,3 +1,2 @@
-MD5 (liblbfgs-1.9.tar.gz) = 311eb920dd3ed777c3fae14e4ae7c9a5
-SHA256 (liblbfgs-1.9.tar.gz) = 76e2decbb4d05349f83ed81d30318b3af8597c007f447a0f68ff6f9eb8a8b47c
-SIZE (liblbfgs-1.9.tar.gz) = 318447
+SHA256 (liblbfgs-1.10.tar.gz) = 4158ab7402b573e5c69d5f6b03c973047a91e16ca5737d3347e3af9c906868cf
+SIZE (liblbfgs-1.10.tar.gz) = 318739
diff --git a/math/liblbfgs/files/patch-lib_arithmetic_sse_double.h b/math/liblbfgs/files/patch-lib_arithmetic_sse_double.h
index bd4c23db1bc0..8eaa8e7d5754 100644
--- a/math/liblbfgs/files/patch-lib_arithmetic_sse_double.h
+++ b/math/liblbfgs/files/patch-lib_arithmetic_sse_double.h
@@ -1,19 +1,12 @@
---- lib/arithmetic_sse_double.h.orig 2010-06-08 08:17:38.000000000 +0800
-+++ lib/arithmetic_sse_double.h 2010-06-08 08:19:41.000000000 +0800
-@@ -26,7 +26,6 @@
- /* $Id: arithmetic_sse_double.h 65 2010-01-29 12:19:16Z naoaki $ */
+--- lib/arithmetic_sse_double.h.orig 2010-12-30 02:13:34.000000000 +0800
++++ lib/arithmetic_sse_double.h 2010-12-30 02:14:04.000000000 +0800
+@@ -26,9 +26,6 @@
+ /* $Id$ */
#include <stdlib.h>
+-#ifndef __APPLE__
-#include <malloc.h>
+-#endif
#include <memory.h>
#if 1400 <= _MSC_VER
-@@ -37,6 +36,8 @@
- #include <emmintrin.h>
- #endif/*HAVE_EMMINTRIN_H*/
-
-+#define memalign(A,B) malloc(B)
-+
- inline static void* vecalloc(size_t size)
- {
- #ifdef _MSC_VER