aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
commite1bfdfbe5665c963621e06f6bbfbbc2c000a804e (patch)
treeeaf052562fa1ad9b232918eb5e617ac1df0dd725 /math
parentf57bc4af665126de839ff734a08e57726e84da84 (diff)
Notes
Diffstat (limited to 'math')
-rw-r--r--math/analitza/Makefile2
-rw-r--r--math/blacs/Makefile2
-rw-r--r--math/blocksolve95/Makefile1
-rw-r--r--math/cantor/Makefile2
-rw-r--r--math/ccmath/Makefile2
-rw-r--r--math/clp/Makefile2
-rw-r--r--math/ggobi/Makefile2
-rw-r--r--math/gracetmpl/Makefile2
-rw-r--r--math/kalgebra/Makefile2
-rw-r--r--math/kbruch/Makefile2
-rw-r--r--math/kcalc/Makefile2
-rw-r--r--math/kig/Makefile2
-rw-r--r--math/kmplot/Makefile2
-rw-r--r--math/liborigin/Makefile4
-rw-r--r--math/librsb/Makefile2
-rw-r--r--math/mpfr/Makefile2
-rw-r--r--math/muparser/Makefile3
-rw-r--r--math/nfft/Makefile3
-rw-r--r--math/py-bitvector/Makefile2
-rw-r--r--math/reduce-psl/Makefile2
-rw-r--r--math/reduce/Makefile2
-rw-r--r--math/rocs/Makefile2
-rw-r--r--math/scalapack/Makefile2
23 files changed, 43 insertions, 6 deletions
diff --git a/math/analitza/Makefile b/math/analitza/Makefile
index 69761577d45b..159ac3011919 100644
--- a/math/analitza/Makefile
+++ b/math/analitza/Makefile
@@ -24,4 +24,6 @@ SHLIB_VER= 8.0.0
PLIST_SUB+= SHLIB_VER="${SHLIB_VER}" \
SHLIB_SHVER="${SHLIB_VER:R:R}"
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/math/blacs/Makefile b/math/blacs/Makefile
index 12a68f691bc3..276d44288f5e 100644
--- a/math/blacs/Makefile
+++ b/math/blacs/Makefile
@@ -18,6 +18,8 @@ SUB_FILES= pkg-message
USES= fortran gmake
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.if ! ${PORT_OPTIONS:MDOCS}
diff --git a/math/blocksolve95/Makefile b/math/blocksolve95/Makefile
index e71d6b1df7be..ec1d5a24222d 100644
--- a/math/blocksolve95/Makefile
+++ b/math/blocksolve95/Makefile
@@ -23,6 +23,7 @@ LIB_DEPENDS= libf2c.so:lang/f2c \
USES= fortran gmake tar:Z
+OPTIONS_DEFINE= DOCS
OPTIONS_RADIO= BLAS
OPTIONS_RADIO_BLAS= REFERENCE ATLAS
OPTIONS_DEFAULT= REFERENCE
diff --git a/math/cantor/Makefile b/math/cantor/Makefile
index 3944753544a0..971f4eb226ea 100644
--- a/math/cantor/Makefile
+++ b/math/cantor/Makefile
@@ -24,7 +24,7 @@ USE_QT= core dbus gui network printsupport widgets xml xmlpatterns \
buildtools_build qmake_build
USE_LDCONFIG= yes
-OPTIONS_DEFINE= LUAJIT MAXIMA OCTAVE R SAGE SCILAB
+OPTIONS_DEFINE= LUAJIT MAXIMA OCTAVE R SAGE SCILAB DOCS
OPTIONS_SUB= yes # R LUAJIT
LUAJIT_DESC= Build LuaJIT backend and install LuaJIT
diff --git a/math/ccmath/Makefile b/math/ccmath/Makefile
index e260ca32ad10..bc8596e475b4 100644
--- a/math/ccmath/Makefile
+++ b/math/ccmath/Makefile
@@ -20,6 +20,8 @@ PORTDOCS= *
SRC_DIRS= cfit complex fft geom intg matrix roots sfunc simu sort statf \
tseries util xarm
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
diff --git a/math/clp/Makefile b/math/clp/Makefile
index 8b4ed821b27d..4c1a014d72b8 100644
--- a/math/clp/Makefile
+++ b/math/clp/Makefile
@@ -27,7 +27,7 @@ CONFIGURE_ARGS= --with-lapack-lib="${LAPACKLIB} -L${LOCALBASE}/lib" \
--with-blas-lib="${BLASLIB} -L${LOCALBASE}/lib" \
--datadir=${DATADIR}
-OPTIONS_DEFINE= DEBUG
+OPTIONS_DEFINE= DEBUG DOCS
PORTDOCS= *
DEBUG_CXXFLAGS= -fomit-frame-pointer
diff --git a/math/ggobi/Makefile b/math/ggobi/Makefile
index aef1dc8779cd..fb3389e2a127 100644
--- a/math/ggobi/Makefile
+++ b/math/ggobi/Makefile
@@ -26,6 +26,8 @@ SUB_FILES= pkg-message
ALL_TARGET= all ggobirc
INSTALL_TARGET= install-strip
+OPTIONS_DEFINE= DOCS
+
post-build:
@${REINPLACE_CMD} -e 's|plugin.la|plugin.so|g' ${WRKSRC}/ggobirc
diff --git a/math/gracetmpl/Makefile b/math/gracetmpl/Makefile
index 9db940395e97..f89e4bc10bf8 100644
--- a/math/gracetmpl/Makefile
+++ b/math/gracetmpl/Makefile
@@ -34,6 +34,8 @@ USE_GCC= yes
PLIST_SUB+= PYTHON_VER=${PYTHON_VER}
+OPTIONS_DEFINE= DOCS
+
post-extract:
@${ECHO_CMD} -n > ${WRKSRC}/Makefile.defs
diff --git a/math/kalgebra/Makefile b/math/kalgebra/Makefile
index 37e1cac1a4a0..d0bd43f91037 100644
--- a/math/kalgebra/Makefile
+++ b/math/kalgebra/Makefile
@@ -20,4 +20,6 @@ USE_QT= core dbus gui location network opengl printsupport qml quick \
svg testlib webchannel webengine widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/math/kbruch/Makefile b/math/kbruch/Makefile
index 24018e8a090c..b07898091eb0 100644
--- a/math/kbruch/Makefile
+++ b/math/kbruch/Makefile
@@ -16,4 +16,6 @@ USE_KDE= auth config crash codecs configwidgets coreaddons doctools ecm \
USE_QT= core dbus gui xml widgets \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
index 1c788bb3f850..c3c3104aacab 100644
--- a/math/kcalc/Makefile
+++ b/math/kcalc/Makefile
@@ -18,4 +18,6 @@ USE_KDE= auth codecs coreaddons ecm config configwidgets doctools \
USE_QT= core dbus gui widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/math/kig/Makefile b/math/kig/Makefile
index f5eb67b521f2..9013792d1421 100644
--- a/math/kig/Makefile
+++ b/math/kig/Makefile
@@ -19,4 +19,6 @@ USE_QT= core dbus gui network printsupport svg widgets xml xmlpatterns \
buildtools_build qmake_build
SHEBANG_FILES= pykig/pykig.py
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/math/kmplot/Makefile b/math/kmplot/Makefile
index 073f191c8c3f..001cf56282b0 100644
--- a/math/kmplot/Makefile
+++ b/math/kmplot/Makefile
@@ -16,4 +16,6 @@ USE_KDE= auth bookmarks codecs completion config configwidgets \
USE_QT= core dbus gui network printsupport svg widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/math/liborigin/Makefile b/math/liborigin/Makefile
index f7d5eaee240c..e1756df6f17f 100644
--- a/math/liborigin/Makefile
+++ b/math/liborigin/Makefile
@@ -23,7 +23,9 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= *
-OPTIONS_DEFINE= DOXYGEN
+OPTIONS_DEFINE= DOXYGEN DOCS
+
+DOXYGEN_IMPLIES= DOCS
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
post-patch-DOXYGEN-off:
diff --git a/math/librsb/Makefile b/math/librsb/Makefile
index 1e307fb1d469..ce77473f1a6d 100644
--- a/math/librsb/Makefile
+++ b/math/librsb/Makefile
@@ -28,6 +28,8 @@ USE_LDCONFIG= yes
MANUAL_PACKAGE_BUILD= Optimizes for the local machine
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -E s/sed/gsed/g ${WRKSRC}/scripts/*.sh
diff --git a/math/mpfr/Makefile b/math/mpfr/Makefile
index 2820612631e2..541f64840454 100644
--- a/math/mpfr/Makefile
+++ b/math/mpfr/Makefile
@@ -35,4 +35,6 @@ INFO= mpfr
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/math/muparser/Makefile b/math/muparser/Makefile
index dbb0772fc80a..41600a1b57d0 100644
--- a/math/muparser/Makefile
+++ b/math/muparser/Makefile
@@ -23,13 +23,12 @@ GNU_CONFIGURE= yes
# otherwise it fails to build when the EXAMPLES option is ON
MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= DOXYGEN EXAMPLES
+OPTIONS_DEFINE= DOCS DOXYGEN EXAMPLES
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
dot:graphics/graphviz
DOXYGEN_ALL_TARGET= documentation
DOXYGEN_PORTDOCS= *
-# PORTDOCS macro won't work if NOPORTDOCS is defined or if DOCS is disabled
DOXYGEN_IMPLIES= DOCS
EXAMPLES_CONFIGURE_ENABLE= samples
diff --git a/math/nfft/Makefile b/math/nfft/Makefile
index 188a99c74c7c..ccecccb94e31 100644
--- a/math/nfft/Makefile
+++ b/math/nfft/Makefile
@@ -21,11 +21,12 @@ TEST_TARGET= check
USE_GITHUB= yes
GH_ACCOUNT= NFFT
-OPTIONS_DEFINE= DOXYGEN
+OPTIONS_DEFINE= DOCS DOXYGEN
OPTIONS_SUB= DOXYGEN
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
DOXYGEN_ALL_TARGET= all doc
+DOXYGEN_IMPLIES= DOCS
INSTALL_TARGET=install-strip
diff --git a/math/py-bitvector/Makefile b/math/py-bitvector/Makefile
index 2cdf7e586fab..3267dfbe16a9 100644
--- a/math/py-bitvector/Makefile
+++ b/math/py-bitvector/Makefile
@@ -19,6 +19,8 @@ PYDISTUTILS_PKGNAME= BitVector
PORTDOCS= README BitVector-${PORTVERSION}.html
+OPTIONS_DEFINE= DOCS
+
post-extract:
@${RM} ${WRKSRC}/test.py
diff --git a/math/reduce-psl/Makefile b/math/reduce-psl/Makefile
index e9c987d649d9..c414070a1f95 100644
--- a/math/reduce-psl/Makefile
+++ b/math/reduce-psl/Makefile
@@ -35,6 +35,8 @@ CONFIGURE_ARGS= --with-psl
REDUCE_BINS= ${WRKSRC}/pslbuild/${TARGET_SDIR}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/math/reduce/Makefile b/math/reduce/Makefile
index 957d1328243b..27de2a16d776 100644
--- a/math/reduce/Makefile
+++ b/math/reduce/Makefile
@@ -44,6 +44,8 @@ LDFLAGS+= `freetype-config --libs`
REDUCE_BINS= ${WRKSRC}/cslbuild/${TARGET_SDIR}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/math/rocs/Makefile b/math/rocs/Makefile
index 2b15e50b0e07..d13c3af89bd5 100644
--- a/math/rocs/Makefile
+++ b/math/rocs/Makefile
@@ -25,4 +25,6 @@ USE_LDCONFIG= yes
# _graphScene->views().at(0)->setRenderHints(QPainter::Antialiasing
USE_CXXSTD= gnu++98
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/math/scalapack/Makefile b/math/scalapack/Makefile
index 9a5418791f40..c6a6cca61644 100644
--- a/math/scalapack/Makefile
+++ b/math/scalapack/Makefile
@@ -32,6 +32,8 @@ EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME:tu}
SUB_FILES= pkg-message
PLIST_SUB= SVERSION=${SVERSION} PORTVERSION=${PORTVERSION}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MDOCS}