aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-08-01 05:24:51 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-08-01 05:24:51 +0000
commitf32b4a646d57ce481b4dd7fe5833576a69aa79d5 (patch)
tree6c82ba3db072751cdb149734b14210803e71bfa2 /math
parent5accad06a79f54cba34f76f2319d8456664b9780 (diff)
downloadports-f32b4a646d57ce481b4dd7fe5833576a69aa79d5.tar.gz
ports-f32b4a646d57ce481b4dd7fe5833576a69aa79d5.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile2
-rw-r--r--math/hexcalc/Makefile27
-rw-r--r--math/hexcalc/distinfo2
-rw-r--r--math/hexcalc/files/patch-hexcalc.c51
-rw-r--r--math/hexcalc/pkg-descr2
-rw-r--r--math/qgfe/Makefile37
-rw-r--r--math/qgfe/distinfo2
-rw-r--r--math/qgfe/pkg-descr4
8 files changed, 0 insertions, 127 deletions
diff --git a/math/Makefile b/math/Makefile
index 067eb35be05e..ba6646cf777e 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -121,7 +121,6 @@
SUBDIR += grpn
SUBDIR += gsl
SUBDIR += guppi
- SUBDIR += hexcalc
SUBDIR += hs-Agda
SUBDIR += hs-Agda-executable
SUBDIR += hs-category-extras
@@ -488,7 +487,6 @@
SUBDIR += py-sympy
SUBDIR += qalculate
SUBDIR += qd
- SUBDIR += qgfe
SUBDIR += qhull
SUBDIR += qrupdate
SUBDIR += qtiplot
diff --git a/math/hexcalc/Makefile b/math/hexcalc/Makefile
deleted file mode 100644
index 23bf79635544..000000000000
--- a/math/hexcalc/Makefile
+++ /dev/null
@@ -1,27 +0,0 @@
-# New ports collection makefile for: hexcalc
-# Date created: 5 December 1994
-# Whom: asami
-#
-# $FreeBSD$
-#
-
-PORTNAME= hexcalc
-PORTVERSION= 1.11
-PORTREVISION= 3
-CATEGORIES= math
-MASTER_SITES= ftp://aixpdslib.seas.ucla.edu/pub/hexcalc/RISC/3.2/src/
-DISTNAME= ${PORTNAME}
-EXTRACT_SUFX= ..tar.Z
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A multi-radix calculator for x11
-
-DEPRECATED= Look like an abandonware, no more public distifles
-EXPIRATION_DATE= 2011-08-01
-
-USE_IMAKE= yes
-USE_XORG= ice sm x11 xaw xext xmu xt
-MAN1= hexcalc.1
-PLIST_FILES= bin/hexcalc
-
-.include <bsd.port.mk>
diff --git a/math/hexcalc/distinfo b/math/hexcalc/distinfo
deleted file mode 100644
index 6eb4ee032385..000000000000
--- a/math/hexcalc/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (hexcalc..tar.Z) = cd9aed4c21b1dc4ea217fa78ec8558320ae93e944179055e5d184050b189631f
-SIZE (hexcalc..tar.Z) = 25129
diff --git a/math/hexcalc/files/patch-hexcalc.c b/math/hexcalc/files/patch-hexcalc.c
deleted file mode 100644
index c071859b659f..000000000000
--- a/math/hexcalc/files/patch-hexcalc.c
+++ /dev/null
@@ -1,51 +0,0 @@
---- hexcalc.c.orig 2011-05-13 08:28:24.000000000 +0800
-+++ hexcalc.c 2011-05-13 08:32:09.000000000 +0800
-@@ -37,6 +37,7 @@
- #endif
-
- #include <stdio.h>
-+#include <stdlib.h>
- #include <ctype.h>
- #include <X11/IntrinsicP.h>
- #include <X11/StringDefs.h>
-@@ -509,14 +510,16 @@
-
- switch(topOp) {
- case '+' :
-- ac = PopArg() + PopArg();
-+ temp = PopArg();
-+ ac = PopArg() + temp;
- break;
- case '-' :
- temp = PopArg();
- ac = PopArg() - temp;
- break;
- case '*' :
-- ac = PopArg() * PopArg();
-+ temp = PopArg();
-+ ac = temp * PopArg();
- break;
- case '/' :
- temp = PopArg();
-@@ -528,15 +531,18 @@
- break;
-
- case '|' :
-- ac = PopArg() | PopArg();
-+ temp = PopArg();
-+ ac = temp | PopArg();
- break;
-
- case '&' :
-- ac = PopArg() & PopArg();
-+ temp = PopArg();
-+ ac = temp & PopArg();
- break;
-
- case '^' :
-- ac = PopArg() ^ PopArg();
-+ temp = PopArg();
-+ ac = temp ^ PopArg();
- break;
-
- case '<' :
diff --git a/math/hexcalc/pkg-descr b/math/hexcalc/pkg-descr
deleted file mode 100644
index 0404ad27e89e..000000000000
--- a/math/hexcalc/pkg-descr
+++ /dev/null
@@ -1,2 +0,0 @@
-hexcalc is a multi-radix calucaltor for integers. It understands
-decimal, hexadecimal, octal and binary numbers.
diff --git a/math/qgfe/Makefile b/math/qgfe/Makefile
deleted file mode 100644
index 54a621b5f084..000000000000
--- a/math/qgfe/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: qgfe
-# Date created: Aug 30, 2004
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= qgfe
-PORTVERSION= 1.0
-PORTREVISION= 5
-CATEGORIES= math
-MASTER_SITES= http://www.xm1math.net/qgfe/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Gnuplot Front End
-
-DEPRECATED= Look like an abandonware, no more public distifles
-EXPIRATION_DATE= 2011-08-01
-
-BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
-RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
-
-USE_BZIP2= yes
-USE_QT_VER= 3
-MAKE_ENV= QTDIR=${QT_PREFIX} \
- MOC=${MOC}
-
-PLIST_FILES= bin/qgfe
-
-pre-build:
- @cd ${WRKSRC}; qmake -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ ${PORTNAME}.pro
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/qgfe ${PREFIX}/bin
-
-.include <bsd.port.mk>
diff --git a/math/qgfe/distinfo b/math/qgfe/distinfo
deleted file mode 100644
index 80c7ada02653..000000000000
--- a/math/qgfe/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (qgfe-1.0.tar.bz2) = 19cacd8f196241ba11fcfe851c3f33b4b6d670d2cb3e275340523bfc52083798
-SIZE (qgfe-1.0.tar.bz2) = 69711
diff --git a/math/qgfe/pkg-descr b/math/qgfe/pkg-descr
deleted file mode 100644
index 29788a4ff79f..000000000000
--- a/math/qgfe/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Qgfe is a graphical interface to the powerful gnuplot program for Unix systems.
-A good knowledge of Gnuplot is required to use Qgfe.
-
-WWW: http://www.xm1math.net/qgfe/