aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorJohannes M Dieterich <jmd@FreeBSD.org>2018-01-17 13:15:36 +0000
committerJohannes M Dieterich <jmd@FreeBSD.org>2018-01-17 13:15:36 +0000
commitf35f3fe7fa61ce4825b5ffbd22944b267cd9af8f (patch)
tree8a8609966181b9b0fd7485114e8f27361d04f92d /math
parente59464588b842d90bdb9e8fabc7c186bda6ec301 (diff)
downloadports-f35f3fe7fa61ce4825b5ffbd22944b267cd9af8f.tar.gz
ports-f35f3fe7fa61ce4825b5ffbd22944b267cd9af8f.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/tblis/Makefile35
-rw-r--r--math/tblis/distinfo3
-rw-r--r--math/tblis/pkg-descr12
-rw-r--r--math/tblis/pkg-plist60
5 files changed, 111 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 03ca52ff1a62..840e0e3df5d9 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -737,6 +737,7 @@
SUBDIR += symmetrica
SUBDIR += tablix
SUBDIR += taucs
+ SUBDIR += tblis
SUBDIR += testu01
SUBDIR += tetgen
SUBDIR += timbl
diff --git a/math/tblis/Makefile b/math/tblis/Makefile
new file mode 100644
index 000000000000..322042dff34a
--- /dev/null
+++ b/math/tblis/Makefile
@@ -0,0 +1,35 @@
+# Created by: Johannes M Dieterich <jmd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= tblis
+PORTVERSION= 1.1.2
+DISTVERSIONPREFIX= v
+CATEGORIES= math
+
+MAINTAINER= jmd@FreeBSD.org
+COMMENT= Framework for performing tensor operations
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NOT_FOR_ARCHS= i386
+NOT_FOR_ARCHS_REASON= i386 requires SSE
+
+OPTIONS_DEFINE= PARA
+PARA_DESC= use pthread parallelization
+OPTIONS_DEFAULT= PARA
+
+USE_GITHUB= yes
+GH_ACCOUNT= devinamatthews
+
+USES= gmake libtool
+USE_LDCONFIG= yes
+
+HAS_CONFIGURE= yes
+
+PARA_CONFIGURE_ON= --enable-thread-model=pthreads
+PARA_CONFIGURE_OFF= --enable-thread-model=none
+
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>
diff --git a/math/tblis/distinfo b/math/tblis/distinfo
new file mode 100644
index 000000000000..ec30d6a4236a
--- /dev/null
+++ b/math/tblis/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1508787490
+SHA256 (devinamatthews-tblis-v1.1.2_GH0.tar.gz) = ab2a77b254f5a2e1565da11236b3b7df7ab4b9badfdd0fe94889b625fe1adfeb
+SIZE (devinamatthews-tblis-v1.1.2_GH0.tar.gz) = 4515899
diff --git a/math/tblis/pkg-descr b/math/tblis/pkg-descr
new file mode 100644
index 000000000000..11a37bcc3614
--- /dev/null
+++ b/math/tblis/pkg-descr
@@ -0,0 +1,12 @@
+TBLIS is a library and framework for performing tensor operations,
+especially tensor contraction, using native algorithms. In this
+context, native means that TBLIS does not translate tensor
+operations into matrix operations using the BLAS libraries.
+Instead, TBLIS uses the philosophy (and certain low-level kernels)
+of the BLIS framework to implement tensor contraction with
+essentially zero overhead compared to matrix multiplication. TBLIS
+also aims to offer a convenient C++ interface for tensors and
+tensor operations, as well as a stable C interface with high
+portability.
+
+WWW: https://github.com/devinamatthews/tblis
diff --git a/math/tblis/pkg-plist b/math/tblis/pkg-plist
new file mode 100644
index 000000000000..41e02888d05a
--- /dev/null
+++ b/math/tblis/pkg-plist
@@ -0,0 +1,60 @@
+include/tblis/external/marray/include/marray.hpp
+include/tblis/external/marray/include/miterator.hpp
+include/tblis/external/marray/include/utility.hpp
+include/tblis/external/marray/include/varray.hpp
+include/tblis/external/marray/include/viterator.hpp
+include/tblis/external/stl_ext/include/algorithm.hpp
+include/tblis/external/stl_ext/include/any.hpp
+include/tblis/external/stl_ext/include/bounded_vector.hpp
+include/tblis/external/stl_ext/include/complex.hpp
+include/tblis/external/stl_ext/include/cosort.hpp
+include/tblis/external/stl_ext/include/fill_iterator.hpp
+include/tblis/external/stl_ext/include/global_ptr.hpp
+include/tblis/external/stl_ext/include/iostream.hpp
+include/tblis/external/stl_ext/include/ptr_list.hpp
+include/tblis/external/stl_ext/include/ptr_vector.hpp
+include/tblis/external/stl_ext/include/string.hpp
+include/tblis/external/stl_ext/include/type_traits.hpp
+include/tblis/external/stl_ext/include/vector.hpp
+include/tblis/external/stl_ext/include/zip.hpp
+include/tblis/iface/1m/add.h
+include/tblis/iface/1m/dot.h
+include/tblis/iface/1m/reduce.h
+include/tblis/iface/1m/scale.h
+include/tblis/iface/1m/set.h
+include/tblis/iface/1t/add.h
+include/tblis/iface/1t/dot.h
+include/tblis/iface/1t/reduce.h
+include/tblis/iface/1t/scale.h
+include/tblis/iface/1t/set.h
+include/tblis/iface/1v/add.h
+include/tblis/iface/1v/dot.h
+include/tblis/iface/1v/reduce.h
+include/tblis/iface/1v/scale.h
+include/tblis/iface/1v/set.h
+include/tblis/iface/3m/mult.h
+include/tblis/iface/3t/mult.h
+include/tblis/memory/aligned_allocator.hpp
+include/tblis/memory/stack_allocator.hpp
+include/tblis/tblis.h
+include/tblis/tblis_config.h
+include/tblis/util/assert.h
+include/tblis/util/basic_types.h
+include/tblis/util/thread.h
+include/tci.h
+include/tci/barrier.h
+include/tci/communicator.h
+include/tci/context.h
+include/tci/mutex.h
+include/tci/parallel.h
+include/tci/tci_config.h
+include/tci/work_item.h
+include/tci/yield.h
+lib/libtblis.a
+lib/libtblis.so
+lib/libtblis.so.0
+lib/libtblis.so.0.0.0
+lib/libtci.a
+lib/libtci.so
+lib/libtci.so.0
+lib/libtci.so.0.0.0