aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-02-19 11:10:43 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-02-19 11:10:43 +0000
commitf7455240e3b2acb3cd4804dac9a3afe2582a0a96 (patch)
tree94eaef37ab07d82e499ae4cafabe202ea2ed0525 /math
parent6db4531ff6ac4b156bdc1499488964f1c2551e7f (diff)
downloadports-f7455240e3b2acb3cd4804dac9a3afe2582a0a96.tar.gz
ports-f7455240e3b2acb3cd4804dac9a3afe2582a0a96.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/biggles/Makefile4
-rw-r--r--math/cadabra2/Makefile4
-rw-r--r--math/cantor/Makefile4
-rw-r--r--math/gnumeric/Makefile3
-rw-r--r--math/hfst/Makefile3
-rw-r--r--math/nlopt/Makefile4
-rw-r--r--math/openfst/Makefile3
-rw-r--r--math/py-bitmath/Makefile3
-rw-r--r--math/py-ffc/Makefile3
-rw-r--r--math/py-fiat/Makefile4
-rw-r--r--math/py-fpconst/Makefile3
-rw-r--r--math/py-gato/Makefile3
-rw-r--r--math/py-gmpy2/Makefile3
-rw-r--r--math/py-symeig/Makefile4
-rw-r--r--math/py-ufl/Makefile3
-rw-r--r--math/py-viper/Makefile3
-rw-r--r--math/saga/Makefile4
-rw-r--r--math/ufc/Makefile4
18 files changed, 36 insertions, 26 deletions
diff --git a/math/biggles/Makefile b/math/biggles/Makefile
index 691fadbe169f..66a81fe7c4b7 100644
--- a/math/biggles/Makefile
+++ b/math/biggles/Makefile
@@ -3,7 +3,7 @@
PORTNAME= biggles
PORTVERSION= 1.6.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math
MASTER_SITES= SF
DISTNAME= python2-${PORTNAME}-${PORTVERSION}
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libplot.so:graphics/plotutils
-USES= gmake python:2
+USES= gmake python:2.7
MAKE_ARGS= CC="${CC}" \
CFLAGS="${CFLAGS} -fPIC" \
LIBPLOT_CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/math/cadabra2/Makefile b/math/cadabra2/Makefile
index b244867e8860..495d5fc45ab1 100644
--- a/math/cadabra2/Makefile
+++ b/math/cadabra2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cadabra2
DISTVERSION= 2.1.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -26,7 +26,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/sympy/__init__.py:math/py-sympy@${PY_FLAVOR} \
OPTIONS_DEFINE= GUI
OPTIONS_DEFAULT=GUI
-USES= compiler:c++14-lang cmake gettext-runtime pkgconfig python:2 sqlite
+USES= compiler:c++14-lang cmake gettext-runtime pkgconfig python:2.7 sqlite
USE_GITHUB= yes
GH_ACCOUNT= kpeeters
GUI_USE= GNOME=gtkmm30,gdkpixbuf2
diff --git a/math/cantor/Makefile b/math/cantor/Makefile
index 6f1c4a5e0e53..74bb82e81f2f 100644
--- a/math/cantor/Makefile
+++ b/math/cantor/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cantor
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= math kde kde-kde4
MAINTAINER= kde@FreeBSD.org
@@ -12,7 +12,7 @@ LIB_DEPENDS= libspectre.so:print/libspectre \
libqalculate.so:math/libqalculate \
libanalitza.so:math/analitza
-USES= cmake:outsource kde:4 pkgconfig python:2 tar:xz
+USES= cmake:outsource kde:4 pkgconfig python:2.7 tar:xz
USE_KDE= kdelibs automoc4
USE_QT4= corelib qtestlib_build xml xmlpatterns \
moc_build qmake_build rcc_build uic_build
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index 5878076206d1..e2236e12edf4 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gnumeric
PORTVERSION= 1.12.28
+PORTREVISION= 1
CATEGORIES= math gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -19,7 +20,7 @@ LIB_DEPENDS= libgoffice-0.10.so:devel/goffice010 \
RUN_DEPENDS= rarian-sk-config:textproc/rarian
USES= cpe desktop-file-utils gettext gmake libtool pathfix pkgconfig \
- python:2 shebangfix tar:xz
+ python:2.7 shebangfix tar:xz
USE_GNOME= intlhack libgsf pygobject3
INSTALLS_OMF= yes
USE_LDCONFIG= yes
diff --git a/math/hfst/Makefile b/math/hfst/Makefile
index 62b3f180ba64..e94bb4ab024a 100644
--- a/math/hfst/Makefile
+++ b/math/hfst/Makefile
@@ -3,6 +3,7 @@
PORTNAME= hfst
PORTVERSION= 3.13.0
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= demon@FreeBSD.org
@@ -13,7 +14,7 @@ BROKEN= fails to build
USE_GITHUB= yes
GH_TAGNAME= c187d5a
-USES= autoreconf libtool pathfix pkgconfig python:2 readline shebangfix
+USES= autoreconf libtool pathfix pkgconfig python:2.7 readline shebangfix
USE_GCC= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-readline --enable-lexc-wrapper --enable-proc --enable-tagger --enable-train-tagger --enable-xfst --enable-shuffle --enable-traverse
diff --git a/math/nlopt/Makefile b/math/nlopt/Makefile
index 4f15bb64682b..7bc82a8e1f51 100644
--- a/math/nlopt/Makefile
+++ b/math/nlopt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nlopt
PORTVERSION= 2.4.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://ab-initio.mit.edu/nlopt/
@@ -25,7 +25,7 @@ CONFIGURE_ARGS= --enable-shared
CONFIGURE_ENV= SWIG="${LOCALBASE}/bin/swig3.0"
USES= autoreconf compiler:features libtool pathfix \
- pkgconfig python:2
+ pkgconfig python:2.7
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/math/openfst/Makefile b/math/openfst/Makefile
index e4b2326cd0d2..c42dee8c9fb4 100644
--- a/math/openfst/Makefile
+++ b/math/openfst/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openfst
PORTVERSION= 1.6.3
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://www.openfst.org/twiki/pub/FST/FstDownload/
@@ -11,7 +12,7 @@ COMMENT= Library for working with weighted finite-state transducers (FSTs)
LICENSE= APACHE20
-USES= compiler:c++11-lib libtool python:2
+USES= compiler:c++11-lib libtool python:2.7
USE_LDCONFIG= ${LOCALBASE}/lib/fst
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-bin --enable-compact-fsts --enable-compress --enable-const-fsts --enable-far --enable-linear-fsts --enable-lookahead-fsts --enable-mpdt --enable-ngram-fsts --enable-pdt --enable-python --enable-special
diff --git a/math/py-bitmath/Makefile b/math/py-bitmath/Makefile
index 6189312e2857..9ab648b42a26 100644
--- a/math/py-bitmath/Makefile
+++ b/math/py-bitmath/Makefile
@@ -2,6 +2,7 @@
PORTNAME= bitmath
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +14,7 @@ COMMENT= Represent and manipulate file sizes with different prefix notations
LICENSE= MIT
-USES= python:2
+USES= python:2.7
USE_PYTHON= autoplist distutils
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-4
diff --git a/math/py-ffc/Makefile b/math/py-ffc/Makefile
index 3ea812c2e3c1..1f5d7a64a66d 100644
--- a/math/py-ffc/Makefile
+++ b/math/py-ffc/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ffc
PORTVERSION= ${MMVERSION}.0
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= https://launchpad.net/${PORTNAME}/${MMVERSION}.x/${PORTVERSION}/+download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +12,7 @@ COMMENT= C++ code generator for multilinear forms
LICENSE= LGPL3
-USES= python:2
+USES= python:2.7
USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= FFC
diff --git a/math/py-fiat/Makefile b/math/py-fiat/Makefile
index 0accbd16b493..66e3aa37e314 100644
--- a/math/py-fiat/Makefile
+++ b/math/py-fiat/Makefile
@@ -2,7 +2,7 @@
PORTNAME= fiat
PORTVERSION= ${MMVERSION}.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math python
MASTER_SITES= https://launchpad.net/${PORTNAME}/${MMVERSION}.x/release-${MMVERSION}/+download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +16,7 @@ LICENSE= LGPL3
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scientific>=0:math/py-scientific@${FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= python:2
+USES= python:2.7
USE_PYTHON= distutils autoplist
MMVERSION= 1.1
diff --git a/math/py-fpconst/Makefile b/math/py-fpconst/Makefile
index 208e69f0033e..ef1172fd5d9b 100644
--- a/math/py-fpconst/Makefile
+++ b/math/py-fpconst/Makefile
@@ -3,6 +3,7 @@
PORTNAME= fpconst
PORTVERSION= 0.7.2
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,7 +11,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Utilities for handling IEEE 754 floating point special values
-USES= python:2
+USES= python:2.7
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/math/py-gato/Makefile b/math/py-gato/Makefile
index 65546ec16d74..de3eefe50f2e 100644
--- a/math/py-gato/Makefile
+++ b/math/py-gato/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gato
PORTVERSION= 1.2.2
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${FLAVOR}
NO_ARCH= yes
PORTEXAMPLES= *
-USES= python:2
+USES= python:2.7
USE_PYTHON= autoplist distutils
post-install:
diff --git a/math/py-gmpy2/Makefile b/math/py-gmpy2/Makefile
index 6d59bdb2b690..434cb3a05817 100644
--- a/math/py-gmpy2/Makefile
+++ b/math/py-gmpy2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gmpy2
PORTVERSION= 2.0.8
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +17,7 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libmpc.so:math/mpc \
libmpfr.so:math/mpfr
-USES= python:2 zip
+USES= python:2.7 zip
USE_PYTHON= distutils autoplist
post-install:
diff --git a/math/py-symeig/Makefile b/math/py-symeig/Makefile
index 3dba3d4e63b7..2b6b93975ed7 100644
--- a/math/py-symeig/Makefile
+++ b/math/py-symeig/Makefile
@@ -3,7 +3,7 @@
PORTNAME= symeig
PORTVERSION= 1.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math python
MASTER_SITES= SF/mdp-toolkit/mdp-toolkit/2.4
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +16,7 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS+= ${PYNUMPY}
RUN_DEPENDS+= ${PYNUMPY}
-USES= fortran python:2
+USES= fortran python:2.7
USE_PYTHON= distutils autoplist
LDFLAGS+= -shared
diff --git a/math/py-ufl/Makefile b/math/py-ufl/Makefile
index dc1288f78739..64f8f15e5843 100644
--- a/math/py-ufl/Makefile
+++ b/math/py-ufl/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ufl
PORTVERSION= ${MMVERSION}0
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= https://launchpad.net/${PORTNAME}/${MMVERSION}.x/${MMVERSION}.0/+download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +13,7 @@ COMMENT= Unified Form Language for finite element discretizations
LICENSE= LGPL3
-USES= python:2
+USES= python:2.7
USE_PYTHON= distutils autoplist
MMVERSION= 1.2
diff --git a/math/py-viper/Makefile b/math/py-viper/Makefile
index 0aae61cb1e97..a5373990862a 100644
--- a/math/py-viper/Makefile
+++ b/math/py-viper/Makefile
@@ -2,6 +2,7 @@
PORTNAME= viper
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= https://launchpad.net/fenics-${PORTNAME}/${MMVERSION}.x/${PORTVERSION}/+download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +12,7 @@ COMMENT= Minimalistic scientific plotter and visualization module
LICENSE= LGPL3
-USES= python:2
+USES= python:2.7
USE_PYTHON= distutils autoplist
post-patch:
diff --git a/math/saga/Makefile b/math/saga/Makefile
index 469bee427368..9a0484e95079 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -3,7 +3,7 @@
PORTNAME= saga
PORTVERSION= 6.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]\.[[:digit:]]*$//}/SAGA%20-%20${PORTVERSION}
@@ -29,7 +29,7 @@ LIB_DEPENDS= libfftw3.so:math/fftw3 \
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= autoreconf compiler:gcc-c++11-lib desktop-file-utils dos2unix \
- iconv:wchar_t libtool localbase pkgconfig python:2
+ iconv:wchar_t libtool localbase pkgconfig python:2.7
USE_LDCONFIG= yes
USE_CXXSTD= c++11
USE_WX= 3.0+
diff --git a/math/ufc/Makefile b/math/ufc/Makefile
index a7d47e060ba3..00b9a32154ae 100644
--- a/math/ufc/Makefile
+++ b/math/ufc/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ufc
PORTVERSION= ${MMVERSION}.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= math python
MASTER_SITES= http://launchpad.net/${PORTNAME}/${MMVERSION}.x/${PORTVERSION}/+download/
@@ -14,7 +14,7 @@ LIB_DEPENDS= libboost_math_c99.so:devel/boost-libs
# LICENSE= public domain
-USES= cmake python:2
+USES= cmake python:2.7
CMAKE_ARGS+= -DUFC_PKGCONFIG_DIR=${PREFIX}/libdata/pkgconfig