aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-05-17 08:43:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-05-17 08:43:49 +0000
commit0375af94115b9301cac82a493acfb15d38c88e9b (patch)
tree30befa9ad4a9c2e20b2a11f4e832c00b45448fe3 /math
parent4dca328334c85590f7594357a69a039716104b99 (diff)
downloadports-0375af94115b9301cac82a493acfb15d38c88e9b.tar.gz
ports-0375af94115b9301cac82a493acfb15d38c88e9b.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/xtensor/Makefile4
-rw-r--r--math/xtensor/distinfo10
-rw-r--r--math/xtensor/files/patch-CMakeLists.txt12
-rw-r--r--math/xtensor/pkg-plist4
4 files changed, 15 insertions, 15 deletions
diff --git a/math/xtensor/Makefile b/math/xtensor/Makefile
index 34fa05c8e1a3..363de4bc15bc 100644
--- a/math/xtensor/Makefile
+++ b/math/xtensor/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xtensor
-DISTVERSION= 0.15.9
+DISTVERSION= 0.16.0
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -15,7 +15,7 @@ TEST_DEPENDS= googletest>0:devel/googletest
USES= cmake
USE_GITHUB= yes
GH_ACCOUNT= QuantStack
-GH_TUPLE= QuantStack:xtl:0.4.4:xtl/xtl
+GH_TUPLE= QuantStack:xtl:0.4.9:xtl/xtl
NO_BUILD= yes
NO_ARCH= yes
diff --git a/math/xtensor/distinfo b/math/xtensor/distinfo
index 7e906d6ecdf6..3c78c01515b2 100644
--- a/math/xtensor/distinfo
+++ b/math/xtensor/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1523524334
-SHA256 (QuantStack-xtensor-0.15.9_GH0.tar.gz) = 2a2386f526c3c5fdfeda43515c68e503ff237e55cdb5c6f43db0161e2ee19a56
-SIZE (QuantStack-xtensor-0.15.9_GH0.tar.gz) = 729185
-SHA256 (QuantStack-xtl-0.4.4_GH0.tar.gz) = 2e24ae1e990b36c21134ee8b2017e4d8f1aa760ba0e62e57c9de8f6339052f7f
-SIZE (QuantStack-xtl-0.4.4_GH0.tar.gz) = 80592
+TIMESTAMP = 1526545877
+SHA256 (QuantStack-xtensor-0.16.0_GH0.tar.gz) = 2ea01524e12da84137e099f497ab7fc2a98e2aaec49011b3ccf5849e225fba2a
+SIZE (QuantStack-xtensor-0.16.0_GH0.tar.gz) = 745524
+SHA256 (QuantStack-xtl-0.4.9_GH0.tar.gz) = 587251bb7787b7dd05a2d432712bb2a7f05411155c61a9bc4a0f69c7b4e85dc3
+SIZE (QuantStack-xtl-0.4.9_GH0.tar.gz) = 81044
diff --git a/math/xtensor/files/patch-CMakeLists.txt b/math/xtensor/files/patch-CMakeLists.txt
index efb712341035..e4c09cbfc6d2 100644
--- a/math/xtensor/files/patch-CMakeLists.txt
+++ b/math/xtensor/files/patch-CMakeLists.txt
@@ -1,14 +1,14 @@
---- CMakeLists.txt.orig 2018-03-13 17:28:19 UTC
+--- CMakeLists.txt.orig 2018-05-16 08:49:00 UTC
+++ CMakeLists.txt
-@@ -28,8 +28,9 @@ message(STATUS "Building xtensor v${${PR
+@@ -28,9 +28,9 @@ message(STATUS "Building xtensor v${${PR
# Dependencies
# ============
-find_package(xtl 0.4.1 REQUIRED)
--message(STATUS "Found xtl: ${xtl_INCLUDE_DIRS}/xtl")
+#find_package(xtl 0.4.1 REQUIRED)
+
+-message(STATUS "Found xtl: ${xtl_INCLUDE_DIRS}/xtl")
+message(STATUS "Found xtl: xtl/include")
-+
- # Build
- # =====
+ find_package(nlohmann_json 3.1.1)
+
diff --git a/math/xtensor/pkg-plist b/math/xtensor/pkg-plist
index ec0ec683bfa7..3d9a4f379461 100644
--- a/math/xtensor/pkg-plist
+++ b/math/xtensor/pkg-plist
@@ -22,6 +22,7 @@ include/xtensor/xinfo.hpp
include/xtensor/xio.hpp
include/xtensor/xiterable.hpp
include/xtensor/xiterator.hpp
+include/xtensor/xjson.hpp
include/xtensor/xlayout.hpp
include/xtensor/xmath.hpp
include/xtensor/xnoalias.hpp
@@ -55,13 +56,12 @@ include/xtl/xbase64.hpp
include/xtl/xbasic_fixed_string.hpp
include/xtl/xclosure.hpp
include/xtl/xcomplex.hpp
-include/xtl/xcrtp.hpp
include/xtl/xdynamic_bitset.hpp
include/xtl/xfunctional.hpp
include/xtl/xhash.hpp
include/xtl/xhierarchy_generator.hpp
-include/xtl/xholder.hpp
include/xtl/xiterator_base.hpp
+include/xtl/xjson.hpp
include/xtl/xmeta_utils.hpp
include/xtl/xoptional.hpp
include/xtl/xoptional_sequence.hpp