aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>1994-11-17 15:25:27 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>1994-11-17 15:25:27 +0000
commit9edf34decf5be17b2fc30b84ba908f21275c0ee2 (patch)
tree932540f354ac62f92b7b0e327e523d9dbc80d2e8 /math
parente0ca3fc42af35e0341545567a83057d1de91d9f1 (diff)
downloadports-9edf34decf5be17b2fc30b84ba908f21275c0ee2.tar.gz
ports-9edf34decf5be17b2fc30b84ba908f21275c0ee2.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/fudgit/Makefile12
-rw-r--r--math/fudgit/files/patch-aa35
-rw-r--r--math/fudgit/pkg-comment1
-rw-r--r--math/fudgit/pkg-descr48
-rw-r--r--math/fudgit/pkg-plist18
-rw-r--r--math/fudgit/scripts/configure16
6 files changed, 130 insertions, 0 deletions
diff --git a/math/fudgit/Makefile b/math/fudgit/Makefile
new file mode 100644
index 000000000000..5ad7aa5b6fe5
--- /dev/null
+++ b/math/fudgit/Makefile
@@ -0,0 +1,12 @@
+DISTNAME= Fudgit_2.41
+DISTFILES= fudgit_2.41.tar.gz
+MASTER_SITES= ftp://ftp.physics.mcgill.ca/pub/Fudgit/
+USE_GMAKE= yes
+
+pre-install:
+ @mkdir -p ${PREFIX}/bin
+ @mkdir -p ${PREFIX}/lib/fudgit
+ @mkdir -p ${PREFIX}/man/man1
+ @(cd ${WRKSRC}/examples; cp * ${PREFIX}/lib/fudgit)
+
+.include <bsd.port.mk>
diff --git a/math/fudgit/files/patch-aa b/math/fudgit/files/patch-aa
new file mode 100644
index 000000000000..1770eb212a6f
--- /dev/null
+++ b/math/fudgit/files/patch-aa
@@ -0,0 +1,35 @@
+*** Makefile.in.orig Wed Nov 9 17:20:09 1994
+--- Makefile.in Sat Nov 12 02:58:47 1994
+***************
+*** 89,94 ****
+--- 89,105 ----
+ @ endif
+ CHECK = @echo "Building FUDGIT for datagen..."
+ @ endif
++ @ comment ==================================================== 386bsd
++ @ if freebsd
++ # This Makefile was generated for freebsd
++ OPTIONS = -DNOTRUNC -DNOMALLINFO -DVOID_SIGHANDLER -DWAIT3_INT \
++ -DNOMALLOC_H -DHAVE_UNISTD_H -DHAVE_STDLIB_H
++ CFLAGS = $(OPTIONS) $(DLOPTIONS) -pipe -O2 -fomit-frame-pointer
++ LDFLAGS = -L../libs $(DLLIB) $(DLDLIB) -lreadline -ltermcap -lm
++ LLFLAGS = -ll
++ CC = cc
++ CHECK = @echo "Building FUDGIT for freebsd..."
++ @ endif
+ @ comment ==================================================== hpux
+ @ if hpux
+ # This Makefile was generated for HPUX
+***************
+*** 311,315 ****
+ cp docs/fudgit.help $(LIBDIR)
+ chmod 444 $(LIBDIR)/fudgit.help
+ cp docs/fudgit.1 $(MANDIR)
+! chmod 444 $(LIBDIR)/fudgit.1
+
+--- 322,326 ----
+ cp docs/fudgit.help $(LIBDIR)
+ chmod 444 $(LIBDIR)/fudgit.help
+ cp docs/fudgit.1 $(MANDIR)
+! chmod 444 $(MANDIR)/fudgit.1
+
diff --git a/math/fudgit/pkg-comment b/math/fudgit/pkg-comment
new file mode 100644
index 000000000000..1b6257ae6e5e
--- /dev/null
+++ b/math/fudgit/pkg-comment
@@ -0,0 +1 @@
+fudgit - double-precision multi-purpose data-processing and fitting program
diff --git a/math/fudgit/pkg-descr b/math/fudgit/pkg-descr
new file mode 100644
index 000000000000..13e1067ecf84
--- /dev/null
+++ b/math/fudgit/pkg-descr
@@ -0,0 +1,48 @@
+FUDGIT is a double-precision multi-purpose fitting program.
+It can manipulate complete columns of numbers in the form
+of vector arithmetic. FUDGIT is also an expression language
+interpreter understanding most of C grammar except pointers.
+Morever, FUDGIT is a front end for any plotting program supporting
+commands from stdin. It is a nice mathematical complement to
+GNUPLOT, for example.
+
+The main features of FUDGIT are:
+ - Command shell including history;
+ - Possible abbreviation of all the ``fitting mode'' commands;
+ - Possible plural when it makes sense too;
+ - Interactive shell supporting flow control (while,
+ if-else-endif, foreach);
+ - User definable macros;
+ - User definable aliases;
+ - On-line help;
+ - On-line loadable procedure- or function-objects;
+ - On-line selectable plotting program;
+ - Fourier transforms;
+ - Spline interpolation;
+ - Smoothing;
+ - Double-precision built-in calculator;
+ - Built-in interpreter supporting most of C language including
+ flow control (if, else, while, for, break, continue);
+ - User definable functions and procedures;
+ - Double-precision vector arithmetic;
+ - Access to the complete C math library;
+ - Access to any external C or FORTRAN routines/libraries
+ through dynamic loading;
+ - Built-in fitting series such as:
+ + power series (polynomial);
+ + sine series;
+ + cosine series;
+ + Legendre polynomials;
+ + series of Gaussians;
+ + series of exponentials;
+ + series of lorentzian;
+ - User definable fitting functions;
+ - Totally dynamical allocation of variables and parameters;
+ - Possible selection of fitting ranges;
+
+FUDGIT has a collection of fitting routines including:
+ - straight line (linear) least squares;
+ - straight line (linear) least absolute deviation;
+ - general linear least squares using QR decomposition;
+ - general linear least squares using singular value decomposition;
+ - nonlinear Marquardt-Levenberg method;
diff --git a/math/fudgit/pkg-plist b/math/fudgit/pkg-plist
new file mode 100644
index 000000000000..7569ed73efce
--- /dev/null
+++ b/math/fudgit/pkg-plist
@@ -0,0 +1,18 @@
+@cd /usr/local
+@owner bin
+@mode 755
+bin/fudgit
+@mode 644
+lib/fudgit/advance.ft
+lib/fudgit/avg.ft
+lib/fudgit/bessel.ft
+lib/fudgit/fac.ft
+lib/fudgit/fft.ft
+lib/fudgit/fib.ft
+lib/fudgit/fib2.ft
+lib/fudgit/fit.ft
+lib/fudgit/fudgitrc
+lib/fudgit/if.ft
+@mode 444
+lib/fudgit/fudgit.help
+man/man1/fudgit.1
diff --git a/math/fudgit/scripts/configure b/math/fudgit/scripts/configure
new file mode 100644
index 000000000000..bce997527a3a
--- /dev/null
+++ b/math/fudgit/scripts/configure
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+cd $WRKSRC || exit 1;
+
+cat >> Makefile << END
+
+BINDIR=$PREFIX/bin
+LIBDIR=$PREFIX/lib/fudgit
+MANDIR=$PREFIX/man/man1
+DLLRL = -Duse-dll-readline
+
+all: freebsd
+
+END
+
+exit 0;